Win10 Install Failure (1 Viewer)

jb282

Portal Member
December 26, 2017
6
0
Aland Islands Aland Islands
Previous long running MP1 install. PC got scrambled so attempting to start over with MP2.

Completely clean install - Win10 Fall creators update.
Local account has administrator privileges.
Install fails when attempting to start services - "account doesn't have necessary permissions". Account is definitely an Administrator.
Have also attempted installer by right-clicking, "Run As Administrator" --- same failure.

Have attached install log. Hints welcome. Otherwise I'll go back to MP1 again.

Thx - j
 

Attachments

Alberto83

Test Group
  • Team MediaPortal
  • August 7, 2012
    336
    108
    Italy Italy
    This might seem a stupid question but... is the windows installer service up and running?
    it seems more a windows problem. check these lines from your log:
    [0438:21F0][2018-02-25T18:55:54]e000: Error 0x80070643: Failed to install MSI package.
    [0438:21F0][2018-02-25T18:55:54]e000: Error 0x80070643: Failed to execute MSI package.
    [1FE0:1ECC][2018-02-25T18:55:54]e000: Error 0x80070643: Failed to configure per-machine MSI package.
     

    jb282

    Portal Member
    December 26, 2017
    6
    0
    Aland Islands Aland Islands
    Verified - Windows Installer and Windows Module Installer services are running.

    This is a completely clean reinstall of Win10 - Fall Creators Update - 1709. Literally nothing else done on the box but format, install Win10, install MP2.

    I'm suspicious it's maybe one of the prerequisites. Will check some of those, but rapidly running out of ideas.
     

    ge2301

    MP2 Design
  • Team MediaPortal
  • January 11, 2014
    6,701
    2,416
    Stuttgart
    Germany Germany
    Country flag
    Verified - Windows Installer and Windows Module Installer services are running.

    This is a completely clean reinstall of Win10 - Fall Creators Update - 1709. Literally nothing else done on the box but format, install Win10, install MP2.

    I'm suspicious it's maybe one of the prerequisites. Will check some of those, but rapidly running out of ideas.
    Can you deactivate windows defender and retry. It’s just an idea. I have same version of Windows and no problems with installation of MP2, but I think i read a similar case somewhere and it was a virus software.
     

    jb282

    Portal Member
    December 26, 2017
    6
    0
    Aland Islands Aland Islands
    Tried deactivating Defender (real time scanning) - no change.
    Have been through the pages of prerequisites (DX, CRT etc).
    Also ran Windows Update Repair Tool, since the reported error code is one of it's: 0x80070643

    No luck.
     

    ge2301

    MP2 Design
  • Team MediaPortal
  • January 11, 2014
    6,701
    2,416
    Stuttgart
    Germany Germany
    Country flag
    Tried deactivating Defender (real time scanning) - no change.
    Have been through the pages of prerequisites (DX, CRT etc).
    Also ran Windows Update Repair Tool, since the reported error code is one of it's: 0x80070643

    No luck.
    hmm, I checked a bit the forum and goggled. It seems most people could only solve it by reinstalling windows again.
    See for example here: [solved] - Install error 0x80070643 on Windows 10 Home (MP2.1)
    Looking to your logs I can see the initial problem here: [0438:21F0][2018-02-25T18:50:27]w363: Could not create system restore point, error: 0x80070422.
    So it seems, that something with perhaps windows update failed and the OS is not able to set a system restore point.
     

    Alberto83

    Test Group
  • Team MediaPortal
  • August 7, 2012
    336
    108
    Italy Italy
    Can you try to create a system restore point manually?
    Go to system properties -> System Protection -> Protection Settings, Disk C, confirm it's on and Create.
    Add a label and create it.

    Does it fail?
    Eventually turn protection off and try installing again.

    EDIT: also, confirm that controlled folder access is off. It shouldn't target programfiles and programdata but it's worth checking.
    Go to windows defender security center -> Virus and threat protection -> virus and threat protection (again) and scroll down till Controlled Folder Access. It's a security feature to limit ransomwares but it's very invasive and can block even system processes and installers.
     
    Last edited:

    jb282

    Portal Member
    December 26, 2017
    6
    0
    Aland Islands Aland Islands
    Since this was a clean install, I just did it again:
    -Clean install from Win10 iso.
    -don't let it install any updates during install
    -make local account
    -turn off Defender (Controlled folder access is already off).
    -Install MP2 -- same failure (at least by eye the log looks the same)

    -Tried making a manual restore point. No difference. Install still fails.

    Happy to try anything else to help the devs out.

    Cheers - j
     

    Alberto83

    Test Group
  • Team MediaPortal
  • August 7, 2012
    336
    108
    Italy Italy
    this is so weird.
    you said .net framework is installed right? from appwiz.cpl?
     

    Timhoh1234

    Portal Pro
    September 29, 2015
    195
    50
    Germany Germany
    Country flag
    you could try to install all the packages manually at first then try to install MP2 again, this helped me once. According to logs non of the required packages was existing before, so they would be installed by MP2. But here is the problem, when the necessary packages are identified (see below) directly the failure happens.

    [1FE0:1ECC][2018-02-25T18:50:27]i201: Planned package: VC2008SP1_x86, state: Absent, default requested:
    [1FE0:1ECC][2018-02-25T18:50:27]i201: Planned package: VC2010_x86, state: Absent, default requested:
    [1FE0:1ECC][2018-02-25T18:50:27]i201: Planned package: VC2013_x86, state: Absent, default requested:
    [1FE0:1ECC][2018-02-25T18:50:27]i201: Planned package: VC2015_x86, state: Absent, default requested:
    [1FE0:1ECC][2018-02-25T18:50:27]i201: Planned package: directx9, state: Absent, default requested:
    [1FE0:1ECC][2018-02-25T18:50:27]i201: Planned package: dokan, state: Absent, default requested:
     
    Last edited:

    Users Who Are Viewing This Thread (Users: 0, Guests: 1)

    OP Similar threads Forum Replies Date
    D [solved] Changed username in Win10, now TV Server config crashes on fresh install Installation, configuration support 1
    rexdog [solved] MP2 Instal failing on WIN10 General 2
    D Fresh Win10 pro install - MP won't start General Support 2
    404 [solved] EPG problem after Win10 'upgrade' General Support 1
    J New computer with win10 and how will i set Mediaportal up ? Newcomers Forum 55
    A Problem Windows 10 64 bit prof. Update auf Version 1903(gelöst) Installationsprobleme? 0
    el Filou Is Windows Media Player still needed on Windows 10 ? MediaPortal 1 Talk 0
    A Operating System Important Win10 Settings for MP Operating System 1
    pur_berger Which TV Card (USB, CI) works with MP2 und Win10? General 6
    P MP2 - V2.1 MP2 computer (client/server) cuts Win10 network communications Older releases 0
    A [solved] Upgraded HTPC. Cannot install MP anymore Installation, configuration support 3
    M Installing Plugins Newcomers Forum 2
    doskabouter Installing mediaportal MediaPortal 1 3
    toricred x64 Bit Installer for 2.2.3 General 2
    F Problems with new install of MP2 Newcomers Forum 3
    C Can't install any extensions - DLL error Installation, configuration support 19
    joecrow 1.25.0 5031: Error on Install. Bugreports 24
    P [solved] MP2 new install, 2 x hdhomerun tuners, client on same PC unable to view TV & recordings Newcomers Forum 8
    M MediaPortal2 TV Config Error on Install (0x80004005) General 7
    ajs [fixed] 5022: Improving the MPE Installer, providing nicer GUI :) MediaPortal 1 42
    Rob Hexenmeister Dependency error on install v2.3.2.0 OnlineVideos 28
    ajs [fixed] 5015: Improving the MP1 installer, providing nicer GUI :) MediaPortal 1 138
    N No TV or EPG on fresh install General 0
    T MediaPortal Extensions Manager Fehlermeldung bei Installation einer Erweiterung Installationsprobleme? 1
    doskabouter [Question] Optional installation of subcomponents in MPE1 Developer Discussions 1
    Similar threads

























    Top Bottom