Windows 10 MP2 Fresh Install with HDHR Extend (1 Viewer)

ArloG

Portal Member
March 20, 2018
21
0
62
Home Country
United States of America United States of America
Country flag
Getting right to the point. Is MP2 going to work with an HDHomerun Extend?
I have MP1 installed on my laptop and EPG Buddy to grab schedules.
Channels scanned for both tuners, mapped and named to my clear qam cable (no epg data injected in the channel streams).
I can watch TV on my laptop using the MP1 native client on it with a good guide...so far so good.
Cant watch TV on my android tab, phone, etc using MP apps (aMPdroid...MPTvScheduler).
My goal is to get a working client on a new Sony Android TV.

MP2 installed on my laptop goes through setup similar to MP1 and EPG Buddy works to grab schedules.
Cant use the native MP2 client to watch TV at all on it.

So. I installed MP2 (Only) on my Windows 10 desktop PC. It's more robust than my laptop.
Setup very similar to MP1. EPG Buddy integrates fine. Test Channels fails (MP1 on laptop works fine).
Any tips? Anyone?
Will MP2 work at all with my tuner?
The end goal is to use Kodi, Plex, or Whatever Will Work to watch TV on my Android TV.
If so. Is there a link to a step by step guide and any prerequisites that have to be done?
And what about not being able to use a simple client at first to watch on a remote device?
Errors like HTTP Error 405 pop up on my Android devices when I try to connect to the server.
And I tried turning off Windows Firewall, Port scanned the default value back to both PC's (which showed open).

I'm "OK" with software and setups. MP1 works OK locally on my laptop. MP2 is a big fail.
Both fail when trying to watch remotely on the server they are installed on.

Help!!
 

ge2301

Lead Design MP2
  • Team MediaPortal
  • January 11, 2014
    7,383
    2,639
    Stuttgart
    Home Country
    Germany Germany
    Country flag
    Please always attach log files when you report a problem, otherwise we can not see what is really happening on your PC.
    Generally all TV tuner supported by MP1 should be also supported by MP2, because same TV engine is used.
     

    Alberto83

    Test Group
  • Team MediaPortal
  • August 7, 2012
    336
    108
    Home Country
    Italy Italy
    Yes, logs would help.

    Also, did you install MePo2 along with MePo1? If so you have to disable the tvservice from old MePo 1 before starting the Mediaportal 2 server service.
    I forgot to disable it once, and I had the same problems with testing channels. they were failing badly.
     

    ArloG

    Portal Member
    March 20, 2018
    21
    0
    62
    Home Country
    United States of America United States of America
    Country flag
    I uninstalled MP1 and 2 from my laptop, rebooted and then installed MP2 client only.
    On my desktop pc I reset it to new. Installed MP2 client and server. Got it all configed. Channels are named and mapped, EPG Buddy up and running and now have a functional TV viewer working on it with channel guides and correct channel mapping.

    The desktop is Cat5e'd to an Asus RT-AC68U router running AsusMerlin firmware. PC is using the default port 554. I.P. is set static.
    Since I'm on my localnet, no router port mapping SHOULD be needed....right? I haven't port scanned the desktop server from my laptop.
    I can browse shared drives/folders both way on the PC's
    My laptop cannot see the server, no TV.
    Desktop MP server service verified working.
    I'm very interested in running through logs to see what's going on.

    Although channel scanning, guide setup, and channel mapping/naming took quite a bit....the server end seems easy enough to configure.
    Yet no streams are viewable on the client PC.

    I appreciate all of the help immensely.
     

    Attachments

    • MediaPortal2-Logs_Laptop.zip
      191 KB · Views: 36
    • MediaPortal2-Logs-Desktop_Server.zip
      215.7 KB · Views: 43

    ArloG

    Portal Member
    March 20, 2018
    21
    0
    62
    Home Country
    United States of America United States of America
    Country flag
    I just shut down the Windows firewall on the server. Now my laptop can connect. Video/audio is a bit glitchy.
    Strange. I was prompted during setup to allow firewall exceptions, yet something is being blocked.
    Before shutting off the firewall I port scanned the server and port 554 was open.
    So, what gives now?
    Any tips?

    Moving on the Kodi and MP/PVR setup on my Sony Android TV to see if I can get her limping along.
     

    Alberto83

    Test Group
  • Team MediaPortal
  • August 7, 2012
    336
    108
    Home Country
    Italy Italy
    There's no connection to the server at all in the logs, or i can't see it.

    Did you connect the client to the server?
    Fire the client, go to settings -> General -> Connectivity -> Home Server.

    Is the home server attached?
     

    ArloG

    Portal Member
    March 20, 2018
    21
    0
    62
    Home Country
    United States of America United States of America
    Country flag
    Since I was able to connect with the laptop running the MP2 client to my desktop server, I'm guessing yes.
    Plex (not currently installed after the Windows reset) simply worked. Never used a DVR app with that. Or any Hdhomerun apps that may work.

    Big bummer. I spent all that time thinking I would be able to get MP2 to stream to an android device, or Kodi on Android.
    Now I see a big Forget About It! Back to MP1?.

    Since Windows update to ver.1709 many people are seeing various firewall and network discovery issues. Some can be solved by setting 2 services to delayed start instead of manual. The firewall is another issue. Applications that install with an add a firewall exception don't necessarily do just that.

    MediaPortal2, being newer, would leave a person thinking it would be better suited to recent tech.
    I'm not so interested in a DVR. Silicondust left out the ability to edit channel names and numbers for those of us with cable channels with no PSIP mpx.
    It will take me some time to install MP1 on my server PC now. Moving my channel scan, channel names, etc files from MP2 to MP1 would save me a few hours.
    Is that possible? File based or is it a database store thing?
    I couldn't even get the Mediaportal app in Android TV Kodi to give a hint that it may work in connecting to my MP2 server PC.
    Being diligent here though.

    Sigh....
     
    Last edited:

    Alberto83

    Test Group
  • Team MediaPortal
  • August 7, 2012
    336
    108
    Home Country
    Italy Italy
    Since I was able to connect with the laptop running the MP2 client to my desktop server, I'm guessing yes.
    I'm sorry if you think it was sarcasm. It really was not, i was just asking because i haven't seen a ServerConnectionManager entry in your logs, and I'm comparing it with mines.
    I provided full guide on how to look at it, so it's not a matter fo guessing, btw.
    @ge2301 is the ServerConnectionManager entry a new logging feature?

    TVServer from MePo 2.1.3 is exactly the same version as v1 version, really.
    It will take me some time to install MP1 on my server PC now. Moving my channel scan, channel names, etc files from MP2 to MP1 would save me a few hours.
    Is that possible?
    You can import/export config from tv server, again, the server is the same.
    Unfortunately i haven't an android phone (or TV), so i can't test it right now, but i would investigate further.
     
    Last edited:

    Users who are viewing this thread

    Similar threads

    Hi. Probably you've done this too early or too much. I needed to install DX9 manually before I could install MP 2.3 on a clean Win 10 20H2 system. Some VC runtime are also needed to be installed manually before the installation finally works...
    Hi. Probably you've done this too early or too much. I needed to install DX9 manually before I could install MP 2.3 on a clean Win...
    Having issues installing MP 2.3 on an HP Probook G6 running Windows 10 20H2 build I had to install all the dependencies DX9 and...
    Replies
    3
    Views
    661
    Having used MP1 since 15 years, these epg related problems occuring after a fresh install stumble me. Needed to change a system hdd and decided it was time for a clean install anyway. Other hardware (C2D, 8 Gb ram, no tv cards - IP only) unchanged. Was running an earlier Win10 version with MP 1.24 which had been updated for years...
    Having used MP1 since 15 years, these epg related problems occuring after a fresh install stumble me. Needed to change a system...
    Having used MP1 since 15 years, these epg related problems occuring after a fresh install stumble me. Needed to change a system...
    Replies
    0
    Views
    272
    MP1 MP2 MP2 DLNA status? DE
    What I meant is that we have a MP2 plugin called UPnP Render that can play media from DLNA servers if I remember correctly. I don't know the current state of the plugin though. That's why MP2 probably never will be certified. ;) Yes, that was also the idea, but it is a big job as all TV's, software etc. seems to not do everything...
    What I meant is that we have a MP2 plugin called UPnP Render that can play media from DLNA servers if I remember correctly. I don't...
    So I'm wondering what the state of play is with MP2 and DLNA functionality? When I started this post, I did see some posts...
    Replies
    10
    Views
    564
    And if you Record you can see the video on the used player? On my Server i also have no video, but the reason for this is, that my Server have no Monitor/TV connected. I only configure it via AnyDesk Remote Control. But a recorded channel have a video when i play it with VLC Player. If i connect a monitor via HDMI then i have a...
    And if you Record you can see the video on the used player? On my Server i also have no video, but the reason for this is, that my...
    I have used MP for years. Recently I used MP2 v 2.2.3 without any problem. After install MP v 2.3 I have no video on TV. I have...
    Replies
    6
    Views
    524
    There is currently only the reimport function, that can be used individually for media items, that were wrongly found or updated. There is no function yet to check, if the nfo content changed, it would take far too much time. But I'd also like a function to generally reimport all media items once again.
    There is currently only the reimport function, that can be used individually for media items, that were wrongly found or updated...
    G'day guys, I am looking forward to trying the next version of MP2 (new skin hopefully soon;)) and after trying previous versions...
    Replies
    7
    Views
    546
    Top Bottom