Operating System Windows 7 keeps muting sound (1 Viewer)

nfox
Country flag

Portal Pro
August 22, 2006
163
24
London
Home Country
United Kingdom United Kingdom
Hello - I'm hoping someone can shed some light on a very annoying problem I keep having with my HTPC.

Since upgrading to Windows 7, about 50% of the times I start up my HTPC I find that I have no sound. On exiting MP it is clear that for some reason the sound has been muted in Windows (the little speaker icon in the system tray has the mute symbol visible). All I have to do is unmute the sound and restart MP and all is good. Obviously I would rather not have to do this, as well as it badly affecting the WAF.

I've tried to work out how and why this might be happening, but the only clue so far is that it seems to occur after the HTPC has started automatically for a recording, although I can't be absolutely certain of this.

So...
Has anyone else had this problem, and if so do you have a solution?
Is this something to do with "Away Mode"?
Is there a way of preventing muting of sound in Windows 7 (I use the TV mute to do this)?

I haven't attached logs as this does not seem to be associated with MP directly, but will do so if someone thinks they might be helpful - just say.

Many thanks - Neil
 

punking

Portal Member
June 21, 2010
22
4
New York
Home Country
United States of America United States of America
I don't have an answer, but to narrow things down a bit. I don't think it has anything to do with the HTPC starting automatically for a recording. I don't have a tuner card and don't use the HTPC for recording, and this happens to me too. It appears to be pretty random.
 

nfox
Country flag

Portal Pro
August 22, 2006
163
24
London
Home Country
United Kingdom United Kingdom
punking - thanks for your reply.

Please note: I have only just located this possible solution and am still testing. I offer absolutely no guarantee that this will work, or that it will not blow up your PC/TV/house/whatever.

Since I'm not the only one with the problem I decided to try and Google this, and may have found something. It seems that it could be an HDMI handshake issue as described here and here.

These threads make reference to an app called MonInfo, which will create a .INF file specifically for your monitor/TV that can be installed and used as follows (also briefly described in the 2nd link above):

Download, install, and run MonInfo. Go to "File"/"Create INF", and save it somewhere local. Start Device Manager, find the entry for "Generic PnP Monitor", r-click and choose "Update Driver Software". Select "Browse my computer for driver software", and then "Let me pick from a list...". Then select "Have Disk", browse to where you saved the .INF file you created with MonInfo, select it and click "Open", "OK", and "Next". At this point Windows will install the new driver.

You will probably get a warning about the driver not being signed etc, but plough (plow) on regardless. Now you should have a driver for your specific monitor/TV installed and, if the threads above are to be believed, all should be OK.

They claim that this should sort a variety of issues regarding HDMI handshake, including black screens, audio pops, etc.

Best of luck to all who try this.

Neil
 

sepp776

MP Donator
  • Premium Supporter
  • January 28, 2008
    147
    6
    Cologne
    Home Country
    Germany Germany
    Hey nfox,

    I had this problem either and I read somewhere that this is related to audio driver problems. Is it possible you have a Realtek _AND_ ATI HDMI driver installed for your onboard sound?

    For me, installing the latest ATI motherboard drivers solved the problem.

    Good luck :)

    Sepp.
     

    mbuzina
    Country flag

    Retired Team Member
  • Premium Supporter
  • April 11, 2005
    2,839
    726
    Germany
    Home Country
    Germany Germany
    It could be the issue with muting sound on Windows coming back from Away mode. Did you enable away mode?

    Background (as I remember):
    Windows Away mode PC is basically on with screen blanked and sound muted. This is for htpc that record in the background even if the user presse "go to sleep".
    When PC goes to real sleep in Away mode and is awoken by the user, sound is unmuted. If the PC wakes by timer the sound stays muted (safety from the windows guys against waking in the middle of the night when the htpc wakes for EPG grab ;) ). Basically it is "by design" (from MS).

    It could be that your htpc does not go to sleep again after a recording.
     

    nfox
    Country flag

    Portal Pro
    August 22, 2006
    163
    24
    London
    Home Country
    United Kingdom United Kingdom
    I do have drivers installed for both the onboard sound on the MoBo (Realtek High Def Audio), and the GPU (AMD High Def Audio Device). I have this because TV/video sound plays on the TV via HDMI and is handled by the GPU, and music is played on external speakers via the MoBos soundcard. I can say that the onboard Realtek device never gets muted, it is only ever the AMD device on the GPU that this happens to. Since I have an Intel CPU there are no AMD MoBo drivers to install. I have CCC 11.4 installed for the GPU as this is the last version no one complained about.

    My PC does return to sleep after a recording, and no, I have not enabled away mode (at least I don't think so). In Power Options/Advanced Settings/Multimedia Settings/When Sharing Media, I have chosen the option to "allow the computer to sleep" and *not* "allow the computer to enter away mode". Is there somewhere else I should be checking?
     

    larsbln

    MP Donator
  • Premium Supporter
  • June 12, 2010
    337
    62
    Germany
    AW: Windows 7 keeps muting sound

    I had that issue once and downloaded a progamm that unmutes windows with a shell script. You can temp. assign a button of your remote to that script.
    Or you can execute that script on resume somehow ...

    Here it is:
    NirCmd - Windows command line tool

    Mute the system volume nircmd.exe mutesysvolume 1
    Unmute the system volume nircmd.exe mutesysvolume 0
    Switch the system volume between the mute and normal state. nircmd.exe mutesysvolume 2
     

    nfox
    Country flag

    Portal Pro
    August 22, 2006
    163
    24
    London
    Home Country
    United Kingdom United Kingdom
    Thanks larsbln, but I'm hoping that will not be necessary. Since applying the fix I mentioned above it has not happened again, so I'm hoping the problem is solved. It's only been a couple of days, of course, so I'm not getting too excited yet. I'm going to give it another five days or so and will report back here with the results. Fingers crossed! Of course, if it hasn't solved the problem your solution might be very useful.:D
     

    corporate_gadfly

    Portal Pro
    May 17, 2011
    396
    136
    Home Country
    Canada Canada
    Re: AW: Windows 7 keeps muting sound

    I had that issue once and downloaded a progamm that unmutes windows with a shell script. You can temp. assign a button of your remote to that script.
    Or you can execute that script on resume somehow ...

    Here it is:
    NirCmd - Windows command line tool

    Mute the system volume nircmd.exe mutesysvolume 1
    Unmute the system volume nircmd.exe mutesysvolume 0
    Switch the system volume between the mute and normal state. nircmd.exe mutesysvolume 2
    Upon wakeup by user sometimes, I would get the red mute icon in the taskbar. I used the technique described in this post (allows you to run a command specifically on resume thru Task Scheduler) to execute NirCmd to unmute the system.

    That takes care of the problem when user resumes the PC.

    On the flip side, when the system is resumed due to a recording (I use ForTheRecord, BTW) and I happen to turn on the AVR and TV to watch other media or TV in real time, I get no sound. Happens every time in such scenario (no sound). I don't see a red mute icon in the taskbar (perhaps because I have NirCmd unmuting the system upon resume) but still no sound.

    I have a feeling that the HDMI handshake is not happening. No matter what I try (I've tried switching inputs on the AVR, turn AVR on/off, turn TV on/off), the sound won't come. In order to not destroy the recording in progress, I have to resort to waiting for the recording to finish and rebooting the HTPC afterwards (drastic). On second thought, unplugging/plugging the HDMI cable would work as well (system is hard to reach from the back though).

    So, in my mind these are two separate issues.
    1. red mute icon after resume (when user resumes)
    2. no sound after system resume (due to recording)

    I will try the moninfo approach when I get home tonight and the HTPC is interruptable. Has anyone tried HdmiYo and knows if it is better?

    Cheers.
     

    corporate_gadfly

    Portal Pro
    May 17, 2011
    396
    136
    Home Country
    Canada Canada
    Re: AW: Windows 7 keeps muting sound

    So, in my mind these are two separate issues.
    1. red mute icon after resume (when user resumes)
    2. no sound after system resume (due to recording)

    I will try the moninfo approach when I get home tonight and the HTPC is interruptable. Has anyone tried HdmiYo and knows if it is better?
    Cheers.
    I am happy to report that my second issue has been solved by the moninfo approach (merged EDID override of TV and AVR). This morning, the HTPC was on already (due to a recording) and when I turned on the AVR and TV, I got a little windows popup on the screen saying something like "you will need a DVI to HDMI connection to get sound". Since I had sound already at this point (and my connection is HDMI already), I ticked the "do not show this message again" and clicked OK. Hopefully that's the end of it.
     

    Users Who Are Viewing This Thread (Users: 0, Guests: 1)

    Top Bottom