[solved] Zufällige Stotterer bei Videowiedergabe und Live-TV (1 Viewer)

morpheus_xx

Lead Dev MP2
  • Team MediaPortal
  • March 24, 2007
    11,390
    6,966
    Germany Germany
    Country flag
    @Owlsroost this thread is about random stuttering during LiveTV playback. The issue seems to be related to TsReader updates between MP 1.15 and 1.16 and also to MP2.1 builds.
    Do you have any idea about possible cause? Would a downgrade to older TsReader version help to narrow down issues?
     

    Owlsroost

    Development Group
  • Team MediaPortal
  • October 28, 2008
    5,539
    5,037
    Cambridge
    United Kingdom United Kingdom
    Country flag
    @Owlsroost this thread is about random stuttering during LiveTV playback. The issue seems to be related to TsReader updates between MP 1.15 and 1.16 and also to MP2.1 builds.
    Do you have any idea about possible cause?
    No. To get any idea, I need some logs (including TsReader.log) from users with the problem.

    Also need to know if this is happening with single-seat systems, or client-server using RTSP, or client-server using UNC paths ?

    Would a downgrade to older TsReader version help to narrow down issues?
    It's an obvious thing to try.

    The changes between 1.15 and 1.16 are significant (including upgrading to new Live555 RTSP libraries and other RTSP-related changes).
     

    Jelmo

    Portal Pro
    September 8, 2007
    711
    55
    Germany Germany
    No. To get any idea, I need some logs (including TsReader.log) from users with the problem.

    Also need to know if this is happening with single-seat systems, or client-server using RTSP, or client-server using UNC paths ?



    It's an obvious thing to try.

    The changes between 1.15 and 1.16 are significant (including upgrading to new Live555 RTSP libraries and other RTSP-related changes).
    Maybe i´m to blind ... but how to use UNC paths like in MP1. As far as I know this is not possible in MP2. Would like to test it, as my MP1 are configured to use UNC.
     

    morpheus_xx

    Lead Dev MP2
  • Team MediaPortal
  • March 24, 2007
    11,390
    6,966
    Germany Germany
    Country flag
    Maybe i´m to blind ... but how to use UNC paths like in MP1. As far as I know this is not possible in MP2. Would like to test it, as my MP1 are configured to use UNC.
    This is currently not possible for timeshift: on single seat the local files are used, for multi-seat clients always the RTSP stream will be used.

    For recording folders we already support UNC configurations, it would be possible to add support for timeshift as well.

    But for now, please provide log files. especially of TsReader, so further investigations can be done.
     

    Palm_Maniac

    MP Donator
  • Premium Supporter
  • June 1, 2005
    1,238
    215
    Gießen, Hessen
    Germany Germany
    Country flag
    Hallo,

    es hat etwas länger gedauert aber ich habe heute mal getestet. Mir ist an meinem Client folgendes aufgefallen: Wenn ich MP2.1 frisch nach dem Systemstart aufrufe und eine Serienfolge in MKV starte, läuft sie wunderbar. Dann habe ich sie beendet und eine weitere gestartet. Jetzt treten die Stotterer stark auf. Beende ich MP2.1 und rufe es neu auf ist alles wieder top. Alles mit LAV V0.69.0-4.

    Probleme gab es um 16:34Uhr und 16:36Uhr. Die Stotterer im Live-TV sind leider so zufällig, dass ich keine genaue Zeitangabe machen kann. Aktuell sind sie kaum aufgetreten. Es kann mit dem Serverneustart zusammenhängen, den ich heute durchgeführt habe. Eventuell läuft es deshalb besser.

    Vor MP2.1 hatte ich MP1.16.0pre laufen mit LAV 0.69. Dort sind diese Stotterer weder im Live-TV noch bei der Video-Wiedergabe aufgetreten. Soviel kann ich noch sagen. Durch die neuen Versionen des TSwriter.ax und Tsreader.ax sind alle Probleme eigentlich Geschichte gewesen, und das auf allen Klienten.
     

    Owlsroost

    Development Group
  • Team MediaPortal
  • October 28, 2008
    5,539
    5,037
    Cambridge
    United Kingdom United Kingdom
    Country flag
    There were problems at 16: 34Uhr and 16: 36Uhr. The stutterer in live TV are unfortunately so happened that I can make no exact time. Currently they are hardly occurred. It may be related with the server restarts, I have done today. Maybe that's why it works better.
    There are Continuity Errors in the (TV Server) TsWriter.log, which would explain the stuttering, e.g.

    Code:
    [2017-03-11 16:38:01,962] [d98d370] [2110] - Recorder:Pid 106 Continuity error... 9 ( prev 7 ) - bad signal?
    [2017-03-11 16:38:07,424] [d98d370] [2110] - Recorder:Pid 106 Continuity error... 6 ( prev 4 ) - bad signal?
    [2017-03-11 16:38:18,491] [d98d370] [2110] - Recorder:Pid 106 Continuity error... 8 ( prev d ) - bad signal?
    [2017-03-11 16:38:25,158] [d98d370] [2110] - Recorder:Pid 106 Continuity error... f ( prev 3 ) - bad signal?
     

    Palm_Maniac

    MP Donator
  • Premium Supporter
  • June 1, 2005
    1,238
    215
    Gießen, Hessen
    Germany Germany
    Country flag
    Die Zeitangaben bezogen sich auf die Wiedergabe der MKV-Dateien, nicht Live-TV. Zur selben Zeit lief aber auf dem 2. Client Fernsehen. Ob es dabei Störungen gab kann ich nicht sagen, mir wurde zumindest nichts mitgeteilt.
     

    vokir

    New Member
    July 25, 2009
    4
    0
    Germany Germany
    Hallo,ist das Problem mit dem stotterenden LiveTV jetzt gelöst? Der Thread ist als solved gekennzeichnet.
    Die letzten beiden Einträge von Palm_Maniac sehen aber nicht so aus?
    Wenn es gelöst wurde, wann kann man mit einer Downloadlösung rechnen, ich würde ungern wieder auf MP1 wechseln wollen.
    Danke für ein kurzes Feedback.
     

    Palm_Maniac

    MP Donator
  • Premium Supporter
  • June 1, 2005
    1,238
    215
    Gießen, Hessen
    Germany Germany
    Country flag
    Nein, ist es nicht, zumindest nicht bei mir. Es wird besser, wenn man eine ältere Version des LAV-Codecs installiert. Am schlimmsten ist es mit der Version 0.69 und die am besten laufende und neuste Version ist die V0.65. Mit dieser treten die Stotterer viel seltener im Live-TV auf und fast garnicht mehr bei der Wiedergabe von Filmen.

    Die Probleme tauchen wohl auch nicht bei jeden auf. Was läuft denn bei dir für eine Grafikkarte im System? Bei mir ist es eine Intel HD4000.
     

    Users Who Are Viewing This Thread (Users: 0, Guests: 1)

    OP Similar threads Forum Replies Date
    T Gesamten Musik-Ordner als Wiedergabeliste anzeigen,speichern, zufällig neu anordnen Musik - CD / MP3 5
    S Ab MP 1.22 Fehlermeldung "abspielen nicht möglich" bei mp4 dateien Video & DVD 0
    T Kurze Tonaussetzter bei Videos und TV Allgemeines Supportforum 1
    G Cover bei Serien Allgemeines Support- und Diskussionsforum 4
    R kein Ton bei TV, Video, Aufnahme, Musik Allgemeines Support- und Diskussionsforum 0
    T MediaPortal Extensions Manager Fehlermeldung bei Installation einer Erweiterung Installationsprobleme? 1
    Volker MP2 Rewind / zurückspulen bei Live TV funktioniert nicht Allgemeines Support- und Diskussionsforum 3
    C Konfliktbehandlung bei überschneidenden Aufnahmen Allgemeines Support- und Diskussionsforum 6
    M.Hulot Warum Blu-ray-Menü nicht anwendbar bei MediaPortal? Allgemeines Supportforum 5
    A [solved] Rechner fährt bei Wiedergabe von Aufnahmen in den Stdby Allgemeines Support- und Diskussionsforum 26
    H MP startet bei Systemstart automatisch Installationsprobleme? 13
    Golf4 [solved] Bei Import und grabben der Medieninhalte - Client ausschalten? Allgemeines Support- und Diskussionsforum 1
    F [solved] Mediaportal (1 oder 2) Installation mit Fehler bei DirectX9.0 unter Windows 10 Allgemeines Support- und Diskussionsforum 10
    R Verbindungsproblem bei MP Extension Manager Installationsprobleme? 2
    H [solved] Problem bei Update auf 1.21 Installationsprobleme? 4
    mrbonsen Probleme bei "Preview" in der TV Config TV / Streaming 13
    joecool70 Server stürzt ab, dunkler Bildschirm bei Clients Allgemeines Support- und Diskussionsforum 92
    N Timeout bei zugriff auf Medien Allgemeines Support- und Diskussionsforum 4
    J TV-Aufnahmen und LiveStream brechen ab bei Beendigung einer Aufnahme TV / Streaming 0
    R Mp2.2 verschiedene (neue) probleme, server nicht gefunden, client stürzt bei tv ab, timeshift... Allgemeines Support- und Diskussionsforum 1
    Patrik-See Win 10 Benutzer bei verschiedenen Clients Betriebssysteme 4
    2 [solved] Auf einem Client bei TV-Programm und Aufzeichnungen schwarzes Bild / Videos laufen TV / Streaming 3
    Y MP 1.20 starke Verzögerung bei der Auswahl (Musik / Video) Allgemeines Supportforum 1
    KlausWirn [solved] FSK Anzeige bei MePo2 Allgemeines Support- und Diskussionsforum 4
    S Tote Download Links bei den Plugins Plugins & Erweiterungen 3
    Similar threads

























    Top Bottom