Fork MediaPortal on GitHub

IR Server Suite - Version 1.4.2 Test Build 3158/3281

Discussion in 'IR Server Suite (IRSS)' started by and-81, January 5, 2008.

Thread Status:
Not open for further replies.
  1. and-81
    • Team MediaPortal

    and-81

    Hello,

    This is the thread for Version 1.0.4.1 of IR Server Suite.

    There is a Preview of Version 1.4.2 available for download here too. If all is well I will release 1.4.2 final shortly. So please let me know if you have any trouble. Thanks.

    Please note that the version numbering scheme is changing between 1.0.4.1 and 1.4.2. The final number in the version will be used for SVN debug test releases.


    Please read CHANGELOG carefully.


    Documentation is no longer included in the releases made on the forum, this is to keep the download size under the forum attachment limit.

    If you'd like to comment on this version or if you find a bug in this version then please reply in this thread. Please provide as much information as you can about any bugs you find including log files (you don't know how much a log file can help me).

    If you have a more general comment then feel free to start a new thread, or if you have a feature request then please add it on the Feature Requests list.

    Please give us feedback regarding this release

    Cheers,

    Attached Files:

    • Like Like x 47
  2. petsa
    • Premium Supporter

    petsa

    Hi Aaron,

    I figured I finally should migrate from MRP and the replacement driver to eHome and IR Server Suite. Following your directions I installed eHome, changed the registry and then installed IR Server Suite, this version. All keys works fine, with one exception, I can not have it learn a single IR macro.

    I use macros to blast to the TV and audio amplifier. It seems to recognize the IR from the foreign remotes but when I blast nothing happens. The LED lblinks but the command is not recognized by the TV or amp. I tried the Debug utility and it reports some different IR sequencies, which seems to be OK. Having said that, I can not have it learn and blast any commands either...

    I've attached all logfiles I could think of. The last thing I did before zipping them was to try and learn another IR but without success. Can you take a look at the last part to see if I have done something wrong?

    Thanks

    /Peter
  3. and-81
    • Team MediaPortal

    and-81 Thread Starter

    Well, I'm sorry to hear that the move was unsuccessful...

    From looking at the log everything looks 100% ok... can you blast to other IR equipment and control it? Maybe your tv is very sensitive and some small change I've made has knocked it slightly out of range of what it will accept.

    I'll hook up my Pronto again and make sure that blaster output is correct for the code provided...

    I'll post back if I find anything, but can you also do a little test for me:

    Open Debug Client and learn a command from a remote control, then blast it back while pointing an IR blaster bug at the receiver (up close) ... the receiver should register the code and you should see the button code come up in debug client... let me know if that works.

    Cheers,
  4. rekenaar
    • Team MediaPortal

    rekenaar

    STB

    My wife gave the order last night that I must re-activate the control of the STB from within MP. We have not used this for the last couple of months.

    I installed this version, but could not get the STB to change channel.
    Uninstalled and install version of 2007-10-02 - worked first time.
    Uninstalled and install version of 2007-12-18 - same problem as with current version.

    Explanation:
    TV Server Config
    tv3 blaster plugin
    stb setup
    using STB: Panasat IRD624DSTV
    test channel 202
    The blasting lights flicker, but the STB does nothing.

    The logs represent the last try (version of 2007-12-18) although the same problem exist with this current version.
  5. petsa
    • Premium Supporter

    petsa

    Hi Aaron,

    Here are the logs from some new tests I did per your suggestion.

    1. I used my Logitech Z-5500 remote to receive a command once, then learn the same command (4184), then blast it a couple of times. No reaction on Logitech nor Debug Client, and finally received the command again.

    2. I used my Video7 TV remote to recieve a command (1119866927), then learn the same command, then blast it a couple of times. No reaction on the Video7 but the Debug Client received another command (17104), and then finnaly reveiced the command again.

    3. I used my MCE remote RC6 to receive a command once (31713), then learn the same command, then blast it once. Now the Debug client receive the same command as when I use the remote directly.

    I've never had any issues with either remote with MRP.

    Cheers

    /Peter

    EDIT: Just a thought... Since the Power on/off (remote event "4104" and "1119866927") are the only two commands I would like it to learn, can I add them manually (instead of learning)?
  6. hirscho

    hirscho

    System Specs
    Hi Aaron

    Thanks for the new release. For me it works reliable with my MCE Remote. There are just two smaller issues.

    1) The MP-Plugins are always installed to the MP default directory. If you use a different path for MP you have to copy them manually.
    2) I mapped the TV_Power button of my MCE remote to the command"standby", but the system always goes into hibernate mode. Logs are included.

    hirscho
  7. shark147

    shark147

    Hi at all,
    I have one problem con "IR Server Suite" when i select GIRDER PlugIn, i recive this message:

    "************** Testo dell'eccezione **************
    System.ApplicationException: Failed to load girder plugin (C:\Program Files\IR Server Suite\IR Server Plugins\Girder Plugin.dll)
    in GirderPlugin.GirderPluginWrapper..ctor(String fileName) in C:\MediaPortal Development\Plugins\IR Server Suite\IR Server Plugins\Girder Plugin\GirderPluginWrapper.cs:riga 448
    in GirderPlugin.Config.buttonFind_Click(Object sender, EventArgs e) in C:\MediaPortal Development\Plugins\IR Server Suite\IR Server Plugins\Girder Plugin\Config.cs:riga 67
    in System.Windows.Forms.Control.OnClick(EventArgs e)
    in System.Windows.Forms.Button.OnClick(EventArgs e)
    in System.Windows.Forms.Button.OnMouseUp(MouseEventArgs mevent)
    in System.Windows.Forms.Control.WmMouseUp(Message& m, MouseButtons button, Int32 clicks)
    in System.Windows.Forms.Control.WndProc(Message& m)
    in System.Windows.Forms.ButtonBase.WndProc(Message& m)
    in System.Windows.Forms.Button.WndProc(Message& m)
    in System.Windows.Forms.Control.ControlNativeWindow.OnMessage(Message& m)
    in System.Windows.Forms.Control.ControlNativeWindow.WndProc(Message& m)
    in System.Windows.Forms.NativeWindow.Callback(IntPtr hWnd, Int32 msg, IntPtr wparam, IntPtr lparam)"

    My Notebook is HP Pavilion DV2555ea with OS Vista Home Premium

    How can I solve this problem?


    Thks...
  8. petsa
    • Premium Supporter

    petsa

    Hi Aaron,

    Still no success with IR Server. I went back to latest version of MRP but have the same problems there, i.e. can not learn any IR commands. Have not tested all previous versions but the one I had working was from June 16th or so.

    Can I learn a command in that old MRP version and then "import" to IR Server? Then I could workaround the learning issue as a short-term solution.

    /Peter
  9. and-81
    • Team MediaPortal

    and-81 Thread Starter

    petsa, rekenaar, and others:

    I've now reproduced the blasting problem you're having and will hopefully have a fix within 24-hours.

    Thanks for the quick and detailed feedback. It helped a lot.

    1. I need to make a change to the installer there, I'll need to find an example nsis script to do that, hopefully the next version will have this in place.

    2. Sounds like the default driver is acting on that button press. There are certain buttons that are automatically handled, that's one of them. To get around this you need to modify your registry as described in the documentation and at the last link in my signature.

    shark147:

    I'll take a look and see what I can do. Did you locate a girder plugin dll before pressing ok?

    Cheers,
  10. petsa
    • Premium Supporter

    petsa

    Thanks Aaron!

    I'd be happy to test it as soon as you have something for us.

    /Peter
Thread Status:
Not open for further replies.

Share This Page

Users Viewing Thread (Users: 0, Guests: 0)

Running the latest version?

V1.9.0 FINAL - released Sept. 2014 
Releasenews | Download
Changelog
 | Requirements
HTPC
Team-MediaPortal
 
About
Contact |  Press
Partners