1.16.0, madvr and bluray 3D .iso (1 Viewer)

ThoW1982

Portal Member
November 6, 2010
30
16
Home Country
United Kingdom United Kingdom
Hi

I have upgraded to 1.16.0 Pre Relase recently and enabled madvr hoping I could play 3D Bluray .iso without a need to use PowerDVD. Although madvr works like it should in 2D, I can't get 3D Bluray .iso to play in 3D - all of them play in 2D via Mediaportal. I have a new 0.69.0 / 0.69.0-2 Nightly (February 14, 2017) LAV filters installed.

I know that with madvr and 0.69.0 / 0.69.0-2 Nightly (February 14, 2017) LAV filters 1.7.10 MPC-HC plays 3D Blurays without any issues. All I did was to rename LAV filters folder in MPC-HC folder (LAV filter included with MPC-HC) to something different and load new LAV filters in MPC-HC as external filters. That's how I got 3D Bluray in MPC-HC working, which makes me think it should now be possible in Mediaportal.

Can you, please, suggest what should I do to play .iso 3D Blurays in Mediaportal 1.16 Pre Relase? Or maybe I'm confused and it's not doable yet?

Thanks.

Update:

There is progress :) I have disabled Bluray Menu in Mediaportal Configuration and now when I play Bluray 3D .iso I get side by side 3D, not frame packed 3D (all my Blurays are 'frame packed') - I need to activate 3D SBS option on my TV to watch it. Is this by design?

When I play 3D .iso in MPC-HC, it plays frame packed 3D and TV switches on automatically to 3D.

Can someone explain this in short, please?

Update 2:

Right...So I managed to almost solve this. I have AMD 280x with 17.2.1 drivers; 2 displays 1-Acer monitor non 3D 2-Samsung 3D TV working in clone mode, both 1080p60. I use Streamedmp skin with 1.16 Pre Release core.dll overlay fix made by Sebastiii from this thread.

In madvr settings under devices->properties if Acer has '3D format' selected as 'none' I get 3D .iso displayed in side by side on my 3D TV instead of frame packed. Madvr '3D format' for Samsung TV is set as 'auto'

If I set '3D format' in Acer to 'auto' or disable Acer display Mediaportal switches to 1080p24 and plays .iso 3D in frame packed mode. All good. But when playback stops Samsung TV switches to 1080p30, not as it should to 1080p60 and the UI is acting weird (laggy).

I have tried multiple things to solve it including using v289 core.dll with Ares skin and can not solve this.
 
Last edited:

Sebastiii

Development Group
  • Team MediaPortal
  • November 12, 2007
    16,576
    10,395
    France
    Home Country
    France France
    Yep hard to tell :(
    did you try to work with MP refresh rate instead of madVR one ?
     

    joecrow

    Test Group
  • Team MediaPortal
  • August 9, 2012
    2,101
    1,470
    Home Country
    Germany Germany
    If I set '3D format' in Acer to 'auto' or disable Acer display Mediaportal switches to 1080p24 and plays .iso 3D in frame packed mode. All good. But when playback stops Samsung TV switches to 1080p30, not as it should to 1080p60 and the UI is acting weird (laggy).

    I have tried multiple things to solve it including using v289 core.dll with Ares skin and can not solve this.

    I was seeing a similar thing when I had an AMD GPU installed, in my case it would stay stuck at 23hz rather than returning to my default of 50hz following 3D playback, also same laggy UI. It was not a problem with MPC-HC or with the old AMD Catalyst drivers. If you can revert your GPU drivers back to the Catalyst version that could confirm it is the same thing. I my case I have fixed it by using a Nvidia GPU but the down side of that is that I can no longer play 3D with PowerDVD15 (just does not work with Nvidia), which for the admittidly rare occaision when I would like to play a 3D disk is a shame.;)
    @Sebastiii Recently tested on my HTPC with my AMD RX 460 and can confirm this is still a problem with v289.:(
     

    ThoW1982

    Portal Member
    November 6, 2010
    30
    16
    Home Country
    United Kingdom United Kingdom
    I did some more madvr tests yesterday, but haven't tried old Catalyst drivers yet.

    1. Internal refresh rate tests - sadly using Mediaportal internal refresh rates did not help at all. I set 60hz as default and after playing 2D (24hz) content Mediaportal did not switch back to 60hz :( and UI was laggy even after playing 2D. Left this disabled as it creates problems with 2D too.

    2. Setting 'Force MP refresh rate (for 3D)' in madvr Mediaportal tweaks solves the issue with 3D for me - Mediaportal switches back to 1080p60 after playback of 3D frame packed .iso stops.
    But it creates disruption (a new problem o_O) after start of both 2D and 3D contents -> all playback starts in windowed mode then switches after few seconds to exclusive (full screen) mode. This happens for both D3D11 and D3D9.

    I have tried to use settings available in madvr->rendering->exclusive mode settings and disable 'delay switch to exclusive mode by 3 seconds' thinking it could solve the new problem, but this doesn't seem to help, actually it's acting weird because I disable that option, switch Mediaportal on, play some content, see no changes - windowed mode first then fullscreen, close Mediaportal, access madvr settings and 'delay switch to exclusive mode by 3 seconds' is enabled again. Puzzled :confused:
     

    Sebastiii

    Development Group
  • Team MediaPortal
  • November 12, 2007
    16,576
    10,395
    France
    Home Country
    France France
    Ok i can't test now and not sure if i will able too (Nvidia card on my side) but the windowed mode is maybe related to recent change to have a proper OSD and video size when starting 4K video etc. (bug discovered from @GeYe )

    About the UI lazzy lol, MP is set to running @24Hz on my side so for me i have adapted my eyes surely lol. In fact i didn't use the option to restore refresh rate lol. But still it seems to be again some timing issue because of C# and C++ releasing instance not done in sync :(
     

    Users who are viewing this thread

    Similar threads

    MP1 MP2 Is 3D TV dead? DE
    This ( Ultra D) looks very promising.:)
    This ( Ultra D) looks very promising.:)
    It is perhaps ironic that with the latest LAV filters, Madvr and MP 1.16 we can now play framepacked 3D from MP without having to...
    Replies
    6
    Views
    2K
    and you may try to repair your sql database Repair SQLite Database - MediaPortal 1 - MediaPortal Wiki it looks corrupt to me
    and you may try to repair your sql database Repair SQLite Database - MediaPortal 1 - MediaPortal Wiki it looks corrupt to me
    Media Portal version: 1.16.0 MP-TVSeries version: 4.3.0.0 LAV Filters: 0.69.0 madVR: 0.91.8 Operating System: Windows 10...
    Replies
    7
    Views
    1K
    MP1 MP2 Help with subtitles DE
    Hi guys, I've a few issues with subtitles and I'd like to have a few suggestions on how to set up things properly (if possible). Current video codecs are: - LAV Video for all formats (except HVEC using Lentoid), with DXVA native decoding - LAV Splitter Source - LAV Audio - MPAR as audio renderer - EVR as video renderer (not enough...
    Hi guys, I've a few issues with subtitles and I'd like to have a few suggestions on how to set up things properly (if possible)...
    Hi guys, I've a few issues with subtitles and I'd like to have a few suggestions on how to set up things properly (if possible)...
    Replies
    0
    Views
    3K
    Hi @el Filou Ok I understand, that not easy :( So for now ReClock is the best :)
    Hi @el Filou Ok I understand, that not easy :( So for now ReClock is the best :)
    Description of Change This branch will permit to have madVR renderer to MP1, thanks to Tourettes for this and Madshi. This branch...
    Replies
    6K
    Views
    584K
    Tried with a custom LAV build from @Sebastiii (0.68.5 git) and got a bit further :) - Works with MPC-HC (no image corruption) as subtitle engine however no subtitle selection for that sample - With DirectVobSub I get the subtitle selection however also the image corruption back So while not perfect at least I can have MPC-HC for...
    Tried with a custom LAV build from @Sebastiii (0.68.5 git) and got a bit further :) - Works with MPC-HC (no image corruption) as...
    Hi, Been trying out some 2160P releases recently and came across an odd issue with HEVC playback, it will run at a reduced...
    Replies
    16
    Views
    4K
    Top Bottom