A guide to stutter free playback with Reclock (1 Viewer)

red5goahead

MP Donator
  • Premium Supporter
  • November 24, 2007
    695
    144
    Italy, North West
    Italy Italy
    yes Thanks RobyF

    I post some image





    First one is on LCD 19" monitor. evr, Reclock the vSynch is on and work

    Second one is through HDMI on a plasma.Reclock the vSynch is on and not do work.
    I've the same jumps pf the red line and confirm there are related to the stuttering.

    No problem with vmr9. work fine also with no reclock vsynch active.

    Before RC1 I've no problem. :D


    I can confirm the problem since RC1 release. I also upgraded to 10.2 catalyst driver, I will try to downgrade to see if it gets better.

    I can also say that if I press shift+1 when I get stutter, I see no frame drops but the red line is not straight but jumps up and down (is straight when I have no stutter).

    If anyone else can confirm the problem I will try to open a specific topic about it.
     

    tourettes

    Retired Team Member
  • Premium Supporter
  • January 7, 2005
    17,301
    4,800
    PS: Of course if I disable the reclock VSynch correction most of times MP start play the multimedia files fine , often with well known stuttering issue. Would be nice if Media Portal developer could be work on and improve the support for reclock.
    Unfortunately we have no clue what ReClock does internally so trying to fix such is impossible.
     

    red5goahead

    MP Donator
  • Premium Supporter
  • November 24, 2007
    695
    144
    Italy, North West
    Italy Italy
    PS: Of course if I disable the reclock VSynch correction most of times MP start play the multimedia files fine , often with well known stuttering issue. Would be nice if Media Portal developer could be work on and improve the support for reclock.
    Unfortunately we have no clue what ReClock does internally so trying to fix such is impossible.
    :D

    Reclock vSynch internal correction normally should be off, I know that. With vmr9 work fine indeed. With Evr not so since early days of MP use I choose to use vsnch correction that work fine until last RC1.

    My choice to use Reclock is related to pal speedup because I've not a plasma with 24P capability.
    MP and Reclock work very well togher to solve the issue in the Pal countries.

    Maybe the answer is in the issue itself : Why vmr9 work fine and evr not?
     

    robyf

    Retired Team Member
  • Premium Supporter
  • June 20, 2005
    1,076
    278
    49
    Bolzano
    Italy Italy
    PS: Of course if I disable the reclock VSynch correction most of times MP start play the multimedia files fine , often with well known stuttering issue. Would be nice if Media Portal developer could be work on and improve the support for reclock.
    Unfortunately we have no clue what ReClock does internally so trying to fix such is impossible.
    Reclock was the only way I can get stutter free playback using vsync correction. I know that under windows 7 there should be no need for it. Infact with last SVN before RC1, I turned it off and had no problem anymore with stuttering (probably due to modifications in EVR renderer). But from RC1 I now have thhe following problem expecially with XVID files (with reclock disabled):

    I start and xvid video file and after about 30 minutes I can see heavy stuttering not caused by framedrops but the red line in shift+1 is not straight but jumps up and down (is straight when I have no stutter).

    Before the SVN mentioned before I was able to fix it using reclock, now with RC1 I'm not able to fix this anymore.

    So the problem should be: stuttering of video files (xvid) after about 30 minutes of playback in mediaportal. Nothing appears in logs.

    Setup:

    ATI 4670
    FULL HD 1080p
    Catalyst 10.2
    Codec video: ffdshow
    Codec Audio: ffdshow

    Using other codecs does not fix the problem (microsoft, xvid).

    I forgot to mention that I've made the tests using xvid 25fps with a 50hz refresh rate configured, so no need for reclock.
     

    Seeco

    Portal Pro
    October 15, 2007
    241
    7
    Linköping
    Sweden Sweden
    I am also seeing a lot of general, random stutter lately, only I'm not using Reclock. Before RC1 I also had no problems with stutter, but now pretty much all material displays it in some form. Some videos are pretty unsmooth all the way through, other play nicely and then do a small skip-back stutter every other minute or so.

    When I look at the Shift-1 curves I am also seeing a big fluctuation of the red curve sometimes, this corresponds to stutter. Something must have changed in the core of MP, nothing else in my setup has changed (well, I have updated SAF codec package, but I don't think it's related).
     

    tourettes

    Retired Team Member
  • Premium Supporter
  • January 7, 2005
    17,301
    4,800
    Jong suggest to disable the custom evr renderer Media Portal vsynch control to let reclock to take control of it. maybe with an setup option .

    this is the forum thread:
    SlySoft Forum - View Single Post - ReClock 1.8.6.6
    :D
    Basicly it means disabling AERO from Windows itself. Most likely ReClock is not able to get rid of the tearing, but who knows worth to try at least. On Windows Vista / 7 MP is always using v-sync from OS itself. Also nothing has changed regarding the v-sync (unless it is 1:2 fps / Hz matching, where EVR renderer tries to do slight correction presentation time based on the v-sync. Something that cannot be turned of).
     

    robyf

    Retired Team Member
  • Premium Supporter
  • June 20, 2005
    1,076
    278
    49
    Bolzano
    Italy Italy
    I am also seeing a lot of general, random stutter lately, only I'm not using Reclock. Before RC1 I also had no problems with stutter, but now pretty much all material displays it in some form. Some videos are pretty unsmooth all the way through, other play nicely and then do a small skip-back stutter every other minute or so.

    When I look at the Shift-1 curves I am also seeing a big fluctuation of the red curve sometimes, this corresponds to stutter. Something must have changed in the core of MP, nothing else in my setup has changed (well, I have updated SAF codec package, but I don't think it's related).
    Have a look at this thread... https://forum.team-mediaportal.com/...g-1080p-50hz-after-about-20-25-minutes-79686/

    If this is your case please post logs and graph.
     

    red5goahead

    MP Donator
  • Premium Supporter
  • November 24, 2007
    695
    144
    Italy, North West
    Italy Italy
    Jong suggest to disable the custom evr renderer Media Portal vsynch control to let reclock to take control of it. maybe with an setup option .

    this is the forum thread:
    SlySoft Forum - View Single Post - ReClock 1.8.6.6
    :D
    Basicly it means disabling AERO from Windows itself. Most likely ReClock is not able to get rid of the tearing, but who knows worth to try at least. On Windows Vista / 7 MP is always using v-sync from OS itself. Also nothing has changed regarding the v-sync (unless it is 1:2 fps / Hz matching, where EVR renderer tries to do slight correction presentation time based on the v-sync. Something that cannot be turned of).
    A good and maybe cheap solution could be let users choose the offical customized renderer or the evr standard one released with the operating system. Jong said Reclock work fine with Aero on and evr standard but not with customized Evr even with other player such as mpc -hc. tourettes you know indeed reclock is the only way to play decently a 24P material on monitor can't support suitable refresh rate. My opinion the issue is rather important for that kind of users.
    :D
     

    tourettes

    Retired Team Member
  • Premium Supporter
  • January 7, 2005
    17,301
    4,800
    Jong suggest to disable the custom evr renderer Media Portal vsynch control to let reclock to take control of it. maybe with an setup option .

    this is the forum thread:
    SlySoft Forum - View Single Post - ReClock 1.8.6.6
    :D
    Basicly it means disabling AERO from Windows itself. Most likely ReClock is not able to get rid of the tearing, but who knows worth to try at least. On Windows Vista / 7 MP is always using v-sync from OS itself. Also nothing has changed regarding the v-sync (unless it is 1:2 fps / Hz matching, where EVR renderer tries to do slight correction presentation time based on the v-sync. Something that cannot be turned of).
    A good and maybe cheap solution could be let users choose the offical customized renderer or the evr standard one released with the operating system.
    Not possible since standard EVR renderer wont support providing texture for MP GUI engine.
     

    Users Who Are Viewing This Thread (Users: 0, Guests: 1)

    OP Similar threads Forum Replies Date
    D Display Day of week in TV Guide? Feature Requests 0
    S Shortcuts MP1 My Recorded & TV Guide General 10
    framug Nouveau plugin XmlTvFR pour récupérer le guide télé français Kazer / ZguideTv (WebEPGfr) 11
    G Movie release date in guide Electronic Program Guide 2
    M [Rejected] Always show full hours in TV Guide Feature Requests 2
    M [fixed] [MP2-831] 12h time format shown in TV Guide with Swedish language settings Submit: Bug Reports 27
    geotwticher TV Guide EPG Grabber for Australia 2020 RIP freepg.tv General 4
    B [solved] MP2.2.3 TV Guide not scrolling with mouse wheel General 2
    R [solved] All Channel 7 stations listed in guide as 1000 Newcomers Forum 4
    T Freeview EPG-Anyone know what channel sends the guide data? Electronic Program Guide 10
    M Guide mapping schedules direct, tvguide, epg buddy How to get correct entry to the correct channel? Electronic Program Guide 0
    G Newb trying MP2, trouble with guide data General 5
    C How do I see the broadcast channel decimal numbers in the guide? General 0
    M [Pending] Fix for Inconsistent date display in TV Guide Submit: code patches (MediaPortal/TV-Server/etc.) 1
    G [solved] Are genres in the guide working properly General 4
    drumrob Inconsistent date display in TV Guide 1.22 Pre Release 15
    HTPCSourcer [Evaluate] MP2-Updates do not remove the GUID of previous installs MediaPortal 2 13
    Rob Hexenmeister Radio Guide descriptions in myradio.xml (screen 30) MediaPortal 1 Skins 3
    N Include both TV and Radio channels together in the guide Feature Requests 2
    doskabouter No guide info added due to a MYSQL deadlock Electronic Program Guide 1
    Patrik-See [solved] MediaPortal 2.2 Fernseher bleibt schwarz nach TV Sender Stop Allgemeines Support- und Diskussionsforum 2
    W Need help getting my TV guide working again General Support 1
    R TV Guide No Episode Info Displayed Electronic Program Guide 5
    ltfearme Feature request: Parental Guide IMDb+ 17
    B [Finished] TV Guide Navigation Button Archive 0
    Similar threads

























    Top Bottom