MP2 - V2.1 - After changing audio device (WASAPI exclusive) MP2 crashed

Discussion in 'Older releases' started by Helios61, January 4, 2017.

Thread Status:
Not open for further replies.
  1. Helios61
    • Team MediaPortal

    Helios61 Retired Team Member

    Joined:
    January 30, 2008
    Messages:
    4,587
    Likes Received:
    584
    Gender:
    Male
    Location:
    NRW
    Ratings:
    +897 / 4
    Home Country:
    Germany Germany
    Show System Specs
    Hi,
    i've noticed, that MP2 crashed to desktop, if you try to play an audiofile after changing WASAPI exclusiv audio device.

    Requirement:
    HDMI connection <-> PC <-> AVR <-> TV

    Steps to reproduce.
    1. Turn on AVR & TV, in my case then TV is audio device in Windows Audio Settings
    2. Configure TV as WASAPI exclusive Audio device in MP2
    3. Play some music (it should work fine)
    4. Stop playback and exit MP2
    5. Turn off TV -> now AVR (Yamaha RX-V679) is audio device with the same audio properities in Windows as LG-TV.
    6. Start MP2 and change Audio device settings to AVR.
    7. Try to playback some musicfiles -> Playback fails and MP2 crashed to desktop with these error messages ->
    snip_20170104160717.png

    Related log entry ->

    Code (Text):
    1.  
    2. [2017-01-04 16:05:46,846] [22416  ] [Thread9  ] [INFO ] - BassLibrary: Loading player add-ins from 'C:\Program Files (x86)\Team MediaPortal\MP2-Client\Plugins\BassLibraries\Plugins'
    3. [2017-01-04 16:05:46,865] [22435  ] [Thread9  ] [INFO ] - BassLibrary: Loaded 16 audio decoders.
    4. [2017-01-04 16:05:47,008] [22579  ] [Thread9  ] [INFO ] - BassLibrary: Stream info: FLAC, 44100Hz, Stereo, 16bit
    5. [2017-01-04 16:05:47,029] [22600  ] [Thread9  ] [INFO ] - BassLibrary: Stream content: PCM
    6. [2017-01-04 16:05:47,029] [22600  ] [Thread9  ] [INFO ] - BassLibrary: Preparing for playback: 'BassAudioFileInputSource: D:\ToDo\John Lee Hooker (1962) - The Big Soul of John Lee Hooker\05. I Love Her.flac'
    7. [2017-01-04 16:05:47,086] [22656  ] [BassPlay ] [INFO ] - BassLibrary: Initializing WASAPI device 'RX-V679 (Intel(R) Display-Audio)' (device no 8)
    8. [2017-01-04 16:05:47,089] [22659  ] [BassPlay ] [INFO ] - BassLibrary: BASS: WASAPI exclusive mode not directly supported for samplerate of 44100 and 2 channels
    9. [2017-01-04 16:05:47,091] [22662  ] [BassPlay ] [ERROR] - Exception in player main thread
    10. System.Reflection.TargetInvocationException: Ein Aufrufziel hat einen Ausnahmefehler verursacht. ---> MediaPortal.Extensions.BassLibraries.BassLibraryException: Error calling function BASS_WASAPI_Init(): BASS_ERROR_DRIVER
    11.    bei MediaPortal.UI.Players.BassPlayer.OutputDevices.WASAPIOutputDevice.SetInputStream(BassStream stream, Boolean passThrough)
    12.    bei MediaPortal.UI.Players.BassPlayer.PlayerComponents.OutputDeviceManager.SetInputStream(BassStream stream, Boolean passThrough)
    13.    bei MediaPortal.UI.Players.BassPlayer.PlayerComponents.PlaybackSession.Initialize(IInputSource inputSource)
    14.    bei MediaPortal.UI.Players.BassPlayer.PlayerComponents.PlaybackSession.Create(Controller controller)
    15.    bei MediaPortal.UI.Players.BassPlayer.PlayerComponents.PlaybackProcessor.MoveToNextInputSource_Sync()
    16.    --- Ende der internen Ausnahmestapelüberwachung ---
    17.    bei System.RuntimeMethodHandle.InvokeMethod(Object target, Object[] arguments, Signature sig, Boolean constructor)
    18.    bei System.Reflection.RuntimeMethodInfo.UnsafeInvokeInternal(Object obj, Object[] parameters, Object[] arguments)
    19.    bei System.Delegate.DynamicInvokeImpl(Object[] args)
    20.    bei MediaPortal.UI.Players.BassPlayer.Controller.PlayerThreadMain()
    It is possible to configure a DS Sound device and playback music, but changing the WASAPI device isn't possible here.



    Bet regards
    Helios
     
    Last edited: January 4, 2017
  2. Google AdSense Guest Advertisement



    to hide all adverts.
  3. Helios61
    • Team MediaPortal

    Helios61 Retired Team Member

    Joined:
    January 30, 2008
    Messages:
    4,587
    Likes Received:
    584
    Gender:
    Male
    Location:
    NRW
    Ratings:
    +897 / 4
    Home Country:
    Germany Germany
    Show System Specs
    Unfortunately it is impossible now to change WASAPI daudio device. I have to reinstall MP2 completely :confused::confused:
     
  4. HTPCSourcer
    • Team MediaPortal
    • Administrator

    HTPCSourcer MP2 Product Manager

    Joined:
    May 16, 2008
    Messages:
    10,505
    Likes Received:
    1,105
    Gender:
    Male
    Ratings:
    +2,372 / 21
    Home Country:
    Germany Germany
    Show System Specs
    Is this still happening now that you have reinstalled?
     
  5. Helios61
    • Team MediaPortal

    Helios61 Retired Team Member

    Joined:
    January 30, 2008
    Messages:
    4,587
    Likes Received:
    584
    Gender:
    Male
    Location:
    NRW
    Ratings:
    +897 / 4
    Home Country:
    Germany Germany
    Show System Specs
    Yes it is :confused::(. Everytime after chnging the WASAPI audio device i have to reinstall.
     
  6. Lehmden
    • Team MediaPortal

    Lehmden Retired Team Member

    Joined:
    December 17, 2010
    Messages:
    11,755
    Likes Received:
    2,142
    Gender:
    Male
    Location:
    Lehmden
    Ratings:
    +3,597 / 28
    Home Country:
    Germany Germany
    Show System Specs
    Hi.
    I can not confirm this. Tried it on both clients (Asrock H97M-Pro4 with Intel i5 4590 and Asrock q1900 itx with Intel J1900) without any crashes or other issues. So it looks as if it is something specific to your environment. Maybe another program using WASAPI too is causing this. I don't have any other audio software excerpt for MediaMonkey and mp3tag (both on the "big" system only) installed. And afaik both are NOT using WASAPI. But it's just a guess.
    Your error messages are two different things. The log is telling about an exception in BASS player and the popups are telling about not working logging function.

    Also it may be hard, but a clean Windows install with MP2 only could be very useful to track this down.
     
  7. HTPCSourcer
    • Team MediaPortal
    • Administrator

    HTPCSourcer MP2 Product Manager

    Joined:
    May 16, 2008
    Messages:
    10,505
    Likes Received:
    1,105
    Gender:
    Male
    Ratings:
    +2,372 / 21
    Home Country:
    Germany Germany
    Show System Specs
    Thanks. I have not been able to reproduce the problem at my side either.

    Helios could consider installing a VM (VMWare is free). A Windows 7 installation will not be activated but functional for 30 days, so enough to test.
     
  8. Helios61
    • Team MediaPortal

    Helios61 Retired Team Member

    Joined:
    January 30, 2008
    Messages:
    4,587
    Likes Received:
    584
    Gender:
    Male
    Location:
    NRW
    Ratings:
    +897 / 4
    Home Country:
    Germany Germany
    Show System Specs
    I will never do a complete clean install of Win10 for MP2 testing. MP2 is for the moment complete useless for me. Changing Audo devices is no problem in all other software, i use (MP1, MusicBee, Foobar2000). There are a lot of issues in musicpart have to be fixxed, not my Windows installation.
     
  9. Lehmden
    • Team MediaPortal

    Lehmden Retired Team Member

    Joined:
    December 17, 2010
    Messages:
    11,755
    Likes Received:
    2,142
    Gender:
    Male
    Location:
    Lehmden
    Ratings:
    +3,597 / 28
    Home Country:
    Germany Germany
    Show System Specs
    As you are the only one with this issue I've heard from (up to now) it must be something with your system that is causing this. Maybe someone else will report similar in future but up to then we can not fix this as we don't know where it comes from and if it is caused by MP2 code at all...
    It will take you one hour, make an image of your recent installation, install Windows from scratch, install MP 2.1, make a test and write the image back...
     
  10. HTPCSourcer
    • Team MediaPortal
    • Administrator

    HTPCSourcer MP2 Product Manager

    Joined:
    May 16, 2008
    Messages:
    10,505
    Likes Received:
    1,105
    Gender:
    Male
    Ratings:
    +2,372 / 21
    Home Country:
    Germany Germany
    Show System Specs
    @Helios61 , easy.:)

    It's not that we don't believe that you are experiencing problems with Music. I can simply not mark it as bug and add an entry to the Issue Tracker if other test environments are unable to reproduce the problem - there would be nothing to fix for devs.

    As Lehmden is suggesting, we need your help to identify which factors are the root cause of the problem on your system. Ideally you would do this on the same machine.
     
  11. Lehmden
    • Team MediaPortal

    Lehmden Retired Team Member

    Joined:
    December 17, 2010
    Messages:
    11,755
    Likes Received:
    2,142
    Gender:
    Male
    Location:
    Lehmden
    Ratings:
    +3,597 / 28
    Home Country:
    Germany Germany
    Show System Specs
    Oh, I just saw this. I think this is not really as expected... If the AVR is "ON" it should be the HDMI audio device, not the TV. TV only should be the HDMI audio device if AVR is "OFF". At least it is the case on my system and how I understand this in general...
    In your setup the audio signal from PC is send to the TV through the AVR and then is send back to the AVR by ARC. Don't think this is how this was meant. In my setup the audio signal is send from PC to the AVR and I'm done. I even don't know how I can change this (not that I want to change it).
     
Loading...
Thread Status:
Not open for further replies.

Users Viewing Thread (Users: 0, Guests: 0)

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice
  • About The Project

    The vision of the MediaPortal project is to create a free open source media centre application, which supports all advanced media centre functions, and is accessible to all Windows users.

    In reaching this goal we are working every day to make sure our software is one of the best.

             

  • Support MediaPortal!

    The team works very hard to make sure the community is running the best HTPC-software. We give away MediaPortal for free but hosting and software is not for us.

    Care to support our work with a few bucks? We'd really appreciate it!