[Android] aMPdroid 0.8 - Streaming and more (1 Viewer)

Ayindi

Portal Member
December 1, 2011
34
0
AW: Re: AW: [Android] aMPdroid 0.8 - Streaming and more

Ok, I did that and now it seems working, :D. But I can't stream to phone or play on pc the media in shareview.... Also I can't see the files inside folders.
Also, I doesn't show all the files available....
Great that it is working! :)

I have some issues with streaming as well. Currently, I can only get Recordings to work. Havent played with the other options too much, but no luck for me yet. However, since it is still very early stage I think this is more of less expected.

Edit: Now its working with TV streaming. I did not realize that I need to start streaming live TV via the "channels" menu and I have no external player for RTSP streaming. Only thing that does not work for me, yet is streaming Music to my phone.
 

polarie

Retired Team Member
  • Premium Supporter
  • November 20, 2006
    1,252
    152
    47
    Hasloh (near Hamburg)
    Germany Germany

    Evil-Error

    Portal Member
    September 14, 2010
    11
    1
    Germany Germany
    Hi all,

    I'm using aMPdroid 0.8.3...

    I've no crash, but unfortunately I've no channels in each group I've created. I just see the groups themselves.
    Also I see no group "all channels" however the option "hide all channels group" is not activated (but thats not so important for me:p).

    I've checked the connection to all services (GmaWebservice, Tv4Home, WifiRemote) by telnet with success and also with the Test-URLs from the forum.
    I've tried to connect from external (with "no-ip" account and forwarding the ports) and also in local network.
    Both works fine - I get connection!
    Though, if I try to call the channels of my group "Fav" I get this message:

    {"ExceptionType":"Gentle.Common.GentleException","Message":"The columns name, freetoair in table Channel do not exist.","StackTrace":" at Gentle.Common.Check.FailWith(Severity severity, Error error, Exception e, String msg)\u000d\u000a at Gentle.Common.Check.Fail(Exception e, Error error, Object[] args)\u000d\u000a at Gentle.Framework.GentleAnalyzer.UpdateObjectMap(ObjectMap map)\u000d\u000a at Gentle.Framework.ObjectFactory.ConstructMap(PersistenceBroker broker, Type type)\u000d\u000a at Gentle.Framework.ObjectFactory.GetMap(PersistenceBroker broker, Type type)\u000d\u000a at Gentle.Framework.SqlBuilder..ctor(IGentleProvider provider, StatementType stmtType, Type type, LogicalOperator logicalOperator)\u000d\u000a at TvDatabase.TvBusinessLayer.GetTVGuideChannelsForGroup(Int32 groupID)\u000d\u000a at TV4Home.Server.TVEInteractionLibrary.TVEInteraction.GetChannelsBasic(Int32 groupId) in C:\\Users\\T.Lindener\\Documents\\Programming\\TV4Home\\TV4Home\\Server\\TV4Home.Server.TVEInteractionLibrary\\TVEInteraction.cs:line 175\u000d\u000a at SyncInvokeGetChannelsBasic(Object , Object[] , Object[] )\u000d\u000a at System.ServiceModel.Dispatcher.SyncMethodInvoker.Invoke(Object instance, Object[] inputs, Object[]& outputs)\u000d\u000a at System.ServiceModel.Dispatcher.DispatchOperationRuntime.InvokeBegin(MessageRpc& rpc)\u000d\u000a at System.ServiceModel.Dispatcher.ImmutableDispatchRuntime.ProcessMessage5(MessageRpc& rpc)\u000d\u000a at System.ServiceModel.Dispatcher.ImmutableDispatchRuntime.ProcessMessage41(MessageRpc& rpc)\u000d\u000a at System.ServiceModel.Dispatcher.ImmutableDispatchRuntime.ProcessMessage4(MessageRpc& rpc)\u000d\u000a at System.ServiceModel.Dispatcher.ImmutableDispatchRuntime.ProcessMessage31(MessageRpc& rpc)\u000d\u000a at System.ServiceModel.Dispatcher.ImmutableDispatchRuntime.ProcessMessage3(MessageRpc& rpc)\u000d\u000a at System.ServiceModel.Dispatcher.ImmutableDispatchRuntime.ProcessMessage2(MessageRpc& rpc)\u000d\u000a at System.ServiceModel.Dispatcher.ImmutableDispatchRuntime.ProcessMessage11(MessageRpc& rpc)\u000d\u000a at System.ServiceModel.Dispatcher.ImmutableDispatchRuntime.ProcessMessage1(MessageRpc& rpc)\u000d\u000a at System.ServiceModel.Dispatcher.MessageRpc.Process(Boolean isOperationContextSet)"}

    I've no idea what I can do more for testing or how I should adjust my settings in windows, the app or MP :confused:
    I hope, here, somebody can help me with this issue.

    Thanks!

    System:

    aMPdroid 0.8.3

    GmaWebservice - current version from web
    Tv4Home -current version from web
    WifiRemote - current version from web

    Android 2.3.7
    MediaPortal 1.2.2.0
    Windows7 Ult.
    Firewall configured for all needed Ports of services (8017, 4321, 554)
     

    ilovecoffee

    New Member
    January 7, 2012
    3
    0
    Denmark Denmark
    I cannon make ampdroid remote working.
    I am on windows 7 x64 and have followed the setup with no issues.
    Mediaportal and tvserver runs on same machine.

    When troubleshooting:

    eg:
    http://localhost:4321/GmaWebService/...iceDescription
    - returns a windows security login diaglog (username/password) WTF??
    if I enter (admin/admin) I get the correct return.


    http://localhost:4321/TV4Home.Serve...ractionService/json/TestConnectionToTVService
    - same as above...

    Do you have a clue why the security login appears?
     

    loc

    Portal Pro
    May 22, 2010
    70
    13
    Gold Coast
    Australia Australia
    Country flag

    ilovecoffee

    New Member
    January 7, 2012
    3
    0
    Denmark Denmark
    In ampdroid I entered the ip addres of the pc where tvserver is running. I also entered admin / admin as user/pass login into ampdroid . It now connects and I am able to control Mediaportal -
    but
    suddenly I get "you need to authenticate yourself" and the control looses contact to mediaportal. eventually it reconnects and it works briefly before the whole thing repeats itself.

    any idears what could be wrong?
     

    Users Who Are Viewing This Thread (Users: 0, Guests: 1)

    OP Similar threads Forum Replies Date
    ge2301 Android based client for MP2 MediaPortal 2 3
    K MpTvClient: Client for Amazon and Android devices General 2
    K Client für Android und Amazon-Geräte Allgemeines Support- und Diskussionsforum 68
    hanfmaster Dvb-s2 zu android ipad Einsteigerforum 0
    Lehmden Rezension Android TV Box KM8P Barebones/PC-Systeme/Kaufberatung 8
    S rotierende disk in streamed mp Skin Modifikationen 30
    C Streaming/transcoding MP2 vs MP1? General 4
    C Streaming to clients over Wifi. MP1 or MP2? Newcomers Forum 0
    P Streaming MediaPortal 1 Talk 5
    P Streaming to two clients from the same card Newcomers Forum 1
    L Non-PC device streaming... Newcomers Forum 1
    raffe How to add 500+ streams? OnlineVideos 1
    R Heavy pixelation on HD OTA Streams Installation, configuration support 1
    C streaming out UDP instead of RTSP Newcomers Forum 0
    C Recording back to back shows from IPTV streams General Support 8
    T Missing sound in online streaming service (SVTPlay) General Support 3
    H Unable to play stream - again... Television (MyTV frontend and TV-Server) 2
    V Unable to stream : 10 General Support 0
    doskabouter Black screen while watching some iptv streams General Support 2
    II-IRON [solved] MP2 - 2.2 - Es ist kein Player für die Wiedergabe des Medien-Object 'stream 3.0' registriert Allgemeines Support- und Diskussionsforum 16
    amatesi MP2.2pre Client crash while streaming Live TV from remote MP2.2pre Server (both offline) 2.2 Archive 8
    Cowboy [solved] MP1.20 issue with HD audio stream (not all media) watch/edit Videos 6
    K MP2 - V2.1 [MP2-763] Interface configuration for RTSP streaming server lost on every restart Older releases 6
    jmarc Recording IPTV streams General Support 1
    A Unable to play :stream 3 Television (MyTV frontend and TV-Server) 1
    Top Bottom