[Android] aMPdroid - Android MediaPortal Client (2 Viewers)

DieBagger

Retired Team Member
  • Premium Supporter
  • September 11, 2007
    2,516
    1,276
    36
    Austria
    Austria Austria
    Re: Installing aMPdroid - Android MediaPortal Client - I am lost!

    Hi guys,
    sorry for the stupid question, but is there an install guide for aMPdroid and Wifiremote. I have been trying to get this to work for days now. The remote works, but whenever I want to access video, music or TV get something that I should check username and password.

    Username and password of what do I have to put where? PW from Windows for accessing the drives or pw from MP-database. Where do I have to put the username and password. If MP TV is on, in the bottom of remote It shows the correct EPG. I am really lost and would love to use this app. Could somebody please help?
    Your problem isn't WifiRemote, it's GmaWebservice -> GmaWebservice - MediaPortal Wiki

    The default password is admin/admin, you can change it only in the config file in c:\program files (x86)\gmawebservice\config.xml . Since there will be a new (and hopefully much easier) service in the future (mp-extended) there won't be a config tool for gmawebservice. The wiki is open for everyone, so it would be great if other people could add such things (setup guides, etc). That way the developers can do some actual developing work.

    :D
     

    Dandy

    Portal Pro
    June 4, 2007
    93
    0
    59
    Hamburg
    Germany Germany
    AW: [Android] aMPdroid - Android MediaPortal Client

    ok, great thank you.
    Now where do I put the username and password. In the app on my android or in the service that runs on my pc?
    :D
     

    Shakal

    New Member
    September 28, 2011
    1
    0
    43
    Switzerland Switzerland
    Dear all,
    Is it possbile to define which ip address will bind on the server to connect to? :confused: Actually I've multiple (virtual) network cards in my MP server and the wrong ip address is taken.

    Thanks in advance for support.
     

    Dandy

    Portal Pro
    June 4, 2007
    93
    0
    59
    Hamburg
    Germany Germany
    AW: [Android] aMPdroid - Android MediaPortal Client

    H guysi,
    Now with some support I got it to work - basically. Now the problem is:

    I have about 10.000 Artists in the database. If I press Music and then artist it takes about 3-4 minutes to load that list. Every time I leave the list, it has to be reloaded.

    Is there a way to keep the list in local cache on the android, update it if necessary so the list does not have to be reloaded every time. To wait so long for the list is a real burden.
    :(
     

    joystick

    MP Donator
  • Premium Supporter
  • January 26, 2006
    892
    39
    Germany Germany
    AW: [Android] aMPdroid - Android MediaPortal Client

    Hi,
    since I just received my new GalaxyTab 10.1 I setup aMPdroid, but still I am facing some problems.

    1)
    Initially everything seems to work, however, doing the folling steps will break the remote feature and (I think) the connection to the service, for me.
    First, my Setup is client server, the steps are done on a client profile i setup in aMPdroid

    - login to client profile (server is setup for TV, Client is setup for remote and GMAwebservice)
    - choose remote -> remote working
    - choose Video -> Then choose an option, either video or series
    - Start a movie (streaming)
    - stop movie
    - go back to remote -> remote not working
    - go to Videos -> loading continues forever, but nothing is displayed

    This can only be undone by killing the app.

    2) TV streaming for me is very choppy. Most of the time the sound is lagging (I already tried the different settings in Vplayer, but no success) and the picture is juddering, with wifi and usually a very good connection (no problems with wifi MP clients)

    can someone give me a hint? Please also tell me where to gather logs, i did not find a place where they are stored.


    cheers

    joystick
     

    Oxan

    Retired Team Member
  • Premium Supporter
  • August 29, 2009
    1,730
    1,124
    Netherlands Netherlands
    Re: Installing aMPdroid - Android MediaPortal Client - I am lost!

    Hi guys,
    sorry for the stupid question, but is there an install guide for aMPdroid and Wifiremote. I have been trying to get this to work for days now. The remote works, but whenever I want to access video, music or TV get something that I should check username and password.

    Username and password of what do I have to put where? PW from Windows for accessing the drives or pw from MP-database. Where do I have to put the username and password. If MP TV is on, in the bottom of remote It shows the correct EPG. I am really lost and would love to use this app. Could somebody please help?
    Username and password are separate from other usernames and passwords and are defined in the configuration files of GMA and TV4Home. Usually the default (admin & admin) should work.
     

    DieBagger

    Retired Team Member
  • Premium Supporter
  • September 11, 2007
    2,516
    1,276
    36
    Austria
    Austria Austria
    Re: AW: [Android] aMPdroid - Android MediaPortal Client

    H guysi,
    Now with some support I got it to work - basically. Now the problem is:

    I have about 10.000 Artists in the database. If I press Music and then artist it takes about 3-4 minutes to load that list. Every time I leave the list, it has to be reloaded.

    Is there a way to keep the list in local cache on the android, update it if necessary so the list does not have to be reloaded every time. To wait so long for the list is a real burden.
    :(
    I initially implemented local caching, but disabled it because it brings lots of challanges on the table (cache updating). But what you describe shouldn't happen because only x items should be loaded when you open the view (you can change this in the settings (preload items). The next set of items should be loaded when you reach the end of the list.
     

    DieBagger

    Retired Team Member
  • Premium Supporter
  • September 11, 2007
    2,516
    1,276
    36
    Austria
    Austria Austria
    Re: AW: [Android] aMPdroid - Android MediaPortal Client

    Initially everything seems to work, however, doing the folling steps will break the remote feature and (I think) the connection to the service, for me.
    First, my Setup is client server, the steps are done on a client profile i setup in aMPdroid

    - login to client profile (server is setup for TV, Client is setup for remote and GMAwebservice)
    - choose remote -> remote working
    - choose Video -> Then choose an option, either video or series
    - Start a movie (streaming)
    - stop movie
    - go back to remote -> remote not working
    - go to Videos -> loading continues forever, but nothing is displayed

    This can only be undone by killing the app.
    Try to disable the "Automatic Reconnect" option in the settings

    2) TV streaming for me is very choppy. Most of the time the sound is lagging (I already tried the different settings in Vplayer, but no success) and the picture is juddering, with wifi and usually a very good connection (no problems with wifi MP clients)
    There's nothing I can do in this situation because all aMPdroid does is a)start timeshifting and get the rtsp url and b) open vPlayer with the rtsp url.

    It works much better with our own streaming implement if we wouldn't have the issue with many samsung devices... :(
     

    dragonkeyper

    Portal Member
    November 22, 2011
    13
    0
    43
    United States of America United States of America
    First of let me say thanks for a great app. I do have one problem with the app, the app works fine when i first start it. But once my phone goes to sleep, upon waking I can no longer control MP with the phone. I have to terminate my wifi connection then re-connect before it will resume work. Any ideas as to a resolution?:D:D
     

    1graser

    Portal Member
    September 16, 2011
    43
    2
    Germany Germany
    AW: Re: [Android] aMPdroid - Android MediaPortal Client

    First of let me say thanks for a great app. I do have one problem with the app, the app works fine when i first start it. But once my phone goes to sleep, upon waking I can no longer control MP with the phone. I have to terminate my wifi connection then re-connect before it will resume work.
    I have comparable problems here.
    After some time (can't reproduce the problem) my device can not connect to the MP.
    But the problem seems to be in the MP or Wifiremote.
    I can restart Wifi on my mobile device or reboot it - this does not help.
    I need to restart MP - so the remote control will work again (for a while).

    Does someone have an idea how to fix it?
    How can I debug this?

    Thanks for your help,
    1graser
     

    Users Who Are Viewing This Thread (Users: 0, Guests: 1)

    Top Bottom