[Music] Better sound quality with WASAPI (1 Viewer)

SebNYD

MP Donator
  • Premium Supporter
  • December 26, 2008
    48
    2
    France France
    Re : Better sound quality with WASAPI

    Hello,

    Any chance to get WASAPI support in Bass player for MP 1.2 ? :)

    That would really be great to have Bass setting the proper audio configuration (2.0; 5.1; 44.1KHz; 48KHz; 96Khz...) all by itself :)
     

    tourettes

    Retired Team Member
  • Premium Supporter
  • January 7, 2005
    17,301
    4,800
    Re: Re : Better sound quality with WASAPI

    That would really be great to have Bass setting the proper audio configuration (2.0; 5.1; 44.1KHz; 48KHz; 96Khz...) all by itself :)
    Currently the audio is always resampled to 44.1KHz (at least it looks like based on the code). Not so nice if you play something else than CD sourced audio.

    Code:
    Bass.BASS_Init(soundDevice, 44100, BASSInit.BASS_DEVICE_DEFAULT | BASSInit.BASS_DEVICE_LATENCY, IntPtr.Zero)
     

    diablosv

    Portal Member
    November 1, 2008
    47
    5
    Re: Re : Better sound quality with WASAPI

    That would really be great to have Bass setting the proper audio configuration (2.0; 5.1; 44.1KHz; 48KHz; 96Khz...) all by itself :)
    Currently the audio is always resampled to 44.1KHz (at least it looks like based on the code). Not so nice if you play something else than CD sourced audio.

    Code:
    Bass.BASS_Init(soundDevice, 44100, BASSInit.BASS_DEVICE_DEFAULT | BASSInit.BASS_DEVICE_LATENCY, IntPtr.Zero)
    Thats pretty sucky... anyway for music playing I have resorted to quiting media portal and just using foobar with the wasapi plugin !
     

    Ejorne

    Portal Member
    April 20, 2008
    12
    0
    Netherlands Netherlands
    I am using foobar too for playing music with wasapi.

    Unfortunately the foobar plugin no longer seems to work with the recent MP versions.
     

    diablosv

    Portal Member
    November 1, 2008
    47
    5
    It looks like the plugin is beeing removed in version 1.2.0.

    0002922: Foobar External Player does not work - MediaPortal Bugtracker

    0003179: Remove Foobar2000 (external player) plugin - MediaPortal Bugtracker


    Foobar plugin is not part of official MP anymore
    development can be done by community if needed
    Is someone knowing how and willing to update this plugin for use with recent foobar versions?
    A working plugin for Foobar would be nice, but XBMC is a good alternative it supports WASAPI for everything... (Music and Video)
     

    Ejorne

    Portal Member
    April 20, 2008
    12
    0
    Netherlands Netherlands
    It looks like the plugin is beeing removed in version 1.2.0.

    0002922: Foobar External Player does not work - MediaPortal Bugtracker

    0003179: Remove Foobar2000 (external player) plugin - MediaPortal Bugtracker


    Foobar plugin is not part of official MP anymore
    development can be done by community if needed
    Is someone knowing how and willing to update this plugin for use with recent foobar versions?
    A working plugin for Foobar would be nice, but XBMC is a good alternative it supports WASAPI for everything... (Music and Video)
    I have tried xbmc in the past but didn't worked for me because i needed ASIO for my soundcard.
    But since i changed the soundcard i didn't think of using xbmc anymore.

    Now i don't need asio and do need wasapi, so i tried xbmc yesterday...

    up and running. :cool:
    Thanks for the tip.

    /edit:
    And uhh, sorry MP. I will get back to tou when wasapi is there. Or when i buy me an asio soundcard again.
     

    redmist

    Portal Member
    June 10, 2011
    42
    25
    ASIO4ALL should be renamed "ASIO4SOME". Lots of Realtek sound chips don't work with it - especially in Windows 7.

    WASAPI "just works" and it sounds great. I would LOVE to see WASAPI added to Media Portal.
     

    Users Who Are Viewing This Thread (Users: 0, Guests: 1)

    OP Similar threads Forum Replies Date
    B Why is firetv so much better TV-Cards 3
    E Getting ortek mce remote to work better MediaPortal 1 Talk 13
    C MP1 -- 64 bit OS better General Support 2
    M TV Server Preview Window is blank, sounds works Television (MyTV frontend and TV-Server) 3
    S [solved] No sound - MKV file MediaPortal 1 Talk 2
    A [solved] menu sounds General 1
    R Normalise sound volume somehow? Television (MyTV frontend and TV-Server) 5
    cbr954rr [solved] No sound after clean install? General 24
    Y [solved] Sound will only come out of TV and not computer attached speakers General 1
    T Missing sound in online streaming service (SVTPlay) General Support 3
    rexdog unhandled exception error, and, no sound on first TV channel selected - fine afterwards General 2
    M No sound on videos General 8
    joecrow Loss of Navigation Sounds on Resume from Sleep Mp 1.21 General Support 10
    N [Rejected] Include BBC Sounds (radio catch up) in the Online Videos plugin Feature Requests 4
    Glith Sound stops working after first playback 1.21 88
    Cowboy [solved] MP1.20 issue with HD audio stream (not all media) watch/edit Videos 6
    stirlinghart [solved] No Rear Surround Sound inside MP2 General 10
    J amazon plays sound but no video OnlineVideos for MediaPortal 2 0
    H Sound loss & display problems on refresh rate change Watch / Listen Media 21
    R Delay in audio output over HDMI OffTopic 11
    doskabouter Good quality display Displays 0
    Top Bottom