[Music] Better sound quality with WASAPI (1 Viewer)

natal

New Member
December 5, 2007
4
0
ASIO4ALL should be renamed "ASIO4SOME". Lots of Realtek sound chips don't work with it - especially in Windows 7.

WASAPI "just works" and it sounds great. I would LOVE to see WASAPI added to Media Portal.
+1
 

diablosv

Portal Member
November 1, 2008
47
5
I will be eternally greatfull to whoever implements this.... Media Portal is just so useless for music playing on my setup
 

somy

Portal Pro
March 7, 2010
156
4
Denmark
Denmark Denmark
I really hope next version has this function. As it is now, I have to play flac from Foobar2000 ......
 

M. Mulder

New Member
February 23, 2006
4
0
I tried recleck as auiorenderer (WASAPI Exclusive), but that doesn't work for FLAC files.

This (Un4seen Developments - 2MIDI / BASS / MID2XM / MO3 / XM-EXE / XMPlay) is the official webpage of the BASS-player. Can that (extension; BASSWASAPI) be implemented so that there's finally WASAPI support in MP?

I switched to XBMC (ther's WASAPI running out of the box), but their FANART = dramatic bad!

So I wll stick to Mediaportal, but only if there's WASAPI support.

It sounds 'much' (relative) better with audiofiles!
 

jameson_uk

Retired Team Member
  • Premium Supporter
  • January 27, 2005
    7,258
    2,528
    Birmingham
    United Kingdom United Kingdom
    Country flag
    I plan on looking at WASAPI support using BASS player in 1.3.

    Does this not work if you change the player to directshow and install something like madFLAC ? (Possibly using MP audio renderer?)

    My main HTPC setup is on XP so nothing I can test there. Dev machine is win7 but the audio device in there does not seem to work in exclusive mode. I have a new machine on the process of being built and will hopefully be able to get something sorted
     

    redmist

    Portal Member
    June 10, 2011
    42
    25
    With my old $500 receiver, I couldn't tell the difference between bitperfect music and Windows mixer resampled stuff but since I upgraded to a better $2K receiver the difference is noticeable. The high-end sounds slightly "rolled off" when going through the the Windows resampler - even if it's set to resample to 24bit 192kHz.

    I got ASIO4ALL working with the ATI HDMI sound but for some reason it outputs 7.1 even when the output is set to stereo. I tried playing a DTS wav and it was all garbled so ASIO4ALL obviously doesn't do the job for HDMI sound. Foobar WASAPI works fine with the HDMI audio.
     

    Users Who Are Viewing This Thread (Users: 0, Guests: 1)

    OP Similar threads Forum Replies Date
    B Why is firetv so much better TV-Cards 3
    E Getting ortek mce remote to work better MediaPortal 1 Talk 13
    C MP1 -- 64 bit OS better General Support 2
    S [solved] No sound - MKV file MediaPortal 1 Talk 2
    A [solved] menu sounds General 1
    R Normalise sound volume somehow? Television (MyTV frontend and TV-Server) 5
    cbr954rr [solved] No sound after clean install? General 24
    Y [solved] Sound will only come out of TV and not computer attached speakers General 1
    T Missing sound in online streaming service (SVTPlay) General Support 3
    rexdog unhandled exception error, and, no sound on first TV channel selected - fine afterwards General 2
    M No sound on videos General 8
    joecrow Loss of Navigation Sounds on Resume from Sleep Mp 1.21 General Support 10
    N [Rejected] Include BBC Sounds (radio catch up) in the Online Videos plugin Feature Requests 4
    Glith Sound stops working after first playback 1.21 88
    Cowboy [solved] MP1.20 issue with HD audio stream (not all media) watch/edit Videos 6
    stirlinghart [solved] No Rear Surround Sound inside MP2 General 10
    J amazon plays sound but no video OnlineVideos for MediaPortal 2 0
    H Sound loss & display problems on refresh rate change Watch / Listen Media 21
    R Delay in audio output over HDMI OffTopic 11
    doskabouter Good quality display Displays 0
    Top Bottom