Black Screen at end of movie (1 Viewer)

tmacca

MP Donator
  • Premium Supporter
  • June 24, 2008
    76
    1
    Home Country
    United Kingdom United Kingdom
    I have a couple of hundred or so movies (re-authored DVD's, using DVDRebuilder) that are 'movie only'
    I also have several hundred that are full DVD's (eg Menus, extras etc etc)

    When I play a 'full' DVD, at the end of the movie, it returns to the DVD menu
    When I play a 'movie-only' DVD, it just sits on a black screen at the end of the movie, and requires me to press 'stop' in order to get back to MediaPortal.

    Any ideas?



    TV-Server Version: n/a
    MediaPortal Version: 1.0.0 SVN build 21720
    MediaPortal Skin: Indigo 2.5
    Windows Version: Vista 32-bit SP1
    CPU Type: Intel Q6600 2.4GHz
    HDD: Samsung SpinPoint 1TB
    Memory: 4GB
    Motherboard: Asus P5E-VM HDMI
    Video Card: Intel G35 Express
    Video Card Driver: 7.15.10.1451
    Sound Card: Onboard Realtek
    Sound Card AC3: onboard - coax out
    Sound Card Driver:
    1. TV Card: n/a
    1. TV Card Type: n/a
    1. TV Card Driver: n/a
    2. TV Card: n/a
    2. TV Card Type: n/a
    2. TV Card Driver: n/a
    3. TV Card: n/a
    3. TV Card Type: n/a
    3. TV Card Driver: n/a
    4. TV Card: n/a
    4. TV Card Type: n/a
    4. TV Card Driver: n/a
    MPEG2 Video Codec: ffdshow
    MPEG2 Audio Codec: ffdshow
    h.264 Video Codec: coreavc
    Satelite/CableTV Provider: n/a
    HTPC Case: Antec Fusion
    Cooling:
    Power Supply:
    Remote: Logitech Harmony One
    TV: Samsung
    TV - HTPC Connection: HDMI
     

    tmacca

    MP Donator
  • Premium Supporter
  • June 24, 2008
    76
    1
    Home Country
    United Kingdom United Kingdom
    anybody?

    Could somebody please test this on their system to see if they get the same result? It would be very much appreciated
     

    Gangsta

    Portal Member
    February 15, 2009
    8
    0
    Home Country
    Wales Wales
    I Get this too, I was hoping that it would go back to my pictures at the end of the movie, as I dont back up the menus on any of my dvds, just the main movie.

    Any help would be great.

    Thanks
     

    Paranoid Delusion

    Moderation Manager
  • Premium Supporter
  • June 13, 2005
    13,062
    2,978
    Cheshire
    Home Country
    United Kingdom United Kingdom
    We need, what codecs have you tried !!

    And logs, get the error and then use the mediaportal logs collector found in the start menu to collect them (steo 3) and upload using the advanced + feature.
     

    tmacca

    MP Donator
  • Premium Supporter
  • June 24, 2008
    76
    1
    Home Country
    United Kingdom United Kingdom
    Thanks for the responses

    Have just tried using MPC codecs for audio and video with same results

    log files attached
     

    Paranoid Delusion

    Moderation Manager
  • Premium Supporter
  • June 13, 2005
    13,062
    2,978
    Cheshire
    Home Country
    United Kingdom United Kingdom
    You seem to have ffdshow added to post processing, disable and see if the same thing happens.

    Notice you have powerdvd7, select that and its navigator under dvd settings, see if that makes a difference.
     

    tmacca

    MP Donator
  • Premium Supporter
  • June 24, 2008
    76
    1
    Home Country
    United Kingdom United Kingdom
    OK. Here are my findings

    If I enable MPC for both audio and video for DVD's and use Graphedit to check, it outputs perfectly using only those codecs (however, black screen at the end still exists and need to press top to return to MP)

    If I enable ffdshow for both audio and video, the audio is pumped through ffdshow as expected, but the video now goes through powerdvd first and uses ffdshow for post-processing. Not sure why, as I specifically set ffdshow for video, with no mention of PowerDVD, plus I have no post-processing set in MP Config. However, no big deal as black screen still exists at end of movie

    If I enable PowerDVD for audio and video, video is pumped through as expected, but audio now uses ffdshow for post-processing, Again, weird, as I have not enable and post-processing in MP Config. Again, black screen still persists

    so, 2 new questions!

    a. How do I make sure that when I set ffdshow for video, it uses it, rather than PowerDVD with ffdshow post-processing?

    a. How do I make sure that ffdshow post-processing does not occur on audio when selecting PowerDVD for audio codec?

    Plus, I do not think any of the above have any bearing on the 'black screen' issue - not sure it is a codec issue
     

    Paranoid Delusion

    Moderation Manager
  • Premium Supporter
  • June 13, 2005
    13,062
    2,978
    Cheshire
    Home Country
    United Kingdom United Kingdom
    Just ripping a dvd to movie only output to test, all mine are converted to mp4 on hdd.

    Regarding ffdshow, have you enabled raw format under codec settings.
     

    Users who are viewing this thread

    Similar threads

    Hi catavolt, selling this HTPC does not mean that I will no longer be available to the community as a plugin developer. If there are severe problems with the plugins at the moment, I can try to analyze causes and find possible solutions. However, this will currently only have low priority, as I am responsible for employees and...
    Hi catavolt, selling this HTPC does not mean that I will no longer be available to the community as a plugin developer. If there...
    After many years as a MediaPortal supporter and plugin developer I will now have to say goodbye to my beloved HTPC for personal...
    Replies
    2
    Views
    2K
    Many people found the Lentoid decoder better optimised than LAV for software decoding. If you want to try it, download it from the link below, run reg.bat as an admin to install it and change the HEVC Video settings in MediaPortal Configuration/Codecs and Renderer...
    Many people found the Lentoid decoder better optimised than LAV for software decoding. If you want to try it, download it from the...
    For some unknown reason I can't play HEVC encoded video with MP1 on my system. I have tried every trick I know, but nothing works...
    Replies
    10
    Views
    703
    Sorry for the late response. In my experience, the EPG grabbing of a single transponder takes 2 to 3 minutes. Afterwards it takes 1 to 2 minutes to write the data to disk. To speed up the EPG stuff (not only writing but also reading the EPG guide in MediaPortal), I changed the program table (and only that table) from InnoDB to...
    Sorry for the late response. In my experience, the EPG grabbing of a single transponder takes 2 to 3 minutes. Afterwards it takes...
    I get a few "Continuity error..." after the EPG scan finished: [2021-01-30 18:56:10,278] [4c45530] [18c8] - mhw reset [2021-01-30...
    Replies
    2
    Views
    1K
    MP1 MP2 Migrating from WMC DE
    Hi. Network tuners can be shared even on the same PC (done it often while testing different software, I'm using SAT>IP tuner that are similar to hdhomerun tuner but for European DVB). But you can not use them on both systems at the same time ofc.. Means if WMC is using a tuner (e,g, for a scheduled recording) MP can't use the same...
    Hi. Network tuners can be shared even on the same PC (done it often while testing different software, I'm using SAT>IP tuner that...
    I have been running Windows Media Centre happily for years on Win 7 Pro, more recently with EPG123 as an intermediary providing...
    Replies
    43
    Views
    3K
    It is looking and working very well now and I am almost at the point of switching my HTPC to MP2, madvr would definitely push me over the edge for sure.;)
    It is looking and working very well now and I am almost at the point of switching my HTPC to MP2, madvr would definitely push me...
    We are proud to present MediaPortal 2.3 MediaPortal 2.3 is a full-blown media center software that addresses the most common user...
    Replies
    4
    Views
    2K
    Top Bottom