Broken episode thumbnail crashes MediaPortal (2 Viewers)

emphatic

Design Group
  • Team MediaPortal
  • August 25, 2006
    3,602
    1,093
    Alingsås
    Sweden Sweden
    Country flag
    • Thread starter
    • Moderator
    • #1
    Mystery solved:

    If the thumbnail downloaded from thetvdb is broken (can't be viewed), MediaPortal will crash when the plugin tries to display it.

    Original post:

    This is what happens. If you have the 5th episode of the show American Gods, and browse to it in MP TV-Series, I get the "Mediaportal has stopped working" crash. Every release of this episode I've tried seem to do this, so I wonder if it's in the episode description?

    American Gods: Lemon Scented You

    To test, try to rename a random video file to American.Gods.S01E05.mkv and import it.

    Emph
     
    Last edited:

    JimCatMP

    Documentation Group
  • Team MediaPortal
  • April 1, 2010
    648
    281
    Leeds
    United Kingdom United Kingdom
    Country flag
    Hi

    To meet my naming convention - renamed as "05 - American Gods.mkv" - but in all other respects, assume same - runs to completion on import without issue for me.

    Confirmed 'media portal stopped' on playing [1.1.17 PRE]

    Playing in media play however works BUT clear the encoding is off in some respect - open in MPC and go to end and look at credits - off centre and off screen to left - looks to be incorrectly cropped:-<

    Cheers - JCMP
     

    Wishishi

    New Member
    May 17, 2014
    3
    1
    36
    Norway Norway
    Same crash here, with all the different files i can get my hands on. E6 works tho.
    Have to re-encode it or something to make it work?
     

    emphatic

    Design Group
  • Team MediaPortal
  • August 25, 2006
    3,602
    1,093
    Alingsås
    Sweden Sweden
    Country flag
    • Thread starter
    • Moderator
    • #4
    Same crash here, with all the different files i can get my hands on. E6 works tho.
    Have to re-encode it or something to make it work?
    Pretty sure it has nothing to do with the encoding of the video, as I tried renaming a working file to American Gods S01EO5 and it crashes when you select it in the MediaPortal GUI. If you for example enter the American Gods season 1 view and browse down from episode 1 to 5, it won't crash until you've reached episode 5.

    Emph
     

    JimCatMP

    Documentation Group
  • Team MediaPortal
  • April 1, 2010
    648
    281
    Leeds
    United Kingdom United Kingdom
    Country flag
    Found HD version.

    Tested in MePo 'My Videos" - plays AOK, immediate crash if I try with MPTVSeries.

    Out of interest, recoding in Handbreak to MP4 - will post when I have tested and checking S01E06 as well - interesting quirk:)

    Also - remember in my 1st post - I renamed the SRC file to "05 - American Gods" - so beyond bizarre that naming a working file to caused problems as well................... o_O:confused:


    and a bit more.........
    Now really odd - I swapped "02 - America Gods.avi" and "05 - American Gods.mkv", re-imported and behold it is STILL the claimed "05" version that crashed MePo - so clearly NOT the encoding:cool:. Could this be a problem with the TheTVdb.com entry, for me it's the only common entity left :sneaky:

    TTFN - JCMP
     
    Last edited:

    emphatic

    Design Group
  • Team MediaPortal
  • August 25, 2006
    3,602
    1,093
    Alingsås
    Sweden Sweden
    Country flag
    • Thread starter
    • Moderator
    • #10
    Yes, it's not the video file, but appears to be due to the scraped data from thetvdb. My kids are watching Yogi Bear right now, so I can't perform any more tests, but what does the extended information say in the "Mediaportal has stopped working" message?

    Emph
     

    Users Who Are Viewing This Thread (Users: 0, Guests: 2)

    OP Similar threads Forum Replies Date
    C Grabbers broken General Support 24
    Mr6686 [solved] Titan skin broken since update to 1.23 Installation, configuration support 6
    A Help! MP2 - DVB-T Not recognised (DRIVERS?) General 12
    M [solved] IMDB script broken again General Support 67
    G Q about scheduling weekly series when epg lists duplicate back to back episodes each week General Support 2
    cladinshadows85 [solved] TV Recordings episode field blank General 20
    P TV recording not displaying episode titles or going into series General 10
    G MP 1.21 TVserver race condition when cant delete recording triggered by episode management General Support 0
    A cursor.wav or click.wav set in keyboard and keys cause recordings to be set in upcoming episodes 1.20 2
    A "upcoming episodes" arrow key set recording - Ok/rtn doesn't work General Support 9
    R TV Guide No Episode Info Displayed Electronic Program Guide 5
    Alberto83 [no Bug] Watched status not retained when rewatching an episode and stopping. Archive 49
    A Filenaming Season and Episode Numbers not working General Support 1
    B Episodes to Keep and Priority for Schedules in MP2 General 0
    U Parsing invalid episode names My TVSeries 10
    CyberSimian [Bug] 5035: ZoomPixels in a thumbnail list MediaPortal 1 13
    H [solved] Video database genres, sort titles and collection thumbnails Newcomers Forum 12
    G [fixed] No recorded video thumbnails created while recording. 2.2 Archive 2
    F [Solved] Movies View with Thumbnail Layou General Support 4
    J Question about thumbnail decorations MediaPortal 1 Talk 0
    volumia Q: thumbnail creation for Pictures plugin MediaPortal 1 Plugins 3
    A Thumbnails - where are they stored Installation, configuration support 20
    Similar threads






















    Top Bottom