Cannot delete recorded TV (2 Viewers)

dale77

MP Donator
  • Premium Supporter
  • April 14, 2009
    100
    1
    Christchurch
    Home Country
    New Zealand New Zealand
    When I go in to the recorded tv section, if I try to delete a piece of manual recorded TV, I get an error message to the effect that the recording cannot be deleted. tv server error log shows a message "unable to delete because the file is in use by another process".

    This is on a fresh install of MP1.0.1, with the following relevant tweaks:

    1. I have a single dual hybrid tuner (dvb-t/analog)
    2. Applied forum fix for dual analog tuners prior to setup
    3. Ran TV Server setup as adminstrator to avoid bug where you cannot save config after db test
    4. Setup dual tuners into two groups per wiki
    5. Using PowerCinema h.264 codec for HD DVB-T tv

    Is this a permissions issue? Or is some other process really holding onto that recording? The file does appear to exist under c:\ProgramData.

    TV-Server Version: 1.0.1 with dual analog tuner fix
    MediaPortal Version: 1.0.1
    MediaPortal Skin: Blue, no change to fresh install
    Windows Version: Vista 32 SP1 plus all updates
    CPU Type: AMD 4850e X2 2.5GHz
    HDD: WD Green 750G
    Memory: 2x1GB Corsair
    Motherboard: Gigabyte GA-MA78GPM-UD2H
    Video Card: ATI HD3200 onboard
    Video Card Driver: Catalyst 9.4
    Sound Card: ALC889a onboard
    Sound Card AC3: ??
    Sound Card Driver: latest realtek drivers from gigabyte
    1. TV Card: Hauppage HVR 2200
    1. TV Card Type: dual Hybrid DVB-T/analog
    1. TV Card Driver: latest hauppage WHQL from Windows update
    2. TV Card:
    2. TV Card Type:
    2. TV Card Driver:
    3. TV Card:
    3. TV Card Type:
    3. TV Card Driver:
    4. TV Card:
    4. TV Card Type:
    4. TV Card Driver:
    MPEG2 Video Codec: MPC MPEG2 (Gabest)
    MPEG2 Audio Codec: MPC MPA
    h.264 Video Codec: PCM h.264
    Satelite/CableTV Provider: n/a
    HTPC Case: Antec Veris Fusion 2
    Cooling: case 2x 120mm
    Power Supply: 430W case
    Remote: Genius Remote 300 MCE
    TV: Samsung 32 LCD
    TV - HTPC Connection: HDMI
     

    dale77

    MP Donator
  • Premium Supporter
  • April 14, 2009
    100
    1
    Christchurch
    Home Country
    New Zealand New Zealand
    I removed 1.0.1 and reinstalled 1.0.

    Deleting now works.

    Hmmm. Perhaps this is a 1.0.1 bug?
     

    Jeditrav

    Portal Pro
    May 17, 2007
    319
    20
    Home Country
    New Zealand New Zealand
    Did you have your config set to create thumbnails of recordings? I had this turned on and then couldn't delete recordings; turned it off, and could then delete recordings - turning it off wasn't a big issue, because thumbnails wouldn't show up for me anyway. I see you're in NZ too, perhaps it has something to do with our h.264 dvb-t...
     

    dale77

    MP Donator
  • Premium Supporter
  • April 14, 2009
    100
    1
    Christchurch
    Home Country
    New Zealand New Zealand
    Just installed 1.0.2 on the same hardware, a fresh install of Vista 32, SP1, updated to SP2.

    Delete recorded TV fails again. Anyone know the answer to this one? My guess is it is likely permissions related.

    Did you have your config set to create thumbnails of recordings? I had this turned on and then couldn't delete recordings; turned it off, and could then delete recordings - turning it off wasn't a big issue, because thumbnails wouldn't show up for me anyway. I see you're in NZ too, perhaps it has something to do with our h.264 dvb-t...

    Thanks Jeditrav, your workaround enabled me to delete the recordings. It appears that it is something to do with those thumbs.
     

    bart0190

    Portal Pro
    January 17, 2009
    153
    1
    Hi,
    I also had this problem of deleting recorded tv just after watching it.
    After reboot I could delete them.
    However, this is no solution so I switched back to MP 1.0.0 again although 1.0.2 is more stable with the TvService.
    But a 2nd issue (some recorded tv is not playable) let me decide for MP 1.0.0.

    bart
     

    bart0190

    Portal Pro
    January 17, 2009
    153
    1
    I read somewhere else that a upgrade is not so good.
    Just installed MP1.0.2 as "fresh installation" (better?). It remembers everything except foto, video, music folders.

    I will do some testing.

    bart
     

    bart0190

    Portal Pro
    January 17, 2009
    153
    1
    Well, fresh installation of MP1.0.2 but same issues.
    I found out, that the codec is the cause for the deletion problem.
    Using the MPV codec I could delete the recording right away after watching.
    So, I will try PowerDVD9 in the future.

    For the recording issue: I had a script after waking up from standby which just stops and starts TvService to prevent of not-started Service.
    I took out this script, but then I had one recording (out of ca. 10) where TvService did not start. :(
    So now, I just have a script which starts TvService after wake up - did some recordings today. Will see what came out.

    br
    bart
     

    Users who are viewing this thread

    Similar threads

    Sorry for the late response. In my experience, the EPG grabbing of a single transponder takes 2 to 3 minutes. Afterwards it takes 1 to 2 minutes to write the data to disk. To speed up the EPG stuff (not only writing but also reading the EPG guide in MediaPortal), I changed the program table (and only that table) from InnoDB to...
    Sorry for the late response. In my experience, the EPG grabbing of a single transponder takes 2 to 3 minutes. Afterwards it takes...
    I get a few "Continuity error..." after the EPG scan finished: [2021-01-30 18:56:10,278] [4c45530] [18c8] - mhw reset [2021-01-30...
    Replies
    2
    Views
    1K
    I don't think that it is clear that you need to upgrade :eek:. I used WMC for six years, and have been using MP1 for another six years. I migrated from WMC to MP because it offered more of what I wanted, and less of what I didn't want. But if you are comfortable with WMC, the obvious choice is to stay with WMC on Windows 7. The...
    I don't think that it is clear that you need to upgrade :eek:. I used WMC for six years, and have been using MP1 for another six...
    I have been 15 years with WMC in Windows 7 but clearly need to upgrade. I believe that MP might meet my needs. Before I invest a...
    Replies
    4
    Views
    1K
    Have you checked if any anti-virus program could have locked the file so it can't be deleted?
    Have you checked if any anti-virus program could have locked the file so it can't be deleted?
    Before you create this bug report: Make sure that your system (Windows, codecs and drivers) is up to date, matching the...
    Replies
    6
    Views
    896
    Yes I can stop windows updates - but that has yet to give problems - I have disabled automatic lenovo updates for now and will have no problems with it ;-) Its and old Lenovo Thinkcentre desktop using the On borad intel 4600 graphic card så all is good for know :-) thanks again for all your help :-)
    Yes I can stop windows updates - but that has yet to give problems - I have disabled automatic lenovo updates for now and will have...
    I have been using MP 1 for years with no troubles. but in the last couple of days it sudden just crashes when starting live tv...
    Replies
    20
    Views
    3K
    Hello. I'm 28 from Italy and I use Mediaportal to record videos which I then have to process with another software that only recognize recordings with MPEG video and audio tracks. So, as the object of this thread, I would like to change the audio and video codecs for recordings processed with an analog PCI-E Card with HDMI input...
    Hello. I'm 28 from Italy and I use Mediaportal to record videos which I then have to process with another software that only...
    Hello. I'm 28 from Italy and I use Mediaportal to record videos which I then have to process with another software that only...
    Replies
    0
    Views
    725
    Top Bottom