Certain channels cause MP1.16/1.17/1.18/2.1.2 to crash. 1.15 works fine. (1 Viewer)

drumrob

Portal Member
November 28, 2017
14
14
United States of America United States of America
Country flag
Hey MP Team, thanks for the great work, keep it up! I have found MP to be the only reliable replacement since WMC. But I have had this problem which is preventing me from upgrading:

This happens without exception after installation and scanning for Digital Cable channels when previewing with SetupTV or in MP GUI. All channels work fine except for a couple, which will cause SetupTV or MP GUI to freeze and crash when selected for viewing. I get the error message "SetupTV has stopped working" and the options Debug or Close. Always the same channels. I watch these channels often and don't want to do without them. I have tried every combination of settings for the tuner card in SetupTV, rescanned the channels with different timings (in the General section) with no change. In the Ceton diagnostics app, I am able to confirm that the TV card is successfully tuning the affected channel. In MP, the result is always the same with the same channels, 100% repeatable. I have even tried a clean install of Windows, but no change. MP 1.16, 1.17, 1.18 and 2.1.2 have the same problem. When I revert back to 1.15, everything works fine. I am assuming that there was a change in the MP TV Server starting in MP 1.16. All versions before that worked fine (I started with MP 1.12).

I can stick with MP 1.15, of course, but I would like to be able to upgrade at some point.

Any help appreciated.

Win 10 v. 1709 (Fall Creators Update)
Ceton InfiniTV 4 PCIe
Frontier FiOS digital cable
 

Owlsroost

Development Group
  • Team MediaPortal
  • October 28, 2008
    5,538
    5,037
    Cambridge
    United Kingdom United Kingdom
    Country flag
    It looks like (from the Windows app log) that it's TsReader.ax that is causing the crash (but as the logs are from MP2 there is no TsReader.ax log in there that I can find).

    Can you make a short recording (30s to 60s would be fine) of one of the problem channels and upload it somewhere (or attach it here) so that I can download it please?

    (TsReader.ax is used by the TV client, so you should be able to record OK even if playback is crashing).
     

    drumrob

    Portal Member
    November 28, 2017
    14
    14
    United States of America United States of America
    Country flag
    Hmmm... the Forum won't allow me to upload a file with a .ts extension... Anywhere else I could upload or send it to?

    I forgot to mention that timeshifting continues even after MP or SetupTV has crashed.
    Restarting SetupTV while the previous timeshift is still in progress immediately causes SetupTV to crash.
    I have to manually stop TVService in the Services tab of Windows Task Manager to force timeshifting to stop. Then I have to restart TVService in order to relaunch MP or SetupTV.
     
    Last edited:

    drumrob

    Portal Member
    November 28, 2017
    14
    14
    United States of America United States of America
    Country flag
    OK, so I changed the extension to .zip and was able to upload it :D
    It is not a zipped file. Just change the extension from .zip back to .ts
    The recording was made with MP 1.15, though, which I reinstalled before my original post. I can revert back to another version if it would help...
     

    Attachments

    Last edited:

    Owlsroost

    Development Group
  • Team MediaPortal
  • October 28, 2008
    5,538
    5,037
    Cambridge
    United Kingdom United Kingdom
    Country flag
    Thanks for the sample.

    I can reproduce the problem with the sample recording - TsReader,ax is crashing with an 'access violation'. I'll investigate...(although I won't have any time to do it before the weekend).
     
    Last edited:

    drumrob

    Portal Member
    November 28, 2017
    14
    14
    United States of America United States of America
    Country flag
    OK, thanks! Please let me know if you need more info.
     

    Owlsroost

    Development Group
  • Team MediaPortal
  • October 28, 2008
    5,538
    5,037
    Cambridge
    United Kingdom United Kingdom
    Country flag
    I believe I've fixed the bug (it's now working OK with the test recording), so please try the attached TsReader.ax (version 4.2.2.39).

    To install, replace TsReader.ax in C:\Program Files (x86)\Team MediaPortal\MediaPortal with the new version, after making a backup copy of the original file.

    This version *might* work in MP 1.15 (if you wanted to try a quick test before installing MP 1.18 again), but I haven't tested it with MP 1.15 so I don't know for sure.
     

    Attachments

    Users Who Are Viewing This Thread (Users: 0, Guests: 1)

    OP Similar threads Forum Replies Date
    A [solved] No audio on certain codecs Codecs, External Players 4
    M Music playback stops after certain files 1.19 0
    T Client / Server slow channel-to-channel change (zapping) General Support 1
    V [solved] FTA channels but reported as encrypted MediaPortal 1 Talk 7
    T Server / client channel logo location Installation, configuration support 6
    g0rsq UK Freesat not tunning BBC HD channels, and lots of other freesat channels missing. Newcomers Forum 4
    W [solved] MP suddenly Crashes when starting live TV on most channels and on recordings from the same channels General Support 20
    W [solved] MP suddenly Crashes when starting live TV on some channels and on some recordings Television (MyTV frontend and TV-Server) 1
    raffe [TV] Option for adding IPTV channels without checking Improvement Suggestions 0
    C Telenet analog-to-digital switch -- manually finding and inputting DVB-C channels in Mediaportal2 General 0
    vapourEyes Automatically Tune to Strongest Duplicate Channel Improvement Suggestions 77
    T [solved] Any idea where Channel 107 (DVB-T2) BBC News HD (and others!) have gone??? Installation, configuration support 12
    B [solved] tvguide.xml not importing australian channels Electronic Program Guide 10
    R [fixed] [MP2-819] MP2 Server crashes on ATSC OTA channel scan Submit: Bug Reports 33
    R [solved] All Channel 7 stations listed in guide as 1000 Newcomers Forum 4
    J Rename channel by name Television (MyTV frontend and TV-Server) 2
    P IPTV Channel Problem TV-Server 0
    T Freeview EPG-Anyone know what channel sends the guide data? Electronic Program Guide 10
    M Guide mapping schedules direct, tvguide, epg buddy How to get correct entry to the correct channel? Electronic Program Guide 0
    nominefi Problem scanning channels. General Support 0
    limpwhizkid 1.22.0 Stutter and or artifact problem when recording and watching the same live tv channel 1.22 2
    C Can the XmlTv Plugin handle 600+ channels? General 3
    C How do I see the broadcast channel decimal numbers in the guide? General 0
    C How to quickly map scanned channels to other devices? General 1
    S TV server -. trying to rescan for a local channel Installation, configuration support 0
    Similar threads

























    Top Bottom