Change to TV operation with 1.16.0 upgrade (1 Viewer)

Steve.Rayner61

MP Donator
  • Premium Supporter
  • December 12, 2011
    97
    58
    59
    Perth - Western Australia
    Australia Australia
    Country flag
    Hi all,

    There is a subtle but annoying (For me anyway) change to TV operation with the 1.16.0 version. Previously, if you were in the TV menu (Not viewing live TV or recording), selected "TV Guide", then pressed the Back button on the remote, you were taken "Back" to the TV menu. In this same situation, in 1.16.0, pressing the "Back" button now starts live, full screen TV.

    Apart from the fact that this is counter-intuitive ("Back" should take you "Back" to where you were, not into something else), it's really annoying and makes navigating the TV option very clunky.

    It may be that this was added as a new feature because someone thought, or it was voted to be a good idea. If that's the case, fine. But could we please have it as an option? (I could not find a new setting in TV config for it?).

    Or, it may be that it was a simple error in programming, in which case, could it please be reversed? Happy to offer another donation for the cause :)

    Cheers,
    Steve.
     

    netexplorer

    MP Donator
  • Premium Supporter
  • January 21, 2009
    732
    103
    Germany Germany
    Country flag
    I'm using Titan skin, with an iMon receiver in my case configured as MCE and a Logitech Harmony 555 as remote. But in think it dosn't matter wich remote i use.
     

    joecrow

    Test Group
  • Team MediaPortal
  • August 9, 2012
    1,817
    1,298
    Germany Germany
    Country flag
    I noticed the same thing, using Default Wide HD skin and Ortec remote (with CyberSimians' mapping and Hotkey prog.). Can't be sure but I think it only appeared with 1.16 final. It is a bit of a nuissance as it slows down navigation of the TV gui considerably.;)
     

    Stéphane Lenclud

    Development Group
  • Team MediaPortal
  • April 29, 2013
    2,575
    1,294
    Germany Germany
    Country flag
    Guys please use the Watch Dog and post the logs. It does matter which configuration you are using.
    I just tried that with my configuration for instance it works just fine. Both with "browser back" and "escape" events.
     

    joecrow

    Test Group
  • Team MediaPortal
  • August 9, 2012
    1,817
    1,298
    Germany Germany
    Country flag
    Attached logs produced as follows:-
    Deleted all MP logs then started MP Watchdog and selected option 2, after M;P was ready navigated to TV and pressed OK button, TV starts up and plays in full-screen (per my settings), press stop and from TV gui select "TV Program, EPG displays, navigate in EPG then press back button, TV gui displays briefly but then TV starts up again in full-screen, press stop and back to exit TV. Exit MP and collect logs.
    Hope that helps.:)
     

    CyberSimian

    Test Group
  • Team MediaPortal
  • June 10, 2013
    2,265
    1,361
    Southampton
    United Kingdom United Kingdom
    Country flag
    I noticed the same thing, using Default Wide HD skin and Ortek remote (with CyberSimians' mapping and Hotkey prog.).
    Well, this is strange. I have just tried the test described by the original poster, and for me it works correctly (I am using the Ortek remote with my "Centarea HID" definition and AutoHotKey):

    TV menu (no live TV) -> (GUIDE button) -> TV Guide -> (RETURN button) -> TV menu
    TV menu (live TV) -> (GUIDE button) -> TV Guide -> (RETURN button) -> TV menu (live TV)

    I installed MP 1.16f over MP 1.12f, so it inherited most/all of my settings (it was not a new install).

    -- from CyberSimian in the UK
     

    joecrow

    Test Group
  • Team MediaPortal
  • August 9, 2012
    1,817
    1,298
    Germany Germany
    Country flag
    TV menu (no live TV) -> (GUIDE button) -> TV Guide -> (RETURN button) -> TV menu
    TV menu (live TV) -> (GUIDE button) -> TV Guide -> (RETURN button) -> TV menu (live TV)
    It is strange indeed, but I think there may be a difference in our setups.
    When I select TV from the home gui Iit goes straight to full-screen playback as per the settings in the attached screenshot. and the problem as described in previous posts is reproducible 100%. From your step by step troubleshooting description I get the impression that is not the case for you and you start live TV from the TV Menu, is that correct?:unsure: For sure when I deselect the "Turn on TV" in MP Config/TV then I do not see the problem as per your post.;)
    tvset1.jpg

    P.S. From the description of that setting it kinda implies that the questionable behaviour is maybe correct if not desirable and as mentioned before I'm sure it new in 1.16 final.
     
    Last edited:

    Users who are viewing this thread

    Similar threads
    OP Title Forum Replies Date
    R 1.27.0 Webepg not refreshing changes. See pics WebEPG 1
    F MP don't change refresh rate General Support 8
    T Change tv subtitle in MediaPortal 1.26 Newcomers Forum 12
    T Change tv subtitle in MediaPortal 1.26 MediaPortal 1 Talk 0
    G Changing from MySQL to MariaDB MediaPortal 1 Talk 38
    Lehmden TVDB will change into a payed service in 2021 OffTopic 10
    toricred MP2 - V2.3 Client Dying When Changing Channels ATSC Submit: Bug Reports 1
    E 1.25.0 Change AVC / AAC Codec for Analog card captured videos Codecs, External Players 0
    C 1.25.0 mini Splashscreen - how can i change it MediaPortal 1 Skins 9
    toricred Recordings Change : to _ in Series Name General 0
    A UK Freeview channel changes Installation, configuration support 14
    T Client / Server slow channel-to-channel change (zapping) General Support 1
    framug [solved] Some changes/fix in MP1 configuration client and server Submit: code patches (MediaPortal/TV-Server/etc.) 14
    catavolt [WiP] When changing theme in my skins, I always get this error message in logs MediaPortal 1 9
    azzuro [WiP] MP1-4999 - Big changes with many related change at once by Sebastiii MediaPortal 1 22
    J How to change y position of subtitles General 3
    D [solved] Changed username in Win10, now TV Server config crashes on fresh install Installation, configuration support 1
    M Change size of the splash screen Skins and Plugins Installer (MPEI) 2
    S Remote button to change audio and subtitle on / off General 10
    BenGonGon chaine qui change aléatoirement Support Général 2
    R [solved] Command / Shortcut for changing subtitles or audio Archive 5
    ge2301 New forum design together with change to XF2.x Online Facilities 4
    doskabouter [Evaluate] Changing SecurityProtocol Developer Discussions 1
    O [Help Me!] How to change 'release' status in Jira? Developer Discussions 9
    cbr954rr [fixed] Movie db refresh on changes of nfo and correct spelling of words in titles 2.2 Archive 33

    Similar threads

    Top Bottom