"Double Clicks" with Hauppauge remote (1 Viewer)

wewe

Portal Pro
August 3, 2005
362
0
61
Herxheim
Home Country
Germany Germany
Hi folks,

MP Version: 0.2. RC1 (same with 0.1.3...)
Skin: MCE
Windows Version: XP MCE
CPU Type: AMD Sempron 3100+
Memory: 1GB
Video Card: MSI nVidia 6200
Video Render Type: VMR9
Video Codec Type & Version: MPeg2Dec
Audio Codec Type & Version: MPEG/AC3/DTS/LPCM
TV Card: Hauppage WinTV PVR 150

Synopsis:
Using the Hauppauge remote I have "double clicks" very often. Which means: pressing a button on my remote behaves like clicking the button two times. Example: Full screen TV; click on "record", information appears: "recording started"; information appears "recording stopped". :shock:

- I know that this was discussed a lot of times before
- I know that there is a "delay value" in the settings

I did test around a lot. I did set the delay value to the max of 2 seconds. Then I did a really very short click (Sure less than 2 seconds). Still double clicks ...

I am having a big WAF problem. My wife starts to understand how to use MP - but those double clicks destroy everything ... :(

Question: does anybody else have that?
mPod: any idea?

thanks+regards
WeWe
 

FlipGer

Retired Team Member
  • Premium Supporter
  • April 27, 2004
    2,658
    115
    47
    Leipzig, Germany
    Home Country
    Germany Germany
    Hi,

    yes, i have this from time to time too.
    Especially on ENTER/OK and FULLSCREEN. Eg. entering TV leads me often directly to the EPG....

    Flip.
     

    wewe

    Portal Pro
    August 3, 2005
    362
    0
    61
    Herxheim
    Home Country
    Germany Germany
    So, you think it's a hauppauge specific problem or it's more a MP specific problem?

    With other words: if I change to an other remote? (I fell in love with iMon VFD which comes with a remote)

    thanks + regards
    WeWe
     

    FlipGer

    Retired Team Member
  • Premium Supporter
  • April 27, 2004
    2,658
    115
    47
    Leipzig, Germany
    Home Country
    Germany Germany
    Hi,

    i can really only guess here. But i think it is a problem with hauppauge. But i haven't done any testing. Perhaps someone with MCE or iMON remote could say a littlebit more?

    Flip.
     

    AberDino

    MP Donator
  • Premium Supporter
  • February 17, 2005
    240
    28
    Kincardineshire
    Home Country
    Scotland Scotland
    I have a problem with the MCE remote (Europe), but not 'double clicks'. In my case MP doesn't always repond to the arrow keys. For example, in My Music -> Artist view -> pick an artist and it lists some songs. I select song x and press the ok button, songs starts to play. Then when I press the arrow up or down the first time there is no response, when I press it again it does work. Also, when I bring up the shutdown/restart submenu from the main menu it doesn't repond the first time when I press the down button to select restart. The remote receiver defnitely picks up the signal the first time, MP is just not doing anything with it. It's not ideal, but I can live with it, I'm sure it will be resolved some time soon. I'm using 0.2.0 RC with one of yesterday's CVS files.
     

    Bosso

    Portal Pro
    December 16, 2004
    50
    0
    Sweden / Stockholm
    Fix for hauppage on it's way

    I am working on this.
    I have changed some code in the hauppage remote wich
    handles repetition.
    Seems like we can not rely on the driver here, so I added some functionallity in the plugin.
    For me it reduced doubleclick a lot.
    I have some fine tuning to do before I will post a new dll.
    For now i get double clicks after scrolling etc.
    Have to have a timeout in the code.

    I'll be glad if you guys would test it before I try to check it into the cvs.

    I'll fix some tuning tonight and let ya konow how it works.

    /Bosso
     

    Bosso

    Portal Pro
    December 16, 2004
    50
    0
    Sweden / Stockholm
    hmm. not possible to attach in a post I see.
    I don't have acess to any webserver either.
    hmm.
    Those who are interested to try this, send me a private message with your
    email so I can send it directly to you then.
     

    Users who are viewing this thread

    Top Bottom