DVD resume doesn't work (1 Viewer)

haiwire

New Member
March 26, 2011
1
0
39
Since 1.6 DVD resume doesn't work anymore, was working perfectly before. I was hoping that it was just a small issue solved in one of the following releases but still there: After stopping a DVD and trying to resume (even one sec later) the DVD starts from beginning, no dialog displayed to resume from last position. I'm using the internal DVD navigator, btw no other selectable, greyed out althoug PDVD 13 is installed and codecs are detected by MP. Currently 1.8 is installed, beside this no other DVD playback or navigation issue. Any idea what might be the problem?
 

mm1352000

Development Group
  • Team MediaPortal
  • September 1, 2008
    21,571
    8,218
    New Zealand New Zealand
    Country flag

    Blue Lightning

    Portal Member
    October 8, 2011
    49
    52
    Australia Australia
    I have the same issue. It worked (resuming DVD position) a couple versions ago but doesn't work any more.
    I used the instructions above to generate log files. I had a look but couldn't tell if the problem was visible in it. Any help would be appreciated!

    The action I performed was I started MP using the first option in the debug tool and started the DVD. I went though the menu and started video playback. Then I paused it and pressed 'stop'. I then went back to the DVD but it started from the "warning" screen again rather than resuming (or offering to resume) where I left off.

    Logs attached. System details are on my profile and I used the default "Titan" theme for the test (as that is what the debug tool launched) but I usually use what used to be called "Default Wide". The problem occurs in both themes.
     

    Blue Lightning

    Portal Member
    October 8, 2011
    49
    52
    Australia Australia
    That does describe my issue, except I'm just using the one called "DVD Navigator". There are no other options for me. Is that a renamed MS DVD Navigator? Are there usually other options?
    Would it be worth trying the recent Windows Update KB3001554 "September 2014 update for DVD playback in Windows 7 SP1"? (https://support2.microsoft.com/kb/3001554)
    It doesn't say what it does so I assumed it was probably DRM related and didn't bother.
     

    mm1352000

    Development Group
  • Team MediaPortal
  • September 1, 2008
    21,571
    8,218
    New Zealand New Zealand
    Country flag
    Is that a renamed MS DVD Navigator?
    Yes, it is the MS DVD navigator. No, it has not been renamed. That has always been its name.

    Are there usually other options?
    Only if you install them. For example, if you install Cyberlink software you might get a Cyberlink DVD navigator.

    Would it be worth trying the recent Windows Update KB3001554 "September 2014 update for DVD playback in Windows 7 SP1"?
    As you say, the technical details about what this update actually does don't appear to be available. I also suspect it won't make any difference.

    It doesn't say what it does so I assumed it was probably DRM related and didn't bother.
    That would also have been my assumption. ;)
     

    Blue Lightning

    Portal Member
    October 8, 2011
    49
    52
    Australia Australia
    Hmm okay thanks. I may give the update a try but as you said it probably won't do anything.

    Does this problem happen to everyone who uses the MS DVD navigator or does it work fine for some people?
    That bug report indicates the issue may have started in version 1.6. Is there a way to compare 1.5 with 1.6 in terms of code changes? I can't figure out where the 1.5 and 1.6 merges happened in Github.
     

    HomeY

    Test Group
  • Team MediaPortal
  • February 23, 2008
    6,465
    4,631
    45
    ::1
    Netherlands Netherlands
    Country flag
    I can't figure out where the 1.5 and 1.6 merges happened in Github.
    Search for tags on Github.
    Release_1.5.0 vs Release_1.6.0

    You can find the tags on the Github page, select the 'branch' pulldown menu:
    upload_2014-10-3_12-5-2.png

    and click on the 'Tags' tab in there to select a specific version.

    If you have repos cloned locally and use a tool like (for example) TortoiseGit, you can also 'check out' based on tags.
    And if you want to go a step further, you can use Git Blame:
    http://tortoisegit.org/docs/tortoisegit/tgit-dug-blame.html
     

    Sebastiii

    Development Group
  • Team MediaPortal
  • November 12, 2007
    16,433
    10,254
    France
    France France
    Country flag
    Hi :)

    I have do some quick test, for me resume works when the DVD is ripped on my hard disk.
    I need to test .ISO mounted DVD and DVD from drive :)
     

    Users Who Are Viewing This Thread (Users: 0, Guests: 1)

    OP Similar threads Forum Replies Date
    E MediaPortal kann DVD s nicht wiedergeben Allgemeines Supportforum 3
    Z [solved] DVD playback is super glitchy General 2
    doskabouter 1.23.0 Crash when skipping in a dvd Bugreports 3
    C Attempt to play DVD locks up MediaPortal watch/edit Videos 0
    Rob Hexenmeister DVD Skip steps causing crash General Support 2
    badboyxx MP 1.22 final is crashing when jumping forward while playing DVD-Iso watch/edit Videos 26
    U [DVD] DVD Menu Navigation for HID keyboard Improvement Suggestions 0
    BlueMax1916 [Finished] [MP2-820] Eject command for CD/DVD/Blu-ray disc media Feature Requests 39
    D A couple of DVD questions General 2
    D MP2 - V2.1 Specific ripped DVD not appearing in movie library Older releases 7
    hounddog How to get My Films working in MP 1.20 My Films 5
    W No DVD audio after crash from defective disc drive General Support 2
    joecrow MP 1 Hangs on resume fro sleep (TV) Watch / Listen Media 2
    joecrow 1.25.0 Radio Time plugin fails after Resume from Sleep with MP 1.25 Bugreports 3
    F After resume, TV Server connection screen is shown General Support 4
    Dark Eyes TVService locks up or fails to restart on resuming from sleep, and crashes when grabbing EPG Installation, configuration support 7
    P MP2 Client Screen Flickering on Resume General 2
    HTPCSourcer [fixed] [MP2-815] User not logged in when resuming from standby MediaPortal 2 17
    J Resume from Standby Last Module TV Showing TV Server Settings Television (MyTV frontend and TV-Server) 2
    R Media portal resumes with wrong screen resolution General Support 3
    B resume from within a folder Watch / Listen Media 0
    joecrow No Audio after MP Start/Resume from Sleep General Support 0
    R Weird sleep/resume loop General Support 4
    joecrow Further problem on resume from sleep (MP Crash) 1.21 5
    joecrow Loss of Navigation Sounds on Resume from Sleep Mp 1.21 General Support 10
    Similar threads

























    Top Bottom