DVD resume doesn't work (1 Viewer)

Sebastiii

Development Group
  • Team MediaPortal
  • November 12, 2007
    16,433
    10,254
    France
    France France
    Country flag
    @Deda, will do more check, but i can confirm using older 'VideoDatabaseSqlLite.cs' code make DVD on disc resume works :)
     

    Holzi

    Super Moderator
  • Team MediaPortal
  • April 21, 2010
    7,930
    2,234
    Ba-Wü
    Germany Germany
    Country flag
    No one else lol
    Thanks! I finally was able to test it and can confirm it works with your fix. :)
    Without it didn't work.

    Offtopic:
    But I was not able to play my DVD with LAV Video decoder. MP freezes and I have to use the taskbar to kill it.
    Log attached. After that I tried Cyberlink SP Video Decoder and it works. :) (Logs attached too).

    OS: Win 8.1 with onboard Intel GFX.

    Way more offtopic:
    When I try to play my DVD in MP2 (also using LAV Filters), MP2 crashes to desktop.

    Maybe something wrong with my system?
    Does LAV Video decoder works for you guys?

    I even disabled Hardware acceleration in LAV Video decoder settings.

    EDIT:
    Wow, I feel stupid now.. you should enable DVD support in LAV settings (was disabled by default for me).
    1.jpg

     
    Last edited:

    Blue Lightning

    Portal Member
    October 8, 2011
    49
    52
    Australia Australia
    Just tested it and it works perfectly. Thank you! :D
    My test was on 1.9.0 on my main desktop with the same DVD and ISO as before. DVD resume now works, and ISO resume continues to work.

    I'll try it out on my 1.8.0 media PC and let you know if it breaks any day-to-day use. (Assuming it is 1.8.0 compatible otherwise I'll just wait for 1.10.0)
     

    Sebastiii

    Development Group
  • Team MediaPortal
  • November 12, 2007
    16,433
    10,254
    France
    France France
    Country flag
    Thanks Guys :)

    I'm not sure the dll is compatible with 1.8.0 but it's possible :)
     

    wiyosaya

    MP Donator
  • Premium Supporter
  • January 22, 2014
    77
    25
    United States of America United States of America
    I spent about an hour testing. In general, things seem to work, but there are some hiccups.

    First, sometimes, stopping a disc, ejecting it, then putting in another disc, stopping that one, then going back to the first one resume sometimes works, sometimes not for the first disc. I am not sure what is going on there, but it seems that resume info may only be saved for a single disc. Ideally, at least as I see it, say the last 10 or so discs would remember their position and resume would work even if one inserts a different disc inbetween instances of watching any particular disc.

    My test procedure was, essentially, this:
    1. Put in disc
    2. play
    3. stop
    4. attempt resume
    5. if resume worked, resume
    6. stop
    7. eject disc
    8. put in next disc
    9. repeat from step 1
    10. Then -
    11. Put in previously ejected disc
    12. repeat from step 1
    I used the following discs:
    1. The Matrix DVD
    2. Touched by an Angel Season 8, discs 2 and 3
    3. The Sy-Fy channel's Dune, Special Edition DVD disc 1
    4. Doctor Who, The Reign of Terror DVD
    5. Doctor Who, The Day of the Doctor Blu-ray
    6. Avatar, Extended Blu-ray Collector's Edition
    First off, The Matrix would only play the movie studio logo sequence, then black screen. There was no control bar, however, I was able to right-click then get the context menu and back out of the disc. I have had problems with this disc before, so this may be another bug.

    With both Touched by an Angel discs, menu navigation is goofed up. I was using my remote, and what appears to be happening is that the first time I press a button on the remote, the menu cursor stays at the same place on the screen, but the actual menu item in MePo has shifted to the next menu item so that the menu cursor on the screen and the actually selected menu item are out of sync. Before applying the fix, the disc menu was working.

    With the TBAA discs, the menuing appears out of sync and is quite confusing. However, on going into any particular episode on a disc, stopping, then resuming, the resume seems to work.

    With disc 3 from the list, I went into the setup menu, selected DTS audio instead of AC-3, went back to the main menu, played the disc, and AC-3 was the audio instead of DTS. I then switched by the context menu to DTS, and confirmed this on my receiver, then stopped and attempted resume. The resume works including using the DTS audio with this disc. Other than DTS not sticking when selected from the discs audio setup menu, everything seemed to work fine for this disc.

    In general, both blu-rays worked, too. However, resuming is a bit different. On the Avatar disc, I got the resume menu, but then I got the disc selection menu, and on choosing the same item from that menu, it resumed from the point I had stopped. However, with Avatar, it had one instance of choppy playback which was impossible to watch, and one instance where the drive light was flashing as if it was playing, but the screen was totally black. The Day of the Doctor also exhibited showing the resume dialog, on saying resume from, it then showed the Blu-ray menu, and on selecting the same item from that that I had previously chosen, it did resume from the spot that I had left off. This did not happen all the time, sometimes, resume simply went back into the disc.

    Also, on some discs after I had ejected them and went back into them, I got the :"disc inserted would you like to auto play" on saying "yes" I then got the resume menu.

    So this is probably confusing, but I have attached log files of the my efforts.

    All I can say is that sometimes it works, sometimes not. It seems to depend on the disc.
     

    Users Who Are Viewing This Thread (Users: 0, Guests: 1)

    OP Similar threads Forum Replies Date
    E MediaPortal kann DVD s nicht wiedergeben Allgemeines Supportforum 3
    Z [solved] DVD playback is super glitchy General 2
    doskabouter 1.23.0 Crash when skipping in a dvd Bugreports 3
    C Attempt to play DVD locks up MediaPortal watch/edit Videos 0
    Rob Hexenmeister DVD Skip steps causing crash General Support 2
    badboyxx MP 1.22 final is crashing when jumping forward while playing DVD-Iso watch/edit Videos 26
    U [DVD] DVD Menu Navigation for HID keyboard Improvement Suggestions 0
    BlueMax1916 [Finished] [MP2-820] Eject command for CD/DVD/Blu-ray disc media Feature Requests 39
    D A couple of DVD questions General 2
    D MP2 - V2.1 Specific ripped DVD not appearing in movie library Older releases 7
    hounddog How to get My Films working in MP 1.20 My Films 5
    W No DVD audio after crash from defective disc drive General Support 2
    joecrow 1.25.0 Radio Time plugin fails after Resume from Sleep with MP 1.25 Bugreports 3
    F After resume, TV Server connection screen is shown General Support 4
    Dark Eyes TVService locks up or fails to restart on resuming from sleep, and crashes when grabbing EPG Installation, configuration support 7
    P MP2 Client Screen Flickering on Resume General 2
    HTPCSourcer [fixed] [MP2-815] User not logged in when resuming from standby MediaPortal 2 17
    J Resume from Standby Last Module TV Showing TV Server Settings Television (MyTV frontend and TV-Server) 2
    R Media portal resumes with wrong screen resolution General Support 3
    B resume from within a folder Watch / Listen Media 0
    joecrow No Audio after MP Start/Resume from Sleep General Support 0
    R Weird sleep/resume loop General Support 4
    joecrow Further problem on resume from sleep (MP Crash) 1.21 5
    joecrow Loss of Navigation Sounds on Resume from Sleep Mp 1.21 General Support 10
    D [further infos missing] Problems switching to live tv channel after resume 2.2 Archive 1
    Similar threads

























    Top Bottom