Error logged by Mini Display: LCD2USB.dll not found? (1 Viewer)

rsbrux

Documentation Group
  • Team MediaPortal
  • April 15, 2007
    1,029
    93
    Switzerland Switzerland
    Country flag
    Occasionally I see an error like the following in MediaPortal's error.log:
    2012-03-01 01:08:19.184570 [ERROR][MPMain(1)]: MiniDisplay:Error while loading driver C:\Program Files\Team MediaPortal\MediaPortal\Plugins\process\LCDDrivers\LCD2USB.dll: Unable to load DLL 'C:\Program Files\Team MediaPortal\MediaPortal\Plugins\process\LCDDrivers\LCD2USB.dll': The specified module could not be found. (Exception from HRESULT: 0x8007007E)
    The file is there where it should be (v 1.4.0.0) and the display ( Fujitsu-Siemens Scaleo E w/Futaba VFD using the Fujitsu Scaleo EV driver) seems to work OK.
    Where is the error coming from, and how can I get rid of it?
     

    rsbrux

    Documentation Group
  • Team MediaPortal
  • April 15, 2007
    1,029
    93
    Switzerland Switzerland
    Country flag
    Now I am getting this error again, and I can't find LCD2USB.DLL on my system any more. There doesn't seem to be any functional problem: I am still getting information displayed on my built-in Fujitsu VFD.
     
    B

    BassFan

    Guest
    i have the same Problem when start configuration or MP v1.5 that not appears in 1.4
    so i have deactivate Mini Display..

    why? when i have deactivate the Mini Display the error appears again? (infrequent)
    the lib should NOT checked after deactivate in configuration
    NO error log appears only this message

    greets
     
    Last edited by a moderator:
    B

    BassFan

    Guest
    i have found the mistake
    LCD2USB.DLL used libusb0.dll and that is not 64 Bit kompatible after remove it this message is gone.

    greets
     
    B

    BassFan

    Guest
    @BassFan was libusb0.dll shipped with earlies version of MP? I can't find the dll on my system and also I cannot find any reference to this dll is the source code.
    LCD2USB.DLL used the file libusb0.dll as reference check it with Dependency Walker.
    the sourcecode from MP not used any of them..
    -----------------
    you can not load a DLL if a dependency (Module) are missing.
    and you can not load a Driver on a 64 Bit System with a Module written in 32 Bit.. (libusb0.dll)
    LCD2USB.DLL should be remove from MP !!
    ------------

    Which Problem your have?

    greets
     
    Last edited by a moderator:

    uxDesign

    Portal Pro
    December 10, 2011
    83
    52
    near Munich
    Germany Germany
    Country flag
    I have no problems, I only have the errors in the log and was wondering why. I saw with Dependency Walker that libus0.dll is missing and was curious which module does it actually use and I found none. I agree that LCD2USB.DLL should be removed from MP.

    Regards, uxDesign
     

    Users Who Are Viewing This Thread (Users: 0, Guests: 1)

    OP Similar threads Forum Replies Date
    horned_reaper Errors in FH log ... Fanart Handler 1
    catavolt [WiP] When changing theme in my skins, I always get this error message in logs MediaPortal 1 9
    horned_reaper MediaPortal configuration error log message General Support 1
    horned_reaper MiniDisplayStatus error log messages General Support 7
    horned_reaper [solved] GUITextureManager Load2 log error messages Fanart Handler 1
    horned_reaper MediaPortal.LastFM.LastFMException error log message General Support 1
    F Audio render and font error in my logs General Support 2
    T [solved] "Unable To Play" (Videos) rears it's head again. Logs not possible... WatchDog error attached!! :( General Support 1
    T Get this error message on attempted re-install...LOGS inc. General Support 4
    CyberSimian Inappropriate error messages in the log file MediaPortal 1 0
    S MP restarts after 10-30 sec - how to read error logs General Support 1
    T Moving Pictures error after update to 1.19 Final...logs included! Watch / Listen Media 6
    G [solved] timeshift error Newcomers Forum 2
    C Can't install any extensions - DLL error Installation, configuration support 19
    joecrow 1.25.0 5031: Error on Install. Bugreports 24
    M MediaPortal2 TV Config Error on Install (0x80004005) General 7
    J Blue Screen Error Submit: Bug Reports 0
    G Q about scheduling weekly series when epg lists duplicate back to back episodes each week General Support 2
    Rob Hexenmeister Dependency error on install v2.3.2.0 OnlineVideos 28
    F Error invoking action 'GetNowNextProgramForGroup' Submit: Bug Reports 3
    B MP 2.2.3 Error playing videos from NAS Submit: Bug Reports 2
    vvulture UNKNOWN ERROR when starting live TV General Support 6
    doskabouter Build errors MediaPortal 1 9
    ajs Trakt error when start with MP crash Trakt 1
    R [solved] No Response from Home Page - Error Newcomers Forum 0
    Similar threads

























    Top Bottom