Error while playing any video stream for a 2nd time

xppx

Portal Pro
Joined
September 2, 2007
Messages
78
Points
8
Country flag
Last edited:

johanj

Well-Known Member
Joined
January 31, 2009
Messages
781
Points
63
Age
41
I tried the play command again and could reproduce the issue. It was actually after cleaning up AudioCodec, see below.

Code:
[2014-06-09 21:37:52,287] [Log    ] [47       ] [DEBUG] - [WIFI_REMOTE]  User iPad [MPiV] successfully authentificated by username and password
[2014-06-09 21:37:52,287] [Log    ] [47       ] [DEBUG] - [WIFI_REMOTE]  Client identified: iPad [MPiV]
[2014-06-09 21:38:05,087] [Log    ] [57       ] [DEBUG] - [WIFI_REMOTE]  play mediaitem: ItemId: fs1_MzAwXDMwMC5ta3Y=, itemType: 4, providerId: 10
[2014-06-09 21:38:05,090] [Log    ] [57       ] [INFO ] - MAP: using default mappings for WifiRemote
[2014-06-09 21:38:05,091] [Log    ] [57       ] [DEBUG] - [WIFI_REMOTE]  Play video file: \\SERVER\Videos\300\300.mkv, pos: 0
[2014-06-09 21:38:05,092] [Log    ] [57       ] [DEBUG] - MediaInfoWrapper.MediaInfoWrapper: Opening file : \\SERVER\Videos\300\300.mkv
[2014-06-09 21:38:05,226] [Log    ] [57       ] [DEBUG] - MediaInfoWrapper.MediaInfoWrapper: DLL Version      : MediaInfoLib - v0.7.69
[2014-06-09 21:38:05,226] [Log    ] [57       ] [INFO ] - MediaInfoWrapper.MediaInfoWrapper: Inspecting media : \\SERVER\Videos\300\300.mkv
[2014-06-09 21:38:05,227] [Log    ] [57       ] [DEBUG] - MediaInfoWrapper.MediaInfoWrapper: Parse speed      : 0.3
[2014-06-09 21:38:05,227] [Log    ] [57       ] [DEBUG] - MediaInfoWrapper.MediaInfoWrapper: FrameRate        : 23,976
[2014-06-09 21:38:05,227] [Log    ] [57       ] [DEBUG] - MediaInfoWrapper.MediaInfoWrapper: Width            : 1280
[2014-06-09 21:38:05,227] [Log    ] [57       ] [DEBUG] - MediaInfoWrapper.MediaInfoWrapper: Height           : 528
[2014-06-09 21:38:05,228] [Log    ] [57       ] [DEBUG] - MediaInfoWrapper.MediaInfoWrapper: AspectRatio      : widescreen
[2014-06-09 21:38:05,228] [Log    ] [57       ] [DEBUG] - MediaInfoWrapper.MediaInfoWrapper: VideoCodec       : AVC [ "avc.png" ]
[2014-06-09 21:38:05,228] [Log    ] [57       ] [DEBUG] - MediaInfoWrapper.MediaInfoWrapper: Scan type        : progressive
[2014-06-09 21:38:05,229] [Log    ] [57       ] [DEBUG] - MediaInfoWrapper.MediaInfoWrapper: IsInterlaced     : False
[2014-06-09 21:38:05,229] [Log    ] [57       ] [DEBUG] - MediaInfoWrapper.MediaInfoWrapper: VideoResolution  : 720P
[2014-06-09 21:38:05,229] [Log    ] [57       ] [DEBUG] - MediaInfoWrapper.MediaInfoWrapper: VideoDuration    : 6992576
[2014-06-09 21:38:05,229] [Log    ] [57       ] [DEBUG] - MediaInfoWrapper.MediaInfoWrapper: AudioRate        : 48000
[2014-06-09 21:38:05,230] [Log    ] [57       ] [DEBUG] - MediaInfoWrapper.MediaInfoWrapper: AudioChannels    : 6 [ "5.1.png" ]
[2014-06-09 21:38:05,230] [Log    ] [57       ] [DEBUG] - MediaInfoWrapper.MediaInfoWrapper: AudioCodec       : AC-3 [ "ac-3.png" ]
[2014-06-09 21:38:05,230] [Log    ] [57       ] [DEBUG] - MediaInfoWrapper.MediaInfoWrapper: HasAudio         : True
[2014-06-09 21:38:05,230] [Log    ] [57       ] [DEBUG] - MediaInfoWrapper.MediaInfoWrapper: HasVideo         : True
[2014-06-09 21:38:05,231] [Log    ] [57       ] [DEBUG] - MediaInfoWrapper.MediaInfoWrapper: HasSubtitles     : False
[2014-06-09 21:38:05,231] [Log    ] [57       ] [DEBUG] - MediaInfoWrapper.MediaInfoWrapper: NumSubtitles     : 0
[2014-06-09 21:38:05,231] [Log    ] [57       ] [DEBUG] - MediaInfoWrapper.MediaInfoWrapper: Closing file : \\SERVER\Videos\300\300.mkv
[2014-06-09 21:38:05,232] [Log    ] [57       ] [INFO ] - RefreshRateChanger.AdaptRefreshRate: framerate on file \\SERVER\Videos\300\300.mkv is 23,976
[2014-06-09 21:38:05,243] [Log    ] [57       ] [INFO ] - RefreshRateChanger.SetRefreshRateBasedOnFPS: current refreshrate is 50hz - changing it to 23hz
[2014-06-09 21:38:05,244] [Log    ] [57       ] [INFO ] - RefreshRateChanger.SetRefreshRateBasedOnFPS: using internal win32 method for changing refreshrate. current is 50hz, desired is 23
[2014-06-09 21:38:05,263] [Log    ] [57       ] [INFO ] - RefreshRateChanger AdapterOrdinal value is 0
[2014-06-09 21:38:05,264] [Log    ] [57       ] [DEBUG] - CycleRefreshRate: Current MonitorIndex : 0 and current deviceName : \\.\DISPLAY1
[2014-06-09 21:38:06,039] [Log    ] [57       ] [INFO ] - CycleRefreshRate: result DISP_CHANGE_SUCCESSFUL for refresh rate change 23Hz
[2014-06-09 21:38:06,039] [Log    ] [57       ] [DEBUG] - CycleRefresh: DWM Detected, performing shenanigans
[2014-06-09 21:38:06,040] [Log    ] [57       ] [INFO ] - g_Player.Play(\\SERVER\Videos\300\300.mkv Video)
[2014-06-09 21:38:06,040] [Log    ] [57       ] [DEBUG] - PlayerFactory: Successfully created player instance for file - \\SERVER\Videos\300\300.mkv
[2014-06-09 21:38:06,041] [Log    ] [57       ] [INFO ] - VideoPlayer:play \\SERVER\Videos\300\300.mkv
[2014-06-09 21:38:06,047] [Log    ] [57       ] [INFO ] - VideoPlayer9: Enabling DX9 exclusive mode
[2014-06-09 21:38:06,047] [Log    ] [57       ] [INFO ] - Main: GUI_MSG_SWITCH_FULL_WINDOWED message is obsolete.
[2014-06-09 21:38:06,303] [Log    ] [MPMain   ] [DEBUG] - Main: WM_DISPLAYCHANGE
[2014-06-09 21:38:06,310] [Log    ] [MPMain   ] [DEBUG] - Main: WM_GETMINMAXINFO Start (MaxSize: 1920x1080 - MaxPostion: 0,0 - MinTrackSize: 2x2 - MaxTrackSize: 1932x1092)
[2014-06-09 21:38:06,343] [Log    ] [MPMain   ] [DEBUG] - Main: WM_GETMINMAXINFO End (MaxSize: 1920x1080 - MaxPostion: 0,0 - MinTrackSize: 1920x1080 - MaxTrackSize: 1920x1080)
[2014-06-09 21:38:06,345] [Log    ] [MPMain   ] [DEBUG] - D3D: OnPaint()
[2014-06-09 21:38:06,676] [Log    ] [MPMain   ] [DEBUG] - Main: WM_ACTIVATE (WA_INACTIVE)
[2014-06-09 21:38:06,676] [Log    ] [MPMain   ] [INFO ] - Main: Deactivation request received
[2014-06-09 21:38:06,676] [Log    ] [MPMain   ] [INFO ] - Main: Refresh rate changer running. Ignoring deactivation request
[2014-06-09 21:38:06,677] [Log    ] [MPMain   ] [DEBUG] - D3D: OnLostFocus()
[2014-06-09 21:38:06,682] [Log    ] [MPMain   ] [DEBUG] - Main: WM_ACTIVATE (WA_ACTIVE)
[2014-06-09 21:38:06,682] [Log    ] [MPMain   ] [INFO ] - Main: Activation request received
[2014-06-09 21:38:06,682] [Log    ] [MPMain   ] [DEBUG] - D3D: OnGotFocus()
[2014-06-09 21:38:06,690] [Log    ] [57       ] [INFO ] - VMR9: added EVR Renderer to graph
[2014-06-09 21:38:06,690] [Log    ] [57       ] [DEBUG] - VMR9: Now active
[2014-06-09 21:38:06,691] [Log    ] [57       ] [DEBUG] - VMR9: Renderer successfully added
[2014-06-09 21:38:06,691] [Log    ] [57       ] [DEBUG] - VideoPlayer9: Add LAVSplitter Source to graph
[2014-06-09 21:38:06,692] [Log    ] [MPMain   ] [DEBUG] - VMR9Helper: Playing -> Repainting, Frames 0
[2014-06-09 21:38:06,720] [Log    ] [57       ] [INFO ] - VideoPlayer9: found H264 video out pin
[2014-06-09 21:38:06,722] [Log    ] [57       ] [INFO ] - Added filter: LAV Video Decoder to graph
[2014-06-09 21:38:06,722] [Log    ] [57       ] [INFO ] - DirectShowUtils: First try to insert new audio renderer Default DirectSound Device
[2014-06-09 21:38:06,723] [Log    ] [57       ] [INFO ] - DirectShowUtils: Found audio renderer
[2014-06-09 21:38:06,724] [Log    ] [57       ] [DEBUG] - DirectShowUtils: added filter:Default DirectSound Device to graph
[2014-06-09 21:38:06,728] [Log    ] [57       ] [INFO ] - Added filter: LAV Audio Decoder to graph
[2014-06-09 21:38:06,728] [Log    ] [57       ] [DEBUG] - Filter: LAV Splitter Source - try to connect: Video
[2014-06-09 21:38:06,728] [Log    ] [57       ] [DEBUG] - DirectShowUtil: build the graph for PIN : Video
[2014-06-09 21:38:06,806] [Log    ] [57       ] [DEBUG] - PlaneScene: PresentImage() dispose surfaces
[2014-06-09 21:38:06,807] [Log    ] [57       ] [DEBUG] - Filter: LAV Splitter Source - try to connect: Audio
[2014-06-09 21:38:06,807] [Log    ] [57       ] [DEBUG] - DirectShowUtil: volume handler value 61439
[2014-06-09 21:38:06,808] [Log    ] [57       ] [DEBUG] - DirectShowUtil: build the graph for PIN : Audio
[2014-06-09 21:38:06,827] [Log    ] [57       ] [DEBUG] - Check graph connections for: Default DirectSound Device
[2014-06-09 21:38:06,827] [Log    ] [57       ] [DEBUG] - Check graph connections for: Enhanced Video Renderer
[2014-06-09 21:38:06,827] [Log    ] [57       ] [DEBUG] - Check graph connections for: LAV Audio Decoder
[2014-06-09 21:38:06,827] [Log    ] [57       ] [DEBUG] - Check graph connections for: LAV Video Decoder
[2014-06-09 21:38:06,827] [Log    ] [57       ] [DEBUG] - Check graph connections for: LAV Splitter Source
[2014-06-09 21:38:06,828] [Log    ] [57       ] [DEBUG] - MpcEngine: using texture size of 1280x720
[2014-06-09 21:38:06,828] [Log    ] [57       ] [INFO ] - MpcEngine: Subtitle VideoPlayer CultureInfo sv
[2014-06-09 21:38:06,844] [Log    ] [57       ] [DEBUG] - VideoPlayer: FoundStreams: Type=Video; Name=V: English [eng] (h264 main L5.1, yuv420p, 1280x528) [default], Filter=LAV Splitter Source, Id=0, PDWGroup=0, LCID=1033
[2014-06-09 21:38:06,844] [Log    ] [57       ] [DEBUG] - VideoPlayer: FoundStreams: Type=Audio; Name=A: ac3, 48000 Hz, 5.1, 640 kb/s [default], Filter=LAV Splitter Source, Id=1, PDWGroup=1, LCID=0
[2014-06-09 21:38:06,844] [Log    ] [57       ] [INFO ] - VideoPlayerVMR7: AudioLanguage CultureInfo sv
[2014-06-09 21:38:06,852] [Log    ] [MPMain   ] [DEBUG] - VMR9: Repainting -> Playing, Frames: 50
[2014-06-09 21:38:06,859] [Log    ] [57       ] [INFO ] - VideoPlayer:Duration:6992,579708
[2014-06-09 21:38:06,859] [Log    ] [57       ] [INFO ] - g_Player.OnStarted() \\SERVER\Videos\300\300.mkv media:Video
[2014-06-09 21:38:06,864] [Log    ] [57       ] [DEBUG] - VideodatabaseSqllite AddFile:\300.mkv
[2014-06-09 21:38:06,866] [Log    ] [57       ] [INFO ] - VideoDatabase media info scanning file: \\SERVER\Videos\300\300.mkv
[2014-06-09 21:38:06,870] [Log    ] [57       ] [DEBUG] - VideodatabaseSqllite Finished AddFile:\300.mkv
[2014-06-09 21:38:06,872] [Log    ] [57       ] [DEBUG] - [WIFI_REMOTE]  Playback started!
[2014-06-09 21:38:06,876] [Log    ] [57       ] [INFO ] - [WIFI_REMOTE]  {"Type":"nowplaying","Duration":6992,"File":"\\\\SERVER\\Videos\\300\\300.mkv","Position":0,"IsTv":false,"IsFullscreen":false,"MediaInfo":{"MediaType":"movie","MpExtId":"12","MpExtMediaType":0,"MpExtProviderId":3,"ItemId":12,"Summary":"Based on Frank Miller's graphic novel, \"300\" is very loosely based the 480 B.C. Battle of Thermopylae, where the King of Sparta led his army against the advancing Persians; the battle is said to have inspired all of Greece to band together against the Persians, and helped usher in the world's first democracy.","Title":"300","AlternateTitles":"|300: The IMAX Experience|300: Bitva u Thermopyl|Three Hundred|300|300|300壯士:斯巴達的逆襲|300 1|300 I|300 (2007)|300 (2006)|","Tagline":"Spartans, tonight, we dine in hell!","Directors":"|Zack Snyder|","Writers":"|Frank Miller|Zack Snyder|Kurt Johnstad|Michael B. Gordon|Lynn Varley|","Actors":"|Gerard Butler|Lena Headey|Dominic West|David Wenham|Vincent Regan|Michael Fassbender|Tom Wisdom|Andrew Tiernan|Andrew Pleavin|Rodrigo Santoro|Giovani Cimmino|Tyler Neitzel|Greg Kramer|Stephen McHattie|Alex Ivanovici|Kelly Craig|Eli Snyder|Tim Connolly|Marie-Julie Rivest|Sebastian St. Germain|Peter Mensah|Arthur Holden|Michael Sinelnikoff|John Dunn-Hill|Dennis St John|Neil Napier|Dylan Smith|Maurizio Terrazzano|Robert Paradis|Kwasi Songui|Alexandra Beaton|Frédéric Smith|","Rating":"7,7","Year":2006,"Genres":"|Action|Fantasy|History|War|","Certification":"R","DetailsUrl":"http://www.imdb.com/title/tt0416449","ImageName":"C:\\ProgramData\\Team MediaPortal\\MediaPortal\\Thumbs\\MovingPictures\\Covers\\FullSize\\{300} [1096401819].jpg"}}
[2014-06-09 21:38:06,877] [Log    ] [49       ] [DEBUG] - [WIFI_REMOTE]  Start now-playing update thread
[2014-06-09 21:38:06,987] [Log    ] [52       ] [DEBUG] - PlaneScene: PresentImage() dispose surfaces
[2014-06-09 21:38:07,060] [Log    ] [36       ] [DEBUG] - PlaneScene: crop T, B  : 0, 0
[2014-06-09 21:38:07,060] [Log    ] [36       ] [DEBUG] - PlaneScene: crop L, R  : 0, 0
[2014-06-09 21:38:07,060] [Log    ] [36       ] [INFO ] - PlaneScene: video WxH  : 1280x528
[2014-06-09 21:38:07,061] [Log    ] [36       ] [DEBUG] - PlaneScene: video AR   : 80:33
[2014-06-09 21:38:07,061] [Log    ] [36       ] [INFO ] - PlaneScene: screen WxH : 240x135
[2014-06-09 21:38:07,061] [Log    ] [36       ] [DEBUG] - PlaneScene: AR type    : Normal
[2014-06-09 21:38:07,062] [Log    ] [36       ] [DEBUG] - PlaneScene: PixelRatio : 1
[2014-06-09 21:38:07,062] [Log    ] [36       ] [DEBUG] - PlaneScene: src        : (0,0)-(1280,528)
[2014-06-09 21:38:07,062] [Log    ] [36       ] [DEBUG] - PlaneScene: dst        : (683,61)-(923,160)
[2014-06-09 21:38:14,488] [Log    ] [MPMain   ] [DEBUG] - g_Player: ShowFullScreenWindow
[2014-06-09 21:38:14,489] [Log    ] [MPMain   ] [INFO ] - g_Player: ShowFullScreenWindow switching to fullscreen video
[2014-06-09 21:38:14,490] [Log    ] [MPMain   ] [DEBUG] - Window: MediaPortal.GUI.Video.GUIVideoPlayList deinit
[2014-06-09 21:38:14,511] [Log    ] [MPMain   ] [DEBUG] - TextureManager: CleanupThumbs()
[2014-06-09 21:38:14,526] [Log    ] [MPMain   ] [DEBUG] - Window: MediaPortal.GUI.Video.GUIVideoFullscreen init
[2014-06-09 21:38:14,527] [Log    ] [MPMain   ] [DEBUG] - Loading AR modes from "movies" section...
[2014-06-09 21:38:14,565] [Log    ] [36       ] [DEBUG] - PlaneScene: crop T, B  : 0, 0
[2014-06-09 21:38:14,565] [Log    ] [36       ] [DEBUG] - PlaneScene: crop L, R  : 0, 0
[2014-06-09 21:38:14,566] [Log    ] [36       ] [INFO ] - PlaneScene: video WxH  : 1280x528
[2014-06-09 21:38:14,566] [Log    ] [36       ] [DEBUG] - PlaneScene: video AR   : 80:33
[2014-06-09 21:38:14,567] [Log    ] [36       ] [INFO ] - PlaneScene: screen WxH : 1920x1080
[2014-06-09 21:38:14,567] [Log    ] [36       ] [DEBUG] - PlaneScene: AR type    : Normal
[2014-06-09 21:38:14,567] [Log    ] [36       ] [DEBUG] - PlaneScene: PixelRatio : 1
[2014-06-09 21:38:14,568] [Log    ] [36       ] [DEBUG] - PlaneScene: src        : (0,0)-(1280,528)
[2014-06-09 21:38:14,568] [Log    ] [36       ] [DEBUG] - PlaneScene: dst        : (0,144)-(1920,936)
[2014-06-09 21:38:16,943] [Log    ] [MPMain   ] [INFO ] - Main: Stopping media
[2014-06-09 21:38:16,943] [Log    ] [MPMain   ] [DEBUG] - g_Player.doStop() keepTimeShifting = False keepExclusiveModeOn = False
[2014-06-09 21:38:16,944] [Log    ] [MPMain   ] [INFO ] - g_Player.OnStopped()
[2014-06-09 21:38:16,944] [Log    ] [MPMain   ] [INFO ] - RefreshRateChanger.SetRefreshRateBasedOnFPS: current refreshrate is 23hz - changing it to 50hz
[2014-06-09 21:38:16,945] [Log    ] [MPMain   ] [INFO ] - RefreshRateChanger.SetRefreshRateBasedOnFPS: using internal win32 method for changing refreshrate. current is 23hz, desired is 50
[2014-06-09 21:38:16,945] [Log    ] [MPMain   ] [INFO ] - RefreshRateChanger AdapterOrdinal value is 0
[2014-06-09 21:38:16,946] [Log    ] [MPMain   ] [DEBUG] - CycleRefreshRate: Current MonitorIndex : 0 and current deviceName : \\.\DISPLAY1
[2014-06-09 21:38:17,510] [Log    ] [MPMain   ] [DEBUG] - Main: WM_GETMINMAXINFO Start (MaxSize: 1920x1080 - MaxPostion: 0,0 - MinTrackSize: 2x2 - MaxTrackSize: 1932x1092)
[2014-06-09 21:38:17,511] [Log    ] [MPMain   ] [DEBUG] - Main: WM_GETMINMAXINFO End (MaxSize: 1920x1080 - MaxPostion: 0,0 - MinTrackSize: 1920x1080 - MaxTrackSize: 1920x1080)
[2014-06-09 21:38:17,513] [Log    ] [MPMain   ] [DEBUG] - Main: WM_DISPLAYCHANGE
[2014-06-09 21:38:17,928] [Log    ] [MPMain   ] [INFO ] - CycleRefreshRate: result DISP_CHANGE_SUCCESSFUL for refresh rate change 50Hz
[2014-06-09 21:38:17,928] [Log    ] [MPMain   ] [DEBUG] - CycleRefresh: DWM Detected, performing shenanigans
[2014-06-09 21:38:17,929] [Log    ] [MPMain   ] [INFO ] - RefreshRateChanger.SetRefreshRateBasedOnFPS: dynamic refresh rate change - notify video renderer
[2014-06-09 21:38:18,109] [Log    ] [MPMain   ] [INFO ] - GUIVideoFiles: OnPlayBackStopped idFile=27 timeMovieStopped=9 resumeData= bdtitle=1000
[2014-06-09 21:38:18,110] [Log    ] [MPMain   ] [DEBUG] - GUIVideoFiles: OnPlayBackStopped store resume time
[2014-06-09 21:38:18,111] [Log    ] [MPMain   ] [INFO ] - RadioRecorded:OnPlayRecordingBackStopped Video \\SERVER\Videos\300\300.mkv
[2014-06-09 21:38:18,112] [Log    ] [MPMain   ] [INFO ] - TvRecorded:OnPlayRecordingBackStopped Video \\SERVER\Videos\300\300.mkv
[2014-06-09 21:38:18,112] [Log    ] [MPMain   ] [DEBUG] - [WIFI_REMOTE]  Playback stopped!
[2014-06-09 21:38:18,112] [Log    ] [MPMain   ] [DEBUG] - g_Player.doStop() - stop
[2014-06-09 21:38:18,112] [Log    ] [MPMain   ] [INFO ] - VideoPlayer:ended \\SERVER\Videos\300\300.mkv
[2014-06-09 21:38:18,112] [Log    ] [MPMain   ] [INFO ] - VideoPlayer9: Cleanup DShow graph
[2014-06-09 21:38:18,129] [Log    ] [MPMain   ] [INFO ] - VideoPlayer9: Cleanup Sub/PostProcess
[2014-06-09 21:38:18,129] [Log    ] [MPMain   ] [INFO ] - VideoPlayer9: Cleanup VideoCodec
[2014-06-09 21:38:18,129] [Log    ] [MPMain   ] [INFO ] - VideoPlayer9: Cleanup AudioCodec
[2014-06-09 21:38:18,130] [Log    ] [MPMain   ] [DEBUG] - D3D: OnPaint()
[2014-06-09 21:38:18,134] [Error  ] [MPMain   ] [ERROR] - VideoPlayer9: Exception while cleanuping DShow graph - Unable to cast COM object of type 'System.__ComObject' to interface type 'DirectShowLib.IBaseFilter'. This operation failed because the QueryInterface call on the COM component for the interface with IID '{56A86895-0AD4-11CE-B03A-0020AF0BA770}' failed due to the following error: No such interface supported (Exception from HRESULT: 0x80004002 (E_NOINTERFACE)).    at System.StubHelpers.StubHelpers.GetCOMIPFromRCW(Object objSrc, IntPtr pCPCMD, IntPtr& ppTarget, Boolean& pfNeedsRelease)
   at DirectShowLib.IBaseFilter.EnumPins(IEnumPins& ppEnum)
   at DShowNET.Helper.DirectShowUtil.DisconnectAllPins(IGraphBuilder graphBuilder, IBaseFilter filter)
   at MediaPortal.Player.VideoPlayerVMR9.Cleanup()
[2014-06-09 21:38:18,135] [Log    ] [MPMain   ] [INFO ] - VideoPlayer9: Disabling DX9 exclusive mode
[2014-06-09 21:38:18,135] [Log    ] [MPMain   ] [INFO ] - Main: GUI_MSG_SWITCH_FULL_WINDOWED message is obsolete.
[2014-06-09 21:38:18,136] [Log    ] [MPMain   ] [INFO ] - VideoPlayer9: Cleanup DShow graph
[2014-06-09 21:38:18,136] [Log    ] [MPMain   ] [INFO ] - VideoPlayer9: Cleanup Sub/PostProcess
[2014-06-09 21:38:18,136] [Log    ] [MPMain   ] [DEBUG] - D3D: OnPaint()
[2014-06-09 21:38:18,137] [Error  ] [MPMain   ] [ERROR] - VideoPlayer9: Exception while cleanuping DShow graph - Unable to cast COM object of type 'System.__ComObject' to interface type 'DirectShowLib.IBaseFilter'. This operation failed because the QueryInterface call on the COM component for the interface with IID '{56A86895-0AD4-11CE-B03A-0020AF0BA770}' failed due to the following error: No such interface supported (Exception from HRESULT: 0x80004002 (E_NOINTERFACE)).    at System.StubHelpers.StubHelpers.GetCOMIPFromRCW(Object objSrc, IntPtr pCPCMD, IntPtr& ppTarget, Boolean& pfNeedsRelease)
   at DirectShowLib.IBaseFilter.EnumPins(IEnumPins& ppEnum)
   at DShowNET.Helper.DirectShowUtil.DisconnectAllPins(IGraphBuilder graphBuilder, IBaseFilter filter)
   at MediaPortal.Player.VideoPlayerVMR9.Cleanup()
[2014-06-09 21:38:18,137] [Log    ] [MPMain   ] [INFO ] - VideoPlayer9: Disabling DX9 exclusive mode
[2014-06-09 21:38:18,137] [Log    ] [MPMain   ] [INFO ] - Main: GUI_MSG_SWITCH_FULL_WINDOWED message is obsolete.
[2014-06-09 21:38:18,138] [Log    ] [MPMain   ] [INFO ] - GUIVideoFullscreen:stop
[2014-06-09 21:38:18,138] [Log    ] [MPMain   ] [DEBUG] - Windowmanager: Goto previous window
[2014-06-09 21:38:18,138] [Log    ] [MPMain   ] [DEBUG] - Window: MediaPortal.GUI.Video.GUIVideoFullscreen deinit
[2014-06-09 21:38:18,139] [Log    ] [MPMain   ] [DEBUG] - TextureManager: CleanupThumbs()
[2014-06-09 21:38:18,157] [Log    ] [MPMain   ] [WARN ] - GUIWindow:OnWindowLoaded: 'C:\ProgramData\Team MediaPortal\MediaPortal\Skin\Titan\myvideoplaylist.xml' is missing control id 6 (window property: btnPlayDVD)
[2014-06-09 21:38:18,157] [Log    ] [MPMain   ] [WARN ] - GUIWindow:OnWindowLoaded: 'C:\ProgramData\Team MediaPortal\MediaPortal\Skin\Titan\myvideoplaylist.xml' is missing control id 7 (window property: btnScanNew)
[2014-06-09 21:38:18,157] [Log    ] [MPMain   ] [WARN ] - GUIWindow:OnWindowLoaded: 'C:\ProgramData\Team MediaPortal\MediaPortal\Skin\Titan\myvideoplaylist.xml' is missing control id 8 (window property: btnTrailers)
[2014-06-09 21:38:18,158] [Log    ] [MPMain   ] [WARN ] - GUIWindow:OnWindowLoaded: 'C:\ProgramData\Team MediaPortal\MediaPortal\Skin\Titan\myvideoplaylist.xml' is missing control id 3 (window property: btnSortBy)
[2014-06-09 21:38:18,158] [Log    ] [MPMain   ] [WARN ] - GUIWindow:OnWindowLoaded: 'C:\ProgramData\Team MediaPortal\MediaPortal\Skin\Titan\myvideoplaylist.xml' is missing control id 5 (window property: btnViews)
[2014-06-09 21:38:18,195] [Log    ] [MPMain   ] [DEBUG] - Window: MediaPortal.GUI.Video.GUIVideoPlayList init
[2014-06-09 21:38:18,195] [Log    ] [MPMain   ] [DEBUG] - TextureManager: CleanupThumbs()
[2014-06-09 21:38:18,443] [Log    ] [MPMain   ] [DEBUG] - Main: WM_ACTIVATE (WA_INACTIVE)
[2014-06-09 21:38:18,443] [Log    ] [MPMain   ] [INFO ] - Main: Deactivation request received
[2014-06-09 21:38:18,444] [Log    ] [MPMain   ] [INFO ] - Main: Refresh rate changer running. Ignoring deactivation request
[2014-06-09 21:38:18,444] [Log    ] [MPMain   ] [DEBUG] - D3D: OnLostFocus()
[2014-06-09 21:38:18,446] [Log    ] [MPMain   ] [DEBUG] - Main: WM_ACTIVATE (WA_ACTIVE)
[2014-06-09 21:38:18,446] [Log    ] [MPMain   ] [INFO ] - Main: Activation request received
[2014-06-09 21:38:18,447] [Log    ] [MPMain   ] [DEBUG] - D3D: OnGotFocus()
[2014-06-09 21:38:18,878] [Log    ] [49       ] [DEBUG] - [WIFI_REMOTE]  Stop now-playing update thread
[2014-06-09 21:38:19,971] [Log    ] [MPMain   ] [DEBUG] - VMR9Helper: Playing -> Repainting, Frames 0
[2014-06-09 21:38:29,060] [Log    ] [MPMain   ] [DEBUG] - D3D: OnFormClosing()
[2014-06-09 21:38:29,061] [Log    ] [MPMain   ] [DEBUG] - D3D CleanupEnvironment()
 

xppx

Portal Pro
Joined
September 2, 2007
Messages
78
Points
8
Country flag
Sniplet from the last generated log file - focused on when the error occurs -

I get the error a bit later - after the "VideoPlayer9: Disabling DX9 exclusive mode"

Code:
[2014-06-09 21:44:10,196] [Log    ] [MPMain   ] [INFO ] - VideoPlayer9: Cleanup DShow graph
[2014-06-09 21:44:10,343] [Log    ] [MPMain   ] [INFO ] - VideoPlayer9: Cleanup Sub/PostProcess
[2014-06-09 21:44:10,344] [Log    ] [MPMain   ] [INFO ] - VideoPlayer9: Cleanup VideoCodec
[2014-06-09 21:44:10,344] [Log    ] [MPMain   ] [INFO ] - VideoPlayer9: Cleanup AudioCodec
[2014-06-09 21:44:10,344] [Log    ] [MPMain   ] [INFO ] - Disconnecting all pins from filter DirectSound: Onkyo TX-SR605 [Receiver - Optical] (Realtek High Definition Audio)
[2014-06-09 21:44:10,345] [Log    ] [MPMain   ] [INFO ] - VideoPlayer9: Cleanup AudioRenderer
[2014-06-09 21:44:10,345] [Log    ] [MPMain   ] [INFO ] - VideoPlayer9: Cleanup InterfaceSourceFilter
[2014-06-09 21:44:10,345] [Log    ] [MPMain   ] [INFO ] - VideoPlayer9: Cleanup PostProcess
[2014-06-09 21:44:10,345] [Log    ] [MPMain   ] [INFO ] - VideoPlayer9: Cleanup PostProcess MediaPortal AudioSwitcher
[2014-06-09 21:44:10,346] [Log    ] [MPMain   ] [INFO ] - Disconnecting all pins from filter Enhanced Video Renderer
[2014-06-09 21:44:10,346] [Log    ] [MPMain   ] [DEBUG] - Remove filter from graph: Enhanced Video Renderer 2
[2014-06-09 21:44:10,346] [Log    ] [MPMain   ] [INFO ] - Disconnecting all pins from filter LAV Audio Decoder
[2014-06-09 21:44:10,346] [Log    ] [MPMain   ] [INFO ] - Disconnecting pin Output
[2014-06-09 21:44:10,347] [Log    ] [MPMain   ] [INFO ] -   Not connected
[2014-06-09 21:44:10,347] [Log    ] [MPMain   ] [DEBUG] - Remove filter from graph: LAV Audio Decoder 1
[2014-06-09 21:44:10,347] [Log    ] [MPMain   ] [INFO ] - Disconnecting all pins from filter CoreAVC Video Decoder
[2014-06-09 21:44:10,347] [Log    ] [MPMain   ] [INFO ] - Disconnecting pin Output
[2014-06-09 21:44:10,347] [Log    ] [MPMain   ] [INFO ] -   Not connected
[2014-06-09 21:44:10,367] [Log    ] [MPMain   ] [DEBUG] - Remove filter from graph: CoreAVC Video Decoder 1
[2014-06-09 21:44:10,368] [Log    ] [MPMain   ] [INFO ] - Disconnecting all pins from filter Haali Media Splitter
[2014-06-09 21:44:10,368] [Log    ] [MPMain   ] [INFO ] - Disconnecting pin Video
[2014-06-09 21:44:10,368] [Log    ] [MPMain   ] [INFO ] -   Not connected
[2014-06-09 21:44:10,368] [Log    ] [MPMain   ] [INFO ] - Disconnecting pin Audio
[2014-06-09 21:44:10,368] [Log    ] [MPMain   ] [INFO ] -   Not connected
[2014-06-09 21:44:10,368] [Log    ] [MPMain   ] [DEBUG] - Remove filter from graph: Haali Media Splitter 3
[2014-06-09 21:44:10,368] [Log    ] [MPMain   ] [INFO ] - VideoPlayer9: Cleanup Graphbuilder
[2014-06-09 21:44:10,369] [Log    ] [MPMain   ] [DEBUG] - VMR9: Dispose
[2014-06-09 21:44:10,369] [Log    ] [MPMain   ] [DEBUG] - SubtitleRenderer: starting cleanup
[2014-06-09 21:44:10,369] [Log    ] [MPMain   ] [DEBUG] - SubtitleRenderer: cleanup done
[2014-06-09 21:44:10,369] [Log    ] [MPMain   ] [DEBUG] - VMR9: Inactive
[2014-06-09 21:44:10,378] [Log    ] [MPMain   ] [DEBUG] - PlaneScene: PresentImage() dispose surfaces
[2014-06-09 21:44:10,401] [Log    ] [MPMain   ] [INFO ] - VideoPlayer9: Disabling DX9 exclusive mode
[2014-06-09 21:44:10,401] [Log    ] [MPMain   ] [INFO ] - Main: GUI_MSG_SWITCH_FULL_WINDOWED message is obsolete.
[2014-06-09 21:44:10,401] [Log    ] [MPMain   ] [INFO ] - GUIVideoFullscreen:stop
[2014-06-09 21:44:10,401] [Log    ] [MPMain   ] [DEBUG] - Windowmanager: Goto previous window
[2014-06-09 21:44:10,402] [Log    ] [MPMain   ] [DEBUG] - Window: MediaPortal.GUI.Video.GUIVideoFullscreen deinit
[2014-06-09 21:44:10,403] [Log    ] [MPMain   ] [DEBUG] - TextureManager: CleanupThumbs()
[2014-06-09 21:44:10,404] [Log    ] [MPMain   ] [DEBUG] - Window: MediaPortal.GUI.Video.GUIVideoFiles init
[2014-06-09 21:44:10,450] [Log    ] [MPMain   ] [DEBUG] - D3D: OnPaint()
[2014-06-09 21:44:11,451] [Log    ] [MPMain   ] [DEBUG] - VirtualDirectory: this file is not remote
[2014-06-09 21:44:11,462] [Log    ] [MPMain   ] [DEBUG] - WindowManager: route MediaPortal.GUI.Video.GUIVideoFiles:6->MediaPortal.Dialogs.GUIDialogMenu:2012
[2014-06-09 21:44:11,463] [Log    ] [MPMain   ] [DEBUG] - DialogWindow: MediaPortal.Dialogs.GUIDialogMenu init
[2014-06-09 21:44:12,704] [Log    ] [MPMain   ] [DEBUG] - WindowManager: unroute to MediaPortal.Dialogs.GUIDialogMenu:2012->MediaPortal.GUI.Video.GUIVideoFiles:6
...
[2014-06-09 21:44:12,794] [Log    ] [MPMain   ] [INFO ] - RefreshRateChanger.AdaptRefreshRate: 'auto refreshrate changer' disabled
[2014-06-09 21:44:12,794] [Log    ] [MPMain   ] [INFO ] - g_Player.Play(M:\Clips\The Walking Dead Cold Storage\Webisode 03 The Chosen Ones.mp4 Video)
[2014-06-09 21:44:12,795] [Log    ] [MPMain   ] [DEBUG] - PlayerFactory: Successfully created player instance for file - M:\Clips\The Walking Dead Cold Storage\Webisode 03 The Chosen Ones.mp4
[2014-06-09 21:44:12,795] [Log    ] [MPMain   ] [INFO ] - VideoPlayer:play M:\Clips\The Walking Dead Cold Storage\Webisode 03 The Chosen Ones.mp4
[2014-06-09 21:44:12,799] [Error  ] [MPMain   ] [ERROR] - VideoPlayer9: Exception while creating DShow graph Creating an instance of the COM component with CLSID {E436EBB3-524F-11CE-9F53-0020AF0BA770} from the IClassFactory failed due to the following error: 8000ffff Catastrophic failure (Exception from HRESULT: 0x8000FFFF (E_UNEXPECTED)).    at MediaPortal.Player.VideoPlayerVMR9.GetInterfaces()
[2014-06-09 21:44:12,819] [Log    ] [MPMain   ] [INFO ] - g_Player: ended
[2014-06-09 21:44:12,820] [Error  ] [MPMain   ] [ERROR] - PlaylistPlayer: *** unable to play - M:\Clips\The Walking Dead Cold Storage\Webisode 03 The Chosen Ones.mp4 - skipping track!
 

Sebastiii

Development Group
Joined
November 12, 2007
Messages
16,332
Points
113
Location
France
Country flag
Sorry :)
We can try tomorrow, we need to find the broken commit to be able to analyse it for sure lol

Maybe you can setup on your PC (not the htpc) dev env build to be able to compil source and then it will be faster than me to upload you release build.
In between i will try to create a new 1.6.0 but at a random commit to see if we can start from there or after :)
 

xppx

Portal Pro
Joined
September 2, 2007
Messages
78
Points
8
Country flag
Sorry :)
We can try tomorrow, we need to find the broken commit to be able to analyse it for sure lol

Maybe you can setup on your PC (not the htpc) dev env build to be able to compil source and then it will be faster than me to upload you release build.
In between i will try to create a new 1.6.0 but at a random commit to see if we can start from there or after :)
No problem. Take your time.

During the week I do not have anyway a lot of time in the evening (I spend long days at work).
If you give me the directions on how to setup a local build (incl. all artefacts: project structure, libraries, compiler, (ant?) build scripts) then I will do that.

Thanks again for your effort! :cool:
 

Sebastiii

Development Group
Joined
November 12, 2007
Messages
16,332
Points
113
Location
France
Country flag
New bin to test : https://dl.dropboxusercontent.com/u/10536084/mp/MP1.5/MP.1.6.0Pre-release-MP1-4116-Actors.zip
I have reset the 1.6.0Pre-release to that commit :
Code:
SHA-1: 5f3b5d1c7e8f1c5bc9d453043270b726d19059ec
* MP1-4116-Actors update (fetch fix)
- prevent saving movieinfo to the database on actors fetch while scraping movie before all movieinfo metadata are set
In 1.6.0, we have major update (NET4 and co) some change into EVR related to refresh rate etc.
So will see how it does with this build :)
 

xppx

Portal Pro
Joined
September 2, 2007
Messages
78
Points
8
Country flag
Just back from work.

I'll test the new bin tomorrow if that's ok with you.

And I'll try to get hold of VS 2013... for the dev setup.
Do I need specific acces rights to GIT? Or is setting up a GitHub account enough?
 

Sebastiii

Development Group
Joined
November 12, 2007
Messages
16,332
Points
113
Location
France
Country flag
No need to have a GIT account but you can create one if you want but that's not needed, you can grab source as public and start to build when you have all ready for building :)

No need to have ant for that lol but maybe you can help (for later) the BD-J part where ant and co are needed for building all needed Jar :) (but that not related to MP1 repo :p (for now) )
 

xppx

Portal Pro
Joined
September 2, 2007
Messages
78
Points
8
Country flag
New bin to test : https://dl.dropboxusercontent.com/u/10536084/mp/MP1.5/MP.1.6.0Pre-release-MP1-4116-Actors.zip

In 1.6.0, we have major update (NET4 and co) some change into EVR related to refresh rate etc.
So will see how it does with this build
Worked again late today...

Did test the 1.6.0-pre build. See result.

Just a thought - most probably a stupid question - but how do you manage synchronization in MP? As developer I would look for methods that are running in parallel and do not respect an order when they actually should: the cleanup might take too long (which might cover another issue to be resolved) and the initiation of the next video thread perhaps doesn't wait until the cleanup is finished... (if both methods were synchronized against the default lock manager, they would be slower but never run at the same time and thus avoid a racing condition) - typical side effect is that errors that might appear or not depending on the hardware (number of CPU's, speed) and the system (number of available threads) and the software (each compile might change the behavior a bit). And we see the error appear on the 3rd video for 1.6 in debug, 4th video for 1.7 and 1.8pre in debug, and 2nd video in normal mode...
What do you think?

Result: still error
Code:
MP 1.6 pre - Commit: SHA-1: 5f3b5d1c7e8f1c5bc9d453043270b726d19059ec
Refresh rate changer disabled
Result: Error after start of 3rd video (in 1.7 and 1.8 this happens on the 4th in debug mode and on the 2nd in normal mode)
 
Last edited:
Top