Extensions: A GUI Plugin for MediaPortal's MPEI Installer | Page 27

Discussion in 'Skins and Plugins Installer (MPEI)' started by dukus, January 9, 2010.

  1. seco
    • Team MediaPortal

    seco Development Group

    Joined:
    August 7, 2007
    Messages:
    1,579
    Likes Received:
    897
    Gender:
    Male
    Ratings:
    +1,234 / 4
    Home Country:
    Finland Finland
    Show System Specs
    Seems to be a slight problem when installing non-compatible version:

    I had Online Videos 1.5.0 installed, then there was 1.6.0 and 1.6.1 available. The plugin tries to install the latest version but 1.6.1 is for MP 1.4.0 only and I'm running MP 1.3.0.

    Extensions plugin starts to install but fails silently, there is no message to the user that version is incompatible or that installation failed. After MP restarted, I still had 1.5.0 installed and took a while figure out what was going on.


     
  2. Google AdSense Guest Advertisement



    to hide all adverts.
  3. powermarcel10
    • Team MediaPortal

    powermarcel10 Retired Team Member

    Joined:
    November 30, 2010
    Messages:
    2,839
    Likes Received:
    789
    Gender:
    Male
    Occupation:
    Callcenter Agent
    Location:
    Groningen
    Ratings:
    +1,028 / 4
    Home Country:
    Netherlands Netherlands
    Show System Specs
    Yeah I had this to. I think you need to enable; show only compatible plugins or something like that in the extensions installer.

    But indeed; a pop up would be nice. :)
     
  4. seco
    • Team MediaPortal

    seco Development Group

    Joined:
    August 7, 2007
    Messages:
    1,579
    Likes Received:
    897
    Gender:
    Male
    Ratings:
    +1,234 / 4
    Home Country:
    Finland Finland
    Show System Specs
    I think "compatible" and "stable" plugin options are enabled by default, and I haven't touched these settings.
     
  5. powermarcel10
    • Team MediaPortal

    powermarcel10 Retired Team Member

    Joined:
    November 30, 2010
    Messages:
    2,839
    Likes Received:
    789
    Gender:
    Male
    Occupation:
    Callcenter Agent
    Location:
    Groningen
    Ratings:
    +1,028 / 4
    Home Country:
    Netherlands Netherlands
    Show System Specs
    I will check that when I'm home!
     
  6. ltfearme
    • Premium Supporter

    ltfearme Community Plugin Dev

    Joined:
    June 10, 2007
    Messages:
    6,457
    Likes Received:
    4,241
    Gender:
    Male
    Occupation:
    Software Test Engineer
    Location:
    Sydney
    Ratings:
    +5,385 / 0
    Home Country:
    Australia Australia
    If you have those options then the Api may not work as it did before as it should filter them out.

    I could definitely look at providing a warning popup before trying to install an incompatible plugin. To be honest it should just filter it out regardless of setting enabled unless there is some use case to install a plugin that's not compatible?
     
  7. ltfearme
    • Premium Supporter

    ltfearme Community Plugin Dev

    Joined:
    June 10, 2007
    Messages:
    6,457
    Likes Received:
    4,241
    Gender:
    Male
    Occupation:
    Software Test Engineer
    Location:
    Sydney
    Ratings:
    +5,385 / 0
    Home Country:
    Australia Australia
    New Release available (v1.2.0):
    • Fixed compatibility with MediaPortal 1.4.
    • Updated translations from Transifex.
    Download
     
    • Like Like x 3
  8. ltfearme
    • Premium Supporter

    ltfearme Community Plugin Dev

    Joined:
    June 10, 2007
    Messages:
    6,457
    Likes Received:
    4,241
    Gender:
    Male
    Occupation:
    Software Test Engineer
    Location:
    Sydney
    Ratings:
    +5,385 / 0
    Home Country:
    Australia Australia
    New Release available (v1.2.1):
    • Fixed a bug in Extension GUI Settings where the default settings for a plugin will be loaded instead of the user settings. This occurred if the Skin did not have the 'Restore Defaults' button defined.
    • Updated translations from Transifex.
     
    • Like Like x 2
  9. SpudR
    • Team MediaPortal

    SpudR Documentation Group

    Joined:
    July 27, 2007
    Messages:
    2,604
    Likes Received:
    449
    Occupation:
    CTO, MD
    Location:
    Yorkshire, UK
    Ratings:
    +676 / 2
    Home Country:
    England England
    Show System Specs
    'Wrong file format' errors :(
     
    • Agree Agree x 2
  10. ltfearme
    • Premium Supporter

    ltfearme Community Plugin Dev

    Joined:
    June 10, 2007
    Messages:
    6,457
    Likes Received:
    4,241
    Gender:
    Male
    Occupation:
    Software Test Engineer
    Location:
    Sydney
    Ratings:
    +5,385 / 0
    Home Country:
    Australia Australia
    Last edited: July 3, 2013
  11. RoChess
    • Premium Supporter

    RoChess Extension Developer

    Joined:
    March 10, 2006
    Messages:
    4,182
    Likes Received:
    1,304
    Ratings:
    +1,683 / 2
    The file you gave me before was 678kB, and indeed same 'Wrong file format' error for me when I download it.

    Downloaded it again from the link you just posted and now it is 690kB. Deleted the other commit and reuploaded it. Downloaded it to be sure, and it updated Extensions plugin on this box for me.

    @SpudR, please test to confirm it works for you as well.
     
    • Like Like x 2
Loading...

Users Viewing Thread (Users: 0, Guests: 0)

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice
  • About The Project

    The vision of the MediaPortal project is to create a free open source media centre application, which supports all advanced media centre functions, and is accessible to all Windows users.

    In reaching this goal we are working every day to make sure our software is one of the best.

             

  • Support MediaPortal!

    The team works very hard to make sure the community is running the best HTPC-software. We give away MediaPortal for free but hosting and software is not for us.

    Care to support our work with a few bucks? We'd really appreciate it!