HDPVR2 Dish Network MediaPortal and Me (1 Viewer)

mm1352000

Development Group
  • Team MediaPortal
  • September 1, 2008
    21,571
    8,218
    New Zealand New Zealand
    Country flag
    thank you I have to search those files because i don't have any hauppauge capture folder in program data... on my system it is under : "C:\Users\Public\Hauppauge Capture"

    now i can look at them
    Hmmm, in case it helps:
    1. I assume you're aware that c:\ProgramData is a hidden folder.
    2. I'm using Hauppauge Capture version 1.1.34315 on W7 64 bit.
     

    mrmojo666

    MP Donator
  • Premium Supporter
  • January 24, 2006
    599
    179
    Turin
    Italy Italy
    Country flag
    Hmmm, in case it helps:
    1. I assume you're aware that c:\ProgramData is a hidden folder.
    2. I'm using Hauppauge Capture version 1.1.34315 on W7 64 bit.
    that's why i've found them in users/pulic because i'm on win10 :) and yes they saves the mpeg audio setting in config.xlm node
    thanks

    If you have time, it'd be nice to see a screenshot of the Hauppauge hardware encoder settings page (siena encoder filter?) from GraphStudio, with latest card driver (I'm interested to see if they have exposed any new settings over the last few years ;) ).
    I'm updating everything to latest version, so i can send you screenshots from graphstudio next

    colossus2_driver_1_6_37119.exe
    hauppaugecapture_1_1_37142.exe
    656.png audio_properties.png DNR.png ECp_info.png filter_details.png h264_ecoder.png hauppauge_version.png interfaces.png latency.png MPEGpng.png video_properties.png

    i hope those are the screenshots that you asked, not sure to have understood what you are looking for :)

    Thanks
     

    mm1352000

    Development Group
  • Team MediaPortal
  • September 1, 2008
    21,571
    8,218
    New Zealand New Zealand
    Country flag
    I control DNR and some others by adding some dwords in registry
    Nice.
    Interesting point though: is there a reason you are using sample rate 32k [instead of 48k] for AudEncSample_rate_48?
    I suppose maybe you are using pass-through so it has no effect?
    I just wonder if something like this could be a partial cause for Kodi issues. My understanding is most AC-3 is 48 or 96k, so 48k would be more compatible (no resampling).
     

    mrmojo666

    MP Donator
  • Premium Supporter
  • January 24, 2006
    599
    179
    Turin
    Italy Italy
    Country flag
    Nice.
    Interesting point though: is there a reason you are using sample rate 32k [instead of 48k] for AudEncSample_rate_48?
    I suppose maybe you are using pass-through so it has no effect?
    I just wonder if something like this could be a partial cause for Kodi issues. My understanding is most AC-3 is 48 or 96k, so 48k would be more compatible (no resampling).
    Those values are effective only for tv channel that are not ac3, ac3 is passthrough to .ts other format are reencoded in aac at that rate.

    32 was a try to understand if with a different values than 48 makes changes to the issue i have with kodi client. Thanku for spotting it , now i put again back i i forgot it. But nothing changes on kodi. The issue happens when change channel fom ac3 to aac or aac to ac3, doesn't happen when ac3 to mpeg or mpeg to ac3, i'm pretty sure it is something in kodi, that's why i'm trying to workaround it with avoiding aac.

    Thanks
     
    Last edited:

    CanadianEh

    MP Donator
  • Premium Supporter
  • July 21, 2011
    124
    14
    United States of America United States of America
    Country flag
    @mrmojo666 - thank you so much for the above registry key screenshot, I have matched my Colossus 2 settings to yours which greatly improves performance. Have you found any way to control the contrast / brightness levels of this device though the registry? It seems that the contrast is a little too high on my setup.
     

    mrmojo666

    MP Donator
  • Premium Supporter
  • January 24, 2006
    599
    179
    Turin
    Italy Italy
    Country flag
    @mrmojo666 - thank you so much for the above registry key screenshot, I have matched my Colossus 2 settings to yours which greatly improves performance. Have you found any way to control the contrast / brightness levels of this device though the registry? It seems that the contrast is a little too high on my setup.
    yessssss..... (unfortunately it is something not in the registry)

    I?m using this SuslikV/cfg-cam

    this CLI can setup

    VideoProcAmp_Brightness
    VideoProcAmp_Contrast
    VideoProcAmp_Hue
    VideoProcAmp_Saturation
    VideoProcAmp_Sharpness

    but only on an active pvr session.

    ATM I'm workarounding by call each minute (forever) WebCameraConfig.exe

    what I did is:

    WebCameraConfig.exe --savedev

    to get the config file

    then I setup a task schedule to run webcamera config each minute, so when it is run without parameters it read the standard config file you have saved before (you can change values in the .cfg file, remember to save, at the first exe run it loads them)

    On my tv server running that exe each minutes is not creating any slowness or other side effect.

    PS: i think might be possible to write a server plugin that runs this exe after a channel start....
     

    mrmojo666

    MP Donator
  • Premium Supporter
  • January 24, 2006
    599
    179
    Turin
    Italy Italy
    Country flag
    @CanadianEh I've started writing plugin

    At the moment it calls webcameraconfig.exe each time a timeshift is started.

    Unfortunately I'm stuck in writing the setup section ..it doesn't want to appear in tvservicesetup plugin section.

    So it works only if the webcameraconfig.exe and his cfg file are in c:\plugin\

    I'm going to ask for help in the proper forum section

    Here the code mrmojo666/dsvideocontrol-mp-server-plugin
     

    mrmojo666

    MP Donator
  • Premium Supporter
  • January 24, 2006
    599
    179
    Turin
    Italy Italy
    Country flag
    I managed to make a plugin (with the setup also!!! :D )

    @CanadianEh just in case you would like to have a try
    or someone else with a PVR card :p


    any comment is really appreciated
     

    Users Who Are Viewing This Thread (Users: 0, Guests: 1)

    Top Bottom