IMON IRSS Version (no official version) (1 Viewer)

disaster123

MP Donator
  • Premium Supporter
  • May 14, 2008
    3,546
    432
    Germany Germany
    Country flag
    AW: IMON IRSS Version (no official version)

    could you please post what you've changed? I think there isn't a list of the id codes - just press the button and look into your MP log.
     

    azzuro

    Test Group
  • Team MediaPortal
  • May 10, 2007
    9,604
    5,226
    France - IDF
    France France
    Country flag
    1 : same button name between imon remote and mpcontrol*
    2 : addon button fulscreen work
    3 : addon button caption / subtitle work
    4 : addon context menu in winmenu
    5 : addon button bookmark - i search code for switch view list (filmtrip ...) in explorer -

    i have more work to this file, if anybody have solution - i'm here !!!!
     

    kesar

    MP Donator
  • Premium Supporter
  • August 4, 2008
    154
    7
    Warsaw
    Poland Poland
    Works great for me. Thx from me already in your list.
    The only issue I have is a little slower responsiveness after wake-up. Is there any trick (configuration) I can solve it or I just need to wait for 1.1 version? This is what I read in one of the previous posts by kiwijunglist, right?

    kesar


    Update: I found the solution finally (see link)
    install MPstandbyhandler
    create a batch file with the following lines
    net stop inputservice
    net start inputservice
    place link to the file in exec-line in MPsh
     

    kesar

    MP Donator
  • Premium Supporter
  • August 4, 2008
    154
    7
    Warsaw
    Poland Poland
    Great, everything was working fine until I moved to RC6. Then it stopped. I tried many versions, configuration, copied xml files to many places... nothing helps.

    Here is the MP error.log:
    2010-07-13 23:34:56.906250 [ERROR][MPMain(1)]: MPControlPlugin - LoadRemoteMap(): System.ArgumentException: Requested value 'Open' was not found.
    at System.Enum.Parse(Type enumType, String value, Boolean ignoreCase)
    at MediaPortal.Plugins.MappedKeyCode..ctor(String button, String keyCode) in C:\svnroot\mp-plugins\trunk\plugins\IR Server Suite\MediaPortal Plugins\MediaPortal Plugins\MP Control Plugin\MappedKeyCode.cs:line 59
    at MediaPortal.Plugins.MPControlPlugin.LoadRemoteMap(String remoteFile) in C:\svnroot\mp-plugins\trunk\plugins\IR Server Suite\MediaPortal Plugins\MediaPortal Plugins\MP Control Plugin\MPControlPlugin.cs:line 959

    Am I only one looking at the strange paths starting with C:\svnroot...... it looks suspicious to me.

    And here IR Server log:
    2010-07-13 23:34:39.656250 - Log Opened
    2010-07-13 23:34:39.656250 - IR Server, Version=1.4.2.3664, Culture=neutral, PublicKeyToken=null
    2010-07-13 23:34:39.718750 - Info: Starting IR Server ...
    2010-07-13 23:34:39.718750 - Info: Loading settings ...
    2010-07-13 23:34:40.281250 - Warn: Hauppauge: IrRemote.dll not found
    2010-07-13 23:34:41.828125 - Warn: X10: needed interface not found
    2010-07-13 23:34:41.968750 - Warn: Hauppauge: IrRemote.dll not found
    2010-07-13 23:34:43.062500 - Warn: X10: needed interface not found
    2010-07-13 23:34:43.078125 - Warn: No transmit plugin loaded
    2010-07-13 23:34:43.093750 - Info: Started in Server Mode
    2010-07-13 23:34:43.390625 - Info: Receiver plugin started: "iMon USB"
    2010-07-13 23:34:43.406250 - Info: Receiver plugin started: "Windows Messages"
    2010-07-13 23:34:43.406250 - Info: IR Server started
    2010-07-13 23:34:49.187500 - Debug: Server message received: RegisterClient, Request
    2010-07-13 23:34:49.187500 - Info: Registered a client
    2010-07-13 23:34:49.218750 - Debug: SendTo(RegisterClient, Response, Success)
    2010-07-13 23:34:56.921875 - Debug: Server message received: RegisterClient, Request
    2010-07-13 23:34:56.921875 - Info: Registered a client
    2010-07-13 23:34:56.921875 - Debug: SendTo(RegisterClient, Response, Success)
    2010-07-13 23:35:47.625000 - Info: Unregistered a client
    2010-07-13 23:35:47.937500 - Info: Unregistered a client
    2010-07-13 23:41:11.968750 - Debug: Server message received: RegisterClient, Request
    2010-07-13 23:41:11.968750 - Info: Registered a client
    2010-07-13 23:41:11.968750 - Debug: SendTo(RegisterClient, Response, Success)
    2010-07-13 23:41:13.734375 - Info: Unregistered a client


    I'm lost:
    - what version should I install - the one based on SVN 3561?
    - which xml files to put and where exactly?
    - do I need to have 'custom HID' and 'windows messages' ticked?

    Any help would be appreciated.
     

    azzuro

    Test Group
  • Team MediaPortal
  • May 10, 2007
    9,604
    5,226
    France - IDF
    France France
    Country flag
    you must install 3561, for use imon directly (without Abstract)!
    i have tested 3664 with RC5 and no work without Abstract mode !
    you can use my xml, but i work always for assigned multi command for one button ! you must place in program Data for win7 and user data in XP i think!
    you don't need Windows message, but you can less it!
     

    disaster123

    MP Donator
  • Premium Supporter
  • May 14, 2008
    3,546
    432
    Germany Germany
    Country flag
    AW: IMON IRSS Version (no official version)

    For me it is still working fine.
     

    kesar

    MP Donator
  • Premium Supporter
  • August 4, 2008
    154
    7
    Warsaw
    Poland Poland
    you must install 3561, for use imon directly (without Abstract)!
    i have tested 3664 with RC5 and no work without Abstract mode !
    Thx, azzuro.
    This is exactly what I've done before. I will try one more time from scratch.

    @disaster
    Doesn't it look strange these paths in logs to you?
     

    kesar

    MP Donator
  • Premium Supporter
  • August 4, 2008
    154
    7
    Warsaw
    Poland Poland
    I don't know how it happened - but luckily - I installed IRSS as a service and now everything works great.

    Accept the mistery...

    :D
     

    chemelli

    Retired Team Member
  • Premium Supporter
  • September 28, 2006
    6,159
    2,264
    46
    Milano, Italy
    Italy Italy
    Country flag
    Here is the MP error.log:
    2010-07-13 23:34:56.906250 [ERROR][MPMain(1)]: MPControlPlugin - LoadRemoteMap(): System.ArgumentException: Requested value 'Open' was not found.
    at System.Enum.Parse(Type enumType, String value, Boolean ignoreCase)
    at MediaPortal.Plugins.MappedKeyCode..ctor(String button, String keyCode) in C:\svnroot\mp-plugins\trunk\plugins\IR Server Suite\MediaPortal Plugins\MediaPortal Plugins\MP Control Plugin\MappedKeyCode.cs:line 59
    at MediaPortal.Plugins.MPControlPlugin.LoadRemoteMap(String remoteFile) in C:\svnroot\mp-plugins\trunk\plugins\IR Server Suite\MediaPortal Plugins\MediaPortal Plugins\MP Control Plugin\MPControlPlugin.cs:line 959

    Am I only one looking at the strange paths starting with C:\svnroot...... it looks suspicious to me.
    It's not suspicious if you have sources installed in that path and you are the one compiling and releasing the build like I am :p

    Simone
     

    kesar

    MP Donator
  • Premium Supporter
  • August 4, 2008
    154
    7
    Warsaw
    Poland Poland
    Well, in your case it's fine - I don't mind. :p
    in my case it still looks suspicious. Fortunately I solved it. Thx.
     

    Users Who Are Viewing This Thread (Users: 0, Guests: 1)

    OP Similar threads Forum Replies Date
    T How to add missing buttons IR Server Suite (IRSS) 0
    bigboss97 Does anyone has a SoundGraph imon remote file for MP2 to share? General 0
    Rob Hexenmeister That old chestnut - IMON General Support 10
    T Nochmal Imon Pad und Mediaportal 1 Installationsprobleme? 3
    T Imon Pad mit Mediaportal Allgemeines Supportforum 12
    M Forwarding Cmd Line Arg in IRSS Run Program MediaPortal 1 Plugins 0
    T IRSS not working with ITECIR (Intel NUC7 built-in IR) IR Server Suite (IRSS) 2
    D IRSS Suite not learning remote codes General Support 0
    ajs [WiP] 5044: Upgrade NSIS to actual Version MediaPortal 1 21
    Symphy Version 0.2.9.0 for MediaPortal 1.25 ASIO music player 0
    1gkar A Couple of {On-going} Issues Within Various MP Versions General Support 25
    azzuro [fixed] 5011: Version label in Splash screen - pos, size from skin MediaPortal 1 61
    caveman [solved] Cannot download new version My TVSeries 5
    ajs [WiP] MP1 X64 Version MediaPortal 1 70
    RoChess Splashscreen MePo version Titan Skin Feedback 8
    D how to disengage from one version of a plugin to use another Newcomers Forum 0
    D How to switch versions of Schedules Direct Newcomers Forum 2
    D I just installed MP 1.23. Which version of Schedules Direct should I use, where do I obtain it from Newcomers Forum 6
    Z TV-Service in falscher Version Installationsprobleme? 9
    T Neue Treiber Version 3 für TV-Karte Digital Devices Cine C/C2/T/T2 V7 TV / Streaming 6
    M Version numbers MediaPortal 1 Talk 7
    framug LAVFilter 0.74.1 incorrect version Skins and Plugins Installer (MPEI) 8
    A Problem Windows 10 64 bit prof. Update auf Version 1903(gelöst) Installationsprobleme? 0
    T No TV after updating Windows 10 to latest Version 1903 / OS build 18362.175 (logs attached) General Support 2
    T Issues with MediaPortal not starting correctly using versions after 1.20 Final General Support 6
    Similar threads

























    Top Bottom