IMON support | Page 29

Discussion in 'IR Server Suite (IRSS)' started by chemelli, April 8, 2009.

  1. 1stdead

    1stdead Portal Pro

    Joined:
    February 1, 2008
    Messages:
    1,089
    Likes Received:
    139
    Location:
    Copenhagen
    Ratings:
    +139 / 0
    Home Country:
    Denmark Denmark
    I'm not sure whether you remoed the direct input driver.dll? Mine was not working with this plugin enabled in IRSS, and to delete it.


     
  2. Google AdSense Guest Advertisement



    to hide all adverts.
  3. belcom
    • Team MediaPortal

    belcom Retired Team Member

    Joined:
    February 27, 2009
    Messages:
    154
    Likes Received:
    40
    Gender:
    Male
    Location:
    Leibnitz
    Ratings:
    +42 / 0
    Home Country:
    Austria Austria
    In your "working" logs, your device is found in iMonHidReceiver.log in lines 10 to 19.
    In "non-working" logs, these lines are not there.

    Normally this means that the iMON device (like any other USB HID device) isn't plugged in to your computer.

    Are you still in the runtime where it doesn't work? If yes, does the device show up in Device Manager now?
    Did your here the "USB-Disconnect"-Sound?

    Try watching the Device Manager while starting IR Server, look for changes happen to your receiver.

    If you wish, I could do remote support (with Teamviewer), maybe I can figure something out.
     
    • Like Like x 1
  4. nyt
    • Team MediaPortal

    nyt Retired Team Member

    Joined:
    October 15, 2009
    Messages:
    194
    Likes Received:
    45
    Ratings:
    +47 / 0
    Home Country:
    United States of America United States of America
  5. Dai

    Dai Portal Member

    Joined:
    November 25, 2008
    Messages:
    6
    Likes Received:
    0
    Ratings:
    +0 / 0
    Home Country:
    Irss imon mp xp sos

    Hello Community,

    I'm completely unable to get IRSS to react to either my IMON remote or my MCE Remote.

    I'm Running:

    MP V 1.1 B

    IRSS V 1.4.2 Test Build 3197

    Win XP pro

    Silverstone GD01 HTPC case with integrated remote and LCD

    iMON manager v 7.78.1125

    iMON firmware v 0x389208


    I am trying to get IRSS to allow me to use a standard MCE remote with MP through the iMON IR receiver integrated in my case.

    If i disable the iMON software and plug in the USB IR receiver that came with the MCE remote and set MP to use the MCE remote everything is great out of the box.

    If i disable the MCE remote in MP unplug the USB and enable the imon software i am able to use the Imon remote after loading the mediaportal.imo

    I am unable to get any response at all when using IRSS and i have had no luck at all enabling the LCDto do anything useful at all.

    If i enable the MCE remote in the iMON software and in MP i get a few working buttons but not many, if i fix the mapping manually in iMON to give hotkeys to control MP this sort of works until i open a plugin like My Netflix and then the buttons don't function properly.

    Is there a way with or without IRSS to configure iMON to send along the same commands as the MCE remote receiver?

    IRSS looks like it adds some great functionality to MP I'm really looking forward to sorting this out.

    Help,

    Thanks,

    Dai
     
  6. The_Iceman
    • Premium Supporter

    The_Iceman MP Donator

    Joined:
    April 14, 2008
    Messages:
    165
    Likes Received:
    13
    Location:
    Duisburg
    Ratings:
    +13 / 0
    Home Country:
    Germany Germany
    I've got a similar Problem...

    I installed IRSS as application and disabled the IMON Manager.
    In the configuration panel for IMON USB I enabled the MCE Remote (not the IMON PAD) and disabled Keyboard and Mouse Input.
    In the MediaPortal Config Plugin I've selected the Abstract Remote and ALL Buttons are recognized (e.g. Guide Button is mapped to Guide etc...) BUT after starting MediaPortal some buttons don't work (Guide,Live-TV,DVD-Menue, color buttons)...

    Only the Back button isn't recognized by IRSS...

    Where is the error in my configuration... what did I do wrong?

    Best Regards
    Chris
     
  7. Johan

    Johan Portal Pro

    Joined:
    April 19, 2006
    Messages:
    443
    Likes Received:
    11
    Ratings:
    +11 / 0
    Home Country:
    Sweden Sweden
    7.77 and 7.78 are broken. You should use version <=7.60 (that's what ppl say)
     
  8. sergien

    sergien Portal Member

    Joined:
    September 10, 2008
    Messages:
    5
    Likes Received:
    1
    Ratings:
    +1 / 0
    Home Country:
    Spain Spain
    The funniest of things ...

    Hello, Community!

    I have been trying for almost a year to get this dammed iMon-thing working on Windows XP. I tried everything from tweaking the HID registry settings to the most bizarre solutions I did find in this forum. Finally, as last resort, I've switched to Windows 7 ...

    The result is that now I have a fully functional iMon Pad with no problems at all, working fine and directly out of the box, but the funny thing is that I didn't install any of the Soundgraph drivers ... :confused:

    Nevertheless, thanks to all the developers and helpers in this thread .... :D

    Best regards,
    A (now) very happy user of IIRS!!!

    P.D.: For sake of infromation I've a Silverstone LC16M box with iMon integrated.
     
  9. scma

    scma Portal Pro

    Joined:
    December 24, 2005
    Messages:
    77
    Likes Received:
    4
    Gender:
    Male
    Ratings:
    +4 / 0
    Home Country:
    Sweden Sweden
    Re: The funniest of things ...

    Is that with the iMon pad remote or with a MCE remote?
     
  10. sergien

    sergien Portal Member

    Joined:
    September 10, 2008
    Messages:
    5
    Likes Received:
    1
    Ratings:
    +1 / 0
    Home Country:
    Spain Spain
    iMon Pad remote
     
    • Like Like x 1
  11. daveyboy

    daveyboy Portal Member

    Joined:
    March 15, 2005
    Messages:
    44
    Likes Received:
    0
    Occupation:
    Software Developer
    Location:
    Reading, England
    Ratings:
    +0 / 0
    Hi,

    I've just installed an Antec Veris Multimedia Premier - with iMon Pad. The device is not recognized by IRSS. I read back through this thread and it appears to have a different hardware id.

    I've got 4 HID showing up in device manager - here are their IDs:

    HID\VID_15C2&PID_0045&MI_01\7&E435429&0&0000
    USB\VID_046D&PID_C016\5&1532E701&0&3
    USB\VID_15C2&PID_0045&MI_00\6&A3AB1D0&0&0000
    USB\VID_15C2&PID_0045&MI_01\6&A3AB1D0&0&0001

    iMon firmware version is reported as 0x4502, and i'm running iMon version 7.60.0521.

    I also get this in the IRSS log:

    2010-05-06 17:54:53.750000 - Error: Failed to start receive plugin: "iMon USB"
    2010-05-06 17:54:53.750000 - Error: System.ApplicationException: No iMon devices found!
    at IRServer.Plugin.iMonUSBReceivers.Start() in c:\svnroot\mp-plugins\trunk\plugins\IR Server Suite\IR Server Suite\IR Server Plugins\Imon USB Receivers\PluginBaseInterfaces.cs:line 109
    at IRServer.IRServer.OnStart(String[] args) in c:\svnroot\mp-plugins\trunk\plugins\IR Server Suite\IR Server Suite\IR Server\IR Server\IR Server.cs:line 265

    If there is any other information needed to help, please let me know.

    Many thanks.
     
Loading...

Users Viewing Thread (Users: 0, Guests: 0)

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice
  • About The Project

    The vision of the MediaPortal project is to create a free open source media centre application, which supports all advanced media centre functions, and is accessible to all Windows users.

    In reaching this goal we are working every day to make sure our software is one of the best.

             

  • Support MediaPortal!

    The team works very hard to make sure the community is running the best HTPC-software. We give away MediaPortal for free but hosting and software is not for us.

    Care to support our work with a few bucks? We'd really appreciate it!