Inputdevice Manager for MP2 (1 Viewer)

osre

Retired Team Member
  • Premium Supporter
  • December 14, 2014
    766
    386
    Germany Germany
    If nothing groundbreaking was changed in V2.2.0, then I guess the new version could just work.
    I had to do no modifcations for the V2.1.3 version, except for switching it to .NET V4.7 and raising some API depnency numbers from 1 to 2 (and I guess this wouldnt even havebenn necesarry).
     

    jonathantwynham

    Portal Pro
    March 27, 2013
    79
    2
    36
    United Kingdom United Kingdom
    Hey. I have a Harmony Ultimate setup as a Bluetooth HID keyboard (harmony says it works as Bluetooth or IR but as the IR had a massive lag on MP1 I opted for Bluetooth as it was instant!). Now in MP1 it literally worked out the box when I enabled HID remote. As MP2 doesn't seem to support HID remotes/keyboard input I can't get it working. I've had to reconfigure the buttons via the harmony app. I change the 'browserback' command to 'escape' and 'guide' to 'G' etc. The only thing that alluded me was the 'info' as MP doesn't seem to have a keyboard shortcut (i think MP1 used to be F9) and I couldn't figure out in the harmony app what the physical keyboard 'menu' key is called (the one between the right 'win' and 'ctrl' key) I can't reconfigure it.

    So I tried this plug in, got it installed OK, opened it up, pressed the info button on my harmony and mapped it to key:info and I was quite happy. However MP2 doesn't respond to it.. have I missed something?
     

    ge2301

    MP2 Design
  • Team MediaPortal
  • January 11, 2014
    6,622
    2,387
    Stuttgart
    Germany Germany
    Country flag
    So I tried this plug in, got it installed OK, opened it up, pressed the info button on my harmony and mapped it to key:info and I was quite happy. However MP2 doesn't respond to it.. have I missed something?
    Your remote must be supported to do the mapping. I updated the WIKI for Input devices, please take a look.
     

    Alberto83

    Test Group
  • Team MediaPortal
  • August 7, 2012
    336
    108
    Italy Italy
    I totally forgot about it, my bad. I'm gonna finish the Wiki about User Management and install it :)
     

    Alberto83

    Test Group
  • Team MediaPortal
  • August 7, 2012
    336
    108
    Italy Italy
    @osre @ge2301 I have the same issue I had with the earlier version.
    It works only the first time you set it up. If you close and restart mediaportal it's like it's not reloading mappings until you add a new one.

    Steps to reproduce, for me:
    1. Enter the plugin, map LMENU+L to key:info.
    2. Close mediaportal
    3. Reopen Mediaportal. LMENU+L doesn't work anymore until you remap it. Once you remap it, the earlier mappings pops out and they start to work again.


    I don't know if this has something to do with user management, i'm gonna check the logs and try different things.
     
    Last edited:

    Alberto83

    Test Group
  • Team MediaPortal
  • August 7, 2012
    336
    108
    Italy Italy
    Hello, i made some analysis with process monitor. That's all i can do for now.
    The plugin does indeed write the config file in the right place with user management active. It does search the file in the right profile folder and it does save the configuration.

    When the program loads, it search the config file first on
    C:\ProgramData\Team MediaPortal\MP2-Client\Config\MediaPortal.Plugins.InputdeviceManager.InputmanagerSettings.xml
    and when you log in it does open the file in
    C:\ProgramData\Team MediaPortal\MP2-Client\Config\b9bccb93-008f-4a5b-a85d-f86245cd0137\MediaPortal.Plugins.InputdeviceManager.InputmanagerSettings.xml.

    upload_2018-4-11_13-38-32.png


    The only problem is that it seems somehow not to register the keybindings on subsequent reboots until you first map a new key.
    Is it possible to enable further debugging during the plugin key binding at startup? Or when it's listening and find a new input?


    EDIT: I tried to copy the same InputManagerSettings.xml with the right keybindings in all the directories where it looks for it but still no luck.
     
    Last edited:

    osre

    Retired Team Member
  • Premium Supporter
  • December 14, 2014
    766
    386
    Germany Germany
    @Alberto83 thats starnge. For me the plugin woks fine after restart. It just sometimes stops working while MP2 is running. but that dosn't happen to often for me.
     

    Users Who Are Viewing This Thread (Users: 0, Guests: 1)

    OP Similar threads Forum Replies Date
    hwahrmann [Question] Compatibility Manager for Pugins? MediaPortal 1 7
    T MediaPortal Extensions Manager Fehlermeldung bei Installation einer Erweiterung Installationsprobleme? 1
    rsbrux 1.23.0 MPE Manager Problem with LAV Filters Bugreports 2
    M Unable to map virtual sent keys in the input device management General 6
    Megane Manage Tv Series and Anime in My TVSeries My TVSeries 6
    joecrow 1.22.0 MPE Manager issues. 1.22 5
    G MP 1.21 TVserver race condition when cant delete recording triggered by episode management General Support 0
    high [Evaluate] MP Extension Manager can't download HTTPS links MediaPortal 1 38
    R Verbindungsproblem bei MP Extension Manager Installationsprobleme? 2
    D Large xml database in My Movies Management. I remain unclear on use My Films as bridge to MP2.2 General 9
    joecrow [solved] MP2.2 Input Management General 15
    H [Finished] [MP2-789] Input device manager MediaPortal 2 291
    H [solved] Where is Input Manager General 1
    HTPCSourcer MP2 TV Logo Management General 35
    hounddog How to get My Films working in MP 1.20 My Films 5
    H Genre Management Archive 136
    mp2-ulrich [solved] MP 2.2.3 spielt nur manche Sender Allgemeines Support- und Diskussionsforum 2
    H MP2 database won't keep in synch with recordings General 8
    H [solved] MP2 Wiedergabe von Aufnahmen und Live TV geht nicht Allgemeines Support- und Diskussionsforum 6
    ge2301 [WiP] MP2Web - A platform independent web client for MP2 MediaPortal 2 68
    F Problems with new install of MP2 Newcomers Forum 3
    catalpa Bug MP2-837 Allgemeines Support- und Diskussionsforum 2
    P MP2: US user, OTA - can NOT get SchedulesDirect plugin to work on MP1 or MP2 --> how do I get OTA schedule? General 5
    bigboss97 Does anyone has a SoundGraph imon remote file for MP2 to share? General 0
    ge2301 Android based client for MP2 MediaPortal 2 3
    Similar threads

























    Top Bottom