IR has stopped working (1 Viewer)

rsbrux

Documentation Group
  • Team MediaPortal
  • April 15, 2007
    1,133
    115
    Home Country
    Switzerland Switzerland
    Country flag
    @Stéphane Lenclud
    Since I didn't find any suitable external HW available in Switzerland to replace the non-working internal IR interfaces in my HTPC, I am once again trying to troubleshoot the built-in interfaces, and to this end tried out your HID Demo v1.4.6. Not only does it not see any events from my remote, it doesn't appear to even see the devices which should be receiving them. The onboard CIR I/F on my Intel DH67GD appears to be a Nuvoton SIO chip, VID NTN, PID 0530; the USB IR I/F from the original FSC ScaleoE appears to be VID_05AF, PID_0319. but neither of these appear under Devices in HID Demo. This makes me suspect a driver problem, even though Device Manger shows all devices covered and msinfo32 doesn't show nay problems. I have attached an extract from msinfo32 and a screenshot of the devices tab of HID Demo Do you have any suggestions how I might diagnose the problem?
     

    Attachments

    • HIDdemo.png
      HIDdemo.png
      72.6 KB
    • msinfo32.txt
      35.3 KB

    Stéphane Lenclud

    Development Group
  • Team MediaPortal
  • April 29, 2013
    2,576
    1,294
    Home Country
    Germany Germany
    Country flag
    @Stéphane Lenclud
    Since I didn't find any suitable external HW available in Switzerland to replace the non-working internal IR interfaces in my HTPC, I am once again trying to troubleshoot the built-in interfaces, and to this end tried out your HID Demo v1.4.6. Not only does it not see any events from my remote, it doesn't appear to even see the devices which should be receiving them. The onboard CIR I/F on my Intel DH67GD appears to be a Nuvoton SIO chip, VID NTN, PID 0530; the USB IR I/F from the original FSC ScaleoE appears to be VID_05AF, PID_0319. but neither of these appear under Devices in HID Demo. This makes me suspect a driver problem, even though Device Manger shows all devices covered and msinfo32 doesn't show nay problems. I have attached an extract from msinfo32 and a screenshot of the devices tab of HID Demo Do you have any suggestions how I might diagnose the problem?
    You need to tick the devices you want to use in HID Demo. Those IrDeviceV2 for instance. Then you should receive the reports from your IR remote.
     

    rsbrux

    Documentation Group
  • Team MediaPortal
  • April 15, 2007
    1,133
    115
    Home Country
    Switzerland Switzerland
    Country flag
    Thanks, but I already tried that. The first 12 "IrDeviceV2" entries produced no messages at all. The last 2 (labelled "Mouse") produced messages at a rate which caused the HID Demo UI to become unresponsive. The only possible source for these messages was the RF remote I was using to operate the HID Demo UI. Why should an RF device appear under this device ID, and why should the IR devices I was looking for appear under the same device ID? It would be easier if I could decouple the operation of the HID Demo UI from the signals to be examined, but that will be difficult if they are consolidated under some other, composite or virtual, device. I tried running HID Demo from a Remote Desktop session, but then it didn't see any devices at all. Any other suggestions?
     

    Users who are viewing this thread

    Similar threads

    I have now connected the IR Receiver from the HAMA Remote and enabled the HDI in Remotes. It will worke
    I have now connected the IR Receiver from the HAMA Remote and enabled the HDI in Remotes. It will worke
    Hello I used SerialUIR on my old XP HTPC. But unfortunately I can't get it to work right now. I plugged the COM plug of the old...
    Replies
    4
    Views
    787
    Thx, great resource! (and all the best the power button didn't do anything when I pressed it...:whistle:) It is certainly usefull and I'll dig into it later, but actually I was referring to what MP2 is supposed to do with the button presses, so I was looking for a list of keyboard shortcuts to see which ones "match" between MCE and...
    Thx, great resource! (and all the best the power button didn't do anything when I pressed it...:whistle:) It is certainly usefull...
    I hope somebody has a few pointers as to what I could try, before I do a support request with Hauppaughe. For hardware details on...
    Replies
    11
    Views
    5K
    Just gonna add my 2 cents worth here. I have the Inteset PC-IRS5-01 IR Receiver and it installed fine, as per their instructions. However I did encounter an issue getting my remote, a HP MCE Media Centre remote (RC6), to work as an expected. This, I eventually figured out, was due to the tuner card I was using at the time having a...
    Just gonna add my 2 cents worth here. I have the Inteset PC-IRS5-01 IR Receiver and it installed fine, as per their instructions...
    I have two Dell 990s, one is my MP player machine, the other the MP video recorder/server. Purchased Inteset USB IR receiver...
    Replies
    4
    Views
    5K
    ...which is exactly why I've asked for log files. I want to see: Whether Windows updates were installed recently, and if yes, which ones. Which files Windows is loading as the driver for the receiver. I've seen cases where security software entangled itself with remote control receiver and/or tuner drivers and caused them to stop...
    ...which is exactly why I've asked for log files. I want to see: Whether Windows updates were installed recently, and if yes...
    Hey, I've got a pretty weird issue with my MCE remote that worked well for years. But somehow it suddenly stopped working - not...
    Replies
    12
    Views
    5K
    That means you probably have some other software installed/running which is stealing the "focus" (on top position) from MP. Remote controls usually only work with the program that has the focus. In other words: if MP doesn't have the focus, it's no surprise that the remote control doesn't work. If I were you I would check your other...
    That means you probably have some other software installed/running which is stealing the "focus" (on top position) from MP. Remote...
    When I watch a video for some time, let's say an hour, and I stop playback, the navigation buttons stops working until I use a...
    Replies
    2
    Views
    2K
    Top Bottom