IR has stopped working (1 Viewer)

rsbrux

Documentation Group
  • Team MediaPortal
  • April 15, 2007
    1,053
    101
    Switzerland Switzerland
    Country flag
    My HTPC recently stopped responding to IR signals. At first I suspected a HW problem, but the problem remains with two different IR sources (one an original MCE remote with fresh batteries) and with two different IR receivers (one the onboard CIR decoder on my motherboard, the other the USB IR I/F from my HTPC case.
    The next logical suspect was a SW problem, but I can find no evidence of SW changes around the time the problem appeared. Device Manager shows all of the recognized HID devices as working normally.
    Fortunately, I can still operate MP via either of two different RF keyboards (one using a USB dongle, the other using the built-in keyboard I/F of the HTPC case).
    In the absence of any better indication of where the fault may lie, I am toying with the following two possible courses of action:
    1. Install MP2. If it shows the same problem, then the cause is presumably at a deeper (e.g. system) level.
    2. Reinstall the entire HTPC. Since I am still running Windows 7, whose support will soon end, I will have to do this soon anyway.
    Of course, I would be much happier to clearly identify the cause of the problem.
    Can anyone suggest any more precise diagnostic or troubleshooting procedures?
     

    rsbrux

    Documentation Group
  • Team MediaPortal
  • April 15, 2007
    1,053
    101
    Switzerland Switzerland
    Country flag
    P.S. To answer my own question, a little more research has turned up Stéphane Lenclud's HID Demo. Thanks Stéphane! I'll see what it shows.
     

    rsbrux

    Documentation Group
  • Team MediaPortal
  • April 15, 2007
    1,053
    101
    Switzerland Switzerland
    Country flag
    HID Demo doesn't see anything from the remote, just from the keyboard. As I am reluctant to believe this is a HW problem (see above) is there any way to find out what is wrong at deeper SW layers (e.g. driver, OS)?
     

    CyberSimian

    Test Group
  • Team MediaPortal
  • June 10, 2013
    2,188
    1,343
    Southampton
    United Kingdom United Kingdom
    Country flag
    My HTPC recently stopped responding to IR signals.
    Both of the USB IR receivers that I own have red LEDs that illuminate momentarily when the HTPC powers on (presumably when Windows is querying the device), and illuminate when they receive a signal from the remote control. Does either of your IR receivers do this?

    The green marble button on an MCE remote starts WMC or MP from the desktop. For MP, the code that does this is different from the code that responds to the remote when MP is running. Do either of your remotes start MP from the desktop?

    The symptoms of your problem are really puzzling. It is not obvious what the cause might be.

    -- from CyberSimian in the UK
     

    rsbrux

    Documentation Group
  • Team MediaPortal
  • April 15, 2007
    1,053
    101
    Switzerland Switzerland
    Country flag
    @CyberSimian
    Thanks for responding. Unfortunately, neither of my IR receivers have such a helpful indicator LED. Since @Stéphane Lenclud 's HID Demo sees nothing I presume that the signals are being blocked in the OS, even though I don't find any updates which coincide with the start of the problem. I have lots of "recommended" updates which I haven't installed, as I usually install only the "important" or "Security" updates. I also have two uninstalled "optional" (but not "recommended") updates pertaining to IR, but they are quite old, so I can't imagine why they should suddenly become necessary. Since I have little to lose at this point, I will start installing them one by one to see what happens.
     

    rsbrux

    Documentation Group
  • Team MediaPortal
  • April 15, 2007
    1,053
    101
    Switzerland Switzerland
    Country flag
    In desperation I have now installed an up-to-date Windows 8.1 Pro x64 (from scratch, no upgrade) and MP 1.26, but my built-in IR interface is still unresponsive.
    Worse still, all of my RF remotes are now causing double triggers.
     

    CyberSimian

    Test Group
  • Team MediaPortal
  • June 10, 2013
    2,188
    1,343
    Southampton
    United Kingdom United Kingdom
    Country flag
    my built-in IR interface is still unresponsive. Worse still, all of my RF remotes are now causing double triggers.
    My instant reaction to your post is that you are trying to use remote controls that are all horribly non-standard, so it is perhaps no surprise that they do not work correctly, or do not work at all. :cry:

    Hardly anyone uses RF remote controls, and even fewer use IR remote controls where the IR receiver is part of the motherboard.

    I can understand that you want to use the hardware that you already have. This provides the capabilities that you want (e.g. RF does not require line of sight), and avoids generating yet more redundant hardware that must be recycled somewhere. But in a case like this I would start with something that is known to work correctly with MP, so that you can at least use your system. Then you can at your leisure try to discover why these esoteric remotes are not working.

    The most standard remote control supported by MP is an MCE RC6 remote control with its matching IR receiver connected via USB. I would suggest purchasing a remote plus receiver together, and using that. This HP set is new, and (allegedly) available from the UK (rather than China).

    My view: we all waste far too much of our lives trying to get software and hardware to work. If there is a simple solution that provides most of what I want, I would choose that, rather than banging my head against a brick wall for weeks or months. But opinions differ...

    -- from CyberSimian in the UK
     

    azzuro

    Test Group
  • Team MediaPortal
  • May 10, 2007
    9,832
    5,498
    France - IDF
    France France
    Country flag
    i'm agree with @CyberSimian i have Imon remote, but moved to RC6 universal remote, because the Imon driver was very crappy.

    i suggest to have "official' RC6 support.
     

    rsbrux

    Documentation Group
  • Team MediaPortal
  • April 15, 2007
    1,053
    101
    Switzerland Switzerland
    Country flag
    @CyberSimian thanks for your encouragement! ;-}
    I do have standard equipment. I have been using the built-in USB IR receiver that came with my FSC Scaleo E since 2005 with the included MCE RC6 remote and various emulators of same. A few years ago I switched to using the built-in CIR interface on the Intel motherboard I installed to upgrade my HTPC about 8 years ago, because it supported waking up the HTPC, which the FSC IR I/F couldn't. I also have 3 RF keyboards. One of them came with the Scaleo E and uses a built-in USB I/F, the other 2 have dongles. Except for my brief complaint above, which was caused by my own misconfiguration of the HID options in MP (which I will document in the Wiki), they have always worked fine. All of the IR devices (including the original MCE RC6 remote) stopped working at the same time. If only the motherboard I/F or the USB I/F had been affected, I would have assumed defective HW. However, since both stopped working simultaneously, I suspect a SW problem. I am not blaming MP. In fact nothing had changed in my MP installation when the problem occurred, so I rather suspect a Windows update as the cause. I was hoping that a clean OS installation would resolve the problem, but so far, no joy. In the worst case, I will get myself a new external MCE IR receiver, but this will only complicate my installation and make it uglier, so I am reluctant to do so unless I have exhausted all hope of getting the built-in I/Fs to work.
     

    CyberSimian

    Test Group
  • Team MediaPortal
  • June 10, 2013
    2,188
    1,343
    Southampton
    United Kingdom United Kingdom
    Country flag
    I also have 3 RF keyboards.
    RF keyboards are quite common ( I have one myself (y) ). But RF remote controls are relatively rare (the Emprex is one that comes to mind). You did not mention that your RF devices are keyboards. o_O

    So, is the situation now that you have solved the problem with the RF keyboards, but the MCE RC6 remote control still does not work (either via the built-into-the-motherboard IR receiver, or via the USB IR receiver)?

    Look in Windows "Device Manager" to see if you can identify the entries for the motherboard IR receiver or for the USB IR receiver. On my system there are multiple entries, so it is quite difficult to be sure which entry applies to which device. Unplug all non-essential HID devices before doing this (although you will need to retain one mouse so that you can navigate "Device Manager").
    • If you can identify the motherboard IR receiver, what name is shown in "Device Manager" and what driver does it use?
    • If you can identify the USB IR receiver, what name is shown in "Device Manager" and what driver does it use?
    If the motherboard IR receiver and the USB IR receiver are both MCE RC6 IR receivers, they should both be described as a Microsoft eHome Infrared Transceiver.

    -- from CyberSimian in the UK
     

    Users who are viewing this thread

    Similar threads
    OP Title Forum Replies Date
    rsbrux Extensions Manager has outdated version info for the Extensions plug-in Installation, configuration support 2
    bigboss97 Does anyone has a SoundGraph imon remote file for MP2 to share? General 0
    F MCE Remote has no focus General 6
    A UK - BBC2 EPG suddenly has several programs daily with 'No information' Electronic Program Guide 57
    CyberSimian Has anyone ever seen a multichannel-audio icon for TV? Watch / Listen Media 15
    Lichloathe MP2 - V2.3 Long delay between stopping a movie/episode and replaying. General 12
    Scheibes MP2 - V2.3 2. Client stops video on 1. Client Submit: Bug Reports 10
    C Music player: stop during playback, and later restart from that spot MediaPortal 1 Talk 0
    D wintv doesn’t stop recording on time Newcomers Forum 6
    toricred Using TMM, How to Stop Importer From Going to The Movie Database for Data General 1
    mickb [solved] Mediaportal Stops working General Support 5
    D [solved] Movie artwork download stopped working Submit: Bug Reports 9
    M MP 2.2.3 Unable to play .ts recordings and MediaPortal stops working for TV viewing General 31
    ajs [solved] 4982: Why this error hard stop when Mediaportal start? MediaPortal 1 3
    2BitSculptor MP 1.23.. music stops playing General Support 6
    M MP1 stops responding after Starting Plugins General Support 14
    fredco [solved] Large import not working Moving Pictures 15
    W Recordings will not stop General Support 8
    S [solved] Live TV playing stopped General 13
    R [solved] Watching a record during recording stops sometimes 2.2 Archive 30
    N [confirm] Calling RemoveScheduleForProgramAsync does not stop the recording if it is currently in progress MediaPortal 2 1
    N [confirm] Playing a recording, then pressing stop does not leave cursor on the recording MediaPortal 2 21
    N [will not fix] Changed settings do not take effect until MP2-Client is stopped and restarted. Submit: Bug Reports 4
    D Skip to end/live during dvbip recording causes it to stop playing instead. General Support 15
    Glith Sound stops working after first playback 1.21 88

    Similar threads

    Top Bottom