Operating System IR Receiver (USB) not functioning after standby (1 Viewer)

Brudertac

MP Donator
  • Premium Supporter
  • October 26, 2006
    978
    277
    Augsburg
    Germany Germany
    @HTPCSourcer

    do u use the Remote to wakeup your HTPC? Is that Working and THEN the remote is not working anymore? (This is what happens on my sys)
     

    HTPCSourcer

    MP2 Product Manager
  • Team MediaPortal
  • May 16, 2008
    11,431
    2,333
    Germany Germany
    Country flag
    do u use the Remote to wakeup your HTPC?
    No, that's one of the things I need to fix. Currently using a Harmony 555 and can't get it set up to wake the HTPC (other than some Help cycles, which has no WAF).

    Is that Working and THEN the remote is not working anymore? (This is what happens on my sys)
    However, I have some MCE-compatible remotes lying around, which can wake up the PC - without affecting the receiver's functionality then. So your symptoms are again different from what I observe here.
     

    HTPCSourcer

    MP2 Product Manager
  • Team MediaPortal
  • May 16, 2008
    11,431
    2,333
    Germany Germany
    Country flag
    I have some MCE-compatible remotes lying around, which can wake up the PC - without affecting the receiver's functionality then.
    The behavior is consistent. Again no problem this morning. PC was in standby from ca. 22:00 to 04:15 and then again from ca. 4:15 to 07:00. It is difficult to work on resolving the issue if it is not occuring...
     

    HTPCSourcer

    MP2 Product Manager
  • Team MediaPortal
  • May 16, 2008
    11,431
    2,333
    Germany Germany
    Country flag
    When starting the PC this morning at 07:00, the IR Receiver was still working, i.e. after a ~6 hr pause from 22:00 to 4:00. However, when I restarted the PC this afternoon at around 17:00 the receiver was dead.

    So a 6 hr standby is no enough to trigger the non-functionality, but 10 hr is. Very odd...
     

    HTPCSourcer

    MP2 Product Manager
  • Team MediaPortal
  • May 16, 2008
    11,431
    2,333
    Germany Germany
    Country flag
    One new small piece of information: As part of setting up a new Harmony remote, I initially set the remote to shut off the PC (I.e. standby) when switching off TV and AVR. To my surprise it was then no longer possible to wake the PC with my working remote - the receiver was not opeational , which I could confirm when waling the PC up manually.

    In essence, if the receiver is dead upon resume it has been since entering the standby. I read some reports about issues with the USB stack of Windows but it's merely a hypothesis.
     

    Lightning303

    MP Donator
  • Premium Supporter
  • September 12, 2009
    798
    577
    Germany Germany
    Country flag
    Hey,
    I had the same issue with my IR receiver, howerver was able to fix it by connecting it to a usb hub. As you already mentioned you had no luck with this, i didnt comment earlier.
    Today however i had a similar problem with an arduino i had connected to my htpc and wanted to use after resume. Connecting it to the same hub did not solve the problem however.
    I was able to fix it by disabling power saving features in windows. Thought i leave this info here for you to test on your system.

    Go into your energy settings, and go to the advanced settings. There you will find a USB Settings option, disable selective usb supsend.
    Then go into your device manager and find out on which usb root your device is connected (using the devices by connection view), go into the settings of this usb root, go to the energy tab and disable the function to disable usb devices to save energy.
    Lastly apply this regestry key
    Code:
    [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\services\USB]
    "DisableSelectiveSuspend"=dword:00000001
    I did all these 3 steps in one go, restarted my htpc and my usb device worked after a hibernate/resume cycle again. Not sure if I needed all these steps or just one of them though.

    Hope this helps.
     

    HTPCSourcer

    MP2 Product Manager
  • Team MediaPortal
  • May 16, 2008
    11,431
    2,333
    Germany Germany
    Country flag
    Funny coincidence.

    Then go into your device manager and find out on which usb root your device is connected (using the devices by connection view), go into the settings of this usb root, go to the energy tab and disable the function to disable usb devices to save energy.
    I did this some three days ago and since then the receiver keeps staying operational after resume. However, I have not extensively tested this. It simply was there each time the PC woke up again.

    But the other setting(s) are certainly interesting. I was not aware that ther was a general way of deactivating energy saving for USB devices. Actually I don't think the option exists under Windows 10, but the registry setting may be active. If issues reoccur I will test it.
     
    Last edited:

    Users Who Are Viewing This Thread (Users: 0, Guests: 1)

    Top Bottom