Lan Access issues

Discussion in 'MPExtended' started by asagala, March 18, 2012.

  1. asagala

    asagala Portal Pro

    Joined:
    December 13, 2008
    Messages:
    118
    Likes Received:
    20
    Location:
    Montreal
    Ratings:
    +20 / 0
    Home Country:
    Canada Canada
    Hi. just installed MPExtended 0.43. everything seems to be working fine on my machine where MP is located ( I used the test links). However when I try to access the test links (http://192.168.1.100:4322/MPExtended/MediaAccessService/json/GetServiceDescription) from another machine on my network it timeouts.

    Did a netstat -na and I see that the port 4322 is open on 0.0.0.0 so the service is listening.

    Any ideas?


     
  2. Google AdSense Guest Advertisement



    to hide all adverts.
  3. sjevtic
    • Premium Supporter

    sjevtic MP Donator

    Joined:
    January 16, 2012
    Messages:
    114
    Likes Received:
    29
    Gender:
    Male
    Occupation:
    Engineer
    Location:
    Chicago, IL
    Ratings:
    +29 / 0
    Home Country:
    United States of America United States of America
    Show System Specs
    Have you verified that firewall settings are not preventing connection to the service from an external machine? As far as I know, the core MPExtended services (i.e., everything but WebMediaPortal) are implemented on an internal HTTP server independent from IIS, so IIS settings should be out of the questions for this.

    Sasha
     
  4. asagala

    asagala Portal Pro

    Joined:
    December 13, 2008
    Messages:
    118
    Likes Received:
    20
    Location:
    Montreal
    Ratings:
    +20 / 0
    Home Country:
    Canada Canada
    Yes I did. Even added an explicit exception in the Firewall port 4322.
     
  5. Oxan
    • Premium Supporter

    Oxan Retired Team Member

    Joined:
    August 29, 2009
    Messages:
    1,730
    Likes Received:
    1,024
    Gender:
    Male
    Ratings:
    +1,115 / 2
    Home Country:
    Netherlands Netherlands
    This looks like a firewall issue indeed. Do you use Windows firewall or an external firewall (maybe built into your antivirus)?
     
  6. asagala

    asagala Portal Pro

    Joined:
    December 13, 2008
    Messages:
    118
    Likes Received:
    20
    Location:
    Montreal
    Ratings:
    +20 / 0
    Home Country:
    Canada Canada
    Windows 7 firewall. Ill check again tonight. 4322 open for TCP right?
     
  7. sjevtic
    • Premium Supporter

    sjevtic MP Donator

    Joined:
    January 16, 2012
    Messages:
    114
    Likes Received:
    29
    Gender:
    Male
    Occupation:
    Engineer
    Location:
    Chicago, IL
    Ratings:
    +29 / 0
    Home Country:
    United States of America United States of America
    Show System Specs
    If it still doesn't work after verifying that 4322/TCP is open, as a test, take MPExtended out of the picture. Stop the MPExtended service, and use netcat to listen on the same port. On another machine on your network (e.g., the one you were trying to access MPExtended), try to use netcat as a client to connect to the listening instance on your HTPC. It is a good test, as it bisects the problem space: if the test works, you know the problem is related to MPExtended. If it fails, you know the problem is related to network configuration.

    Sasha
     
  8. lodale

    lodale Portal Pro

    Joined:
    April 9, 2009
    Messages:
    245
    Likes Received:
    9
    Ratings:
    +19 / 1
    Home Country:
    Norway Norway
    Try this site to see if your port 8080 is open from external adresses
    http://www.canyouseeme.org/
    I had to manually open the port (traffic in and out on my Win 7 MP server), You also need to do portforwarding on your router (the ip adress on your MP server to port 8080 (give the MP server dynamic IP adress).
    Its working great for me
     
  9. Oxan
    • Premium Supporter

    Oxan Retired Team Member

    Joined:
    August 29, 2009
    Messages:
    1,730
    Likes Received:
    1,024
    Gender:
    Male
    Ratings:
    +1,115 / 2
    Home Country:
    Netherlands Netherlands
    Yes.
    8080 is only for WebMP, while this thread is about the service.
     
  10. asagala

    asagala Portal Pro

    Joined:
    December 13, 2008
    Messages:
    118
    Likes Received:
    20
    Location:
    Montreal
    Ratings:
    +20 / 0
    Home Country:
    Canada Canada
    Firewall issue. Must of created the firewall rule wrong. Weak....
     
Loading...

Users Viewing Thread (Users: 0, Guests: 0)

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice
  • About The Project

    The vision of the MediaPortal project is to create a free open source media centre application, which supports all advanced media centre functions, and is accessible to all Windows users.

    In reaching this goal we are working every day to make sure our software is one of the best.

             

  • Support MediaPortal!

    The team works very hard to make sure the community is running the best HTPC-software. We give away MediaPortal for free but hosting and software is not for us.

    Care to support our work with a few bucks? We'd really appreciate it!