[fixed] live Tv freeze - 15- --> 30+ helps (3 Viewers)

peque

Moderator - Spanish Forums
  • Premium Supporter
  • August 4, 2007
    859
    98
    Spain Spain
    Country flag
    Sorry to maybe introduce a new topic in this thread... or not...

    I've got this kind of log every second for some of my regular OPEN DVB-t channels:

    Code:
    21-10-2011 09:22:19.596 [123c]vid:Timestamp discontinuity, TsDiff 680.000 ms, TsMeanDiff 40.000 ms, samples 7104
    21-10-2011 09:22:20.237 [123c]vid:Timestamp discontinuity, TsDiff 680.000 ms, TsMeanDiff 40.000 ms, samples 7120
    21-10-2011 09:22:20.877 [123c]vid:Timestamp discontinuity, TsDiff 680.000 ms, TsMeanDiff 40.000 ms, samples 7136
    21-10-2011 09:22:21.519 [123c]vid:Timestamp discontinuity, TsDiff 680.000 ms, TsMeanDiff 40.000 ms, samples 7152
    21-10-2011 09:22:22.154 [123c]vid:Timestamp discontinuity, TsDiff 680.000 ms, TsMeanDiff 40.000 ms, samples 7168
    21-10-2011 09:22:22.798 [123c]vid:Timestamp discontinuity, TsDiff 680.000 ms, TsMeanDiff 40.000 ms, samples 7184
    21-10-2011 09:22:23.463 [123c]vid:Timestamp discontinuity, TsDiff 680.000 ms, TsMeanDiff 40.000 ms, samples 7200
    21-10-2011 09:22:24.078 [123c]vid:Timestamp discontinuity, TsDiff 680.000 ms, TsMeanDiff 40.000 ms, samples 7216
    21-10-2011 09:22:24.717 [123c]vid:Timestamp discontinuity, TsDiff 680.000 ms, TsMeanDiff 40.000 ms, samples 7232
    21-10-2011 09:22:25.357 [123c]vid:Timestamp discontinuity, TsDiff 680.000 ms, TsMeanDiff 40.000 ms, samples 7248
    21-10-2011 09:22:25.997 [123c]vid:Timestamp discontinuity, TsDiff 680.000 ms, TsMeanDiff 40.000 ms, samples 7264
    21-10-2011 09:22:26.637 [123c]vid:Timestamp discontinuity, TsDiff 680.000 ms, TsMeanDiff 40.000 ms, samples 7280
    21-10-2011 09:22:27.277 [123c]vid:Timestamp discontinuity, TsDiff 680.000 ms, TsMeanDiff 40.000 ms, samples 7296
    21-10-2011 09:22:27.941 [123c]vid:Timestamp discontinuity, TsDiff 680.000 ms, TsMeanDiff 40.000 ms, samples 7312
    21-10-2011 09:22:28.557 [123c]vid:Timestamp discontinuity, TsDiff 680.000 ms, TsMeanDiff 40.000 ms, samples 7328
    What do they mean? As you can see, they appear at a regular rate of around 600 ms...

    I've found this while trying to troubleshoot a strange problem that I would describe as weak signal (artifacts in video, reverb repeated audio frames, that sometimes leads in MediaPortal UI restart) in some channels... BUT it's definetely nothing to do with signal strengh, as I don't see problems analyzing live ts with some tools (TransEdit inside DVBViewer for example). I can watch that channels in DVBViewer, in fact. Some other data:

    - it only affects HD channels. SD are OK.
    - It's quite random. I can watch TV with no problem for days, and then, suddenly, it starts happening, then it cures itself.
    - I've been able to reproduce the problem also in HD DVB-s channels. So definetely not a signal problem, also tvcards seem not guilty.
    - I've been suffering this from 1.1.0. I can't remember to have changed anything in my system when it started to happen.
    - I can see the log you can see above always, even when no artifacts... I just put it there in case it helps, but it maybe have nothing to do with the artifacts
    - No strange log in tswriter.log.
    - I've tried Cyberlink PowerDVD 11 and Lav Video last month or so, same artifacts...
    - I'll try to post tsreader log next time it happens, but as every time you start MP, tsreader for that day is overwriten, it's been hard to get...

    If I should open a new thread please tell me and I'll do so.

    Thanks a lot.

    EDIT: FORGET about all the above. I've been able to troubleshoot it in more detail this afternoon, as the problem has appeared quite often... and I can see I've got this problems with virtually ANYTHING I do in my PC. Sometimes my PC just "hangs" itsef for some seconds... :(, same HTPC that has been working OK for more than 2 years...

    Now... how could I find the source of the problem? It will be hard and take time that I don't have... :(

    Thanks again.
     

    mr viggo

    MP Donator
  • Premium Supporter
  • March 1, 2008
    500
    68
    Sweden Sweden
    Ok, here goes... Multi seat, 2 floppydtvs. Server on 24/7. UNC paths

    Been experiencing freezes in live tv since 1.2b but now I'm on 1.2.1. I've tried everything I can think of and are all out of ideas to fix this. The freezes only occurs in the beginning of starting live tv, often around 1-3 minutes into a program. So over the past months I haven't been able to narrow it down any further than this.

    Codecs makes no difference (tried pdvd and ms) (ffdshow, lav and mpaudiodec). HD and SD both freeze. FTA and scramled both freeze. Fresh boot - still the same, etc. Debug mode - still freeze, so no plugins are triggering it.

    Watching other media from the server never freezes, ever. I can watch series for hours and then turn tv on to get the freeze. -15sec doesn't help but stop timeshift and restart tv does. Maybe I get a second freeze and a third but eventually live tv works and can go for hours without a glitch after that.

    I have tried to find the cause in the logs by myself before but they don't make me any smarter. Perhaps not the best log attached but can give better ones if needed.

    Please please make this go away, it wasn't always like this
     

    Attachments

    Owlsroost

    Development Group
  • Team MediaPortal
  • October 28, 2008
    5,540
    5,038
    Cambridge
    United Kingdom United Kingdom
    Country flag
    Is it more reliable using RTSP ?

    Does pausing live TV for a second or so at the beginning stop it freezing later ?

    I think the 'FileReader::Read() read failed - error = -2147024832' messages mean that the file share is not available (but I'm not a expert in that area of the code).

    Tony
     

    mr viggo

    MP Donator
  • Premium Supporter
  • March 1, 2008
    500
    68
    Sweden Sweden
    No, using RTSP is worse since it freezes when zapping. I haven't tried pausing yet, but will do. One thing I forgot to mention is that tv sometimes can pop into gear again after a while, haven't tried it many times but lets say it takes around 15-20 mins or never...

    I have suspected that the network is the crook here, but other media plays fine so never investigated it any further, will hook up an other router and see if anything changes
     

    peque

    Moderator - Spanish Forums
  • Premium Supporter
  • August 4, 2007
    859
    98
    Spain Spain
    Country flag
    Could someone help me to find the meaning of this log in some of my dvb-t channels?

    Code:
    21-10-2011 09:22:19.596 [123c]vid:Timestamp discontinuity, TsDiff 680.000 ms, TsMeanDiff 40.000 ms, samples 7104
    21-10-2011 09:22:20.237 [123c]vid:Timestamp discontinuity, TsDiff 680.000 ms, TsMeanDiff 40.000 ms, samples 7120
    21-10-2011 09:22:20.877 [123c]vid:Timestamp discontinuity, TsDiff 680.000 ms, TsMeanDiff 40.000 ms, samples 7136
    21-10-2011 09:22:21.519 [123c]vid:Timestamp discontinuity, TsDiff 680.000 ms, TsMeanDiff 40.000 ms, samples 7152
    21-10-2011 09:22:22.154 [123c]vid:Timestamp discontinuity, TsDiff 680.000 ms, TsMeanDiff 40.000 ms, samples 7168
    21-10-2011 09:22:22.798 [123c]vid:Timestamp discontinuity, TsDiff 680.000 ms, TsMeanDiff 40.000 ms, samples 7184
    21-10-2011 09:22:23.463 [123c]vid:Timestamp discontinuity, TsDiff 680.000 ms, TsMeanDiff 40.000 ms, samples 7200
    21-10-2011 09:22:24.078 [123c]vid:Timestamp discontinuity, TsDiff 680.000 ms, TsMeanDiff 40.000 ms, samples 7216
    21-10-2011 09:22:24.717 [123c]vid:Timestamp discontinuity, TsDiff 680.000 ms, TsMeanDiff 40.000 ms, samples 7232
    21-10-2011 09:22:25.357 [123c]vid:Timestamp discontinuity, TsDiff 680.000 ms, TsMeanDiff 40.000 ms, samples 7248
    21-10-2011 09:22:25.997 [123c]vid:Timestamp discontinuity, TsDiff 680.000 ms, TsMeanDiff 40.000 ms, samples 7264
    21-10-2011 09:22:26.637 [123c]vid:Timestamp discontinuity, TsDiff 680.000 ms, TsMeanDiff 40.000 ms, samples 7280
    21-10-2011 09:22:27.277 [123c]vid:Timestamp discontinuity, TsDiff 680.000 ms, TsMeanDiff 40.000 ms, samples 7296
    21-10-2011 09:22:27.941 [123c]vid:Timestamp discontinuity, TsDiff 680.000 ms, TsMeanDiff 40.000 ms, samples 7312
    21-10-2011 09:22:28.557 [123c]vid:Timestamp discontinuity, TsDiff 680.000 ms, TsMeanDiff 40.000 ms, samples 7328
    Some channels doesn't have any of this, some have them from the very first second after tuning them.

    Thanks a lot.
     

    Owlsroost

    Development Group
  • Team MediaPortal
  • October 28, 2008
    5,540
    5,038
    Cambridge
    United Kingdom United Kingdom
    Country flag
    You can ignore it - it's logging I put in as part of the FFDShow video decoder fixes, and it can be triggered by some H.264 streams (I've discovered).

    I'll stop the logging in a future version of TsReader.

    Tony
     

    mr viggo

    MP Donator
  • Premium Supporter
  • March 1, 2008
    500
    68
    Sweden Sweden
    Ok, tested RTSP for a couple of days. No freezes at all of the kind I was having before. So the freezes has to do with UNC paths. Also found this post https://forum.team-mediaportal.com/...t-mode-test-plz-36735/index13.html#post702229.

    Seems that more people than me are suffering from issues with UNC. Question is, is it a bug in MP UNC code or is the problem at my end with my network setup. I dunno if UNC is supported or semi-supported by "the team", or if its even being worked on?

    I haven't noticed the zapping freezes yet and thats good. I had a different tv prov. when I had them before, but do have both HD and SD now aswell so... knock on wood. What I do notice is slower zapping times, but I can live with that if freezes are the alternative.
     

    Users Who Are Viewing This Thread (Users: 0, Guests: 3)

    OP Similar threads Forum Replies Date
    404 [solved] Live TV...video and audio freeze General Support 20
    S Mediaportal 1.22 Pre-Release remote live-tv freezes MediaPortal 1.22 Pre Release 0
    K MP1.24 HDHomeRun Quatro DVT2 - Pixelation on live TV General Support 1
    S IPTV from online m3u8 for Aussie Live TV General Support 9
    K Flickering live TV playback Newcomers Forum 3
    H [solved] MP2 Wiedergabe von Aufnahmen und Live TV geht nicht Allgemeines Support- und Diskussionsforum 6
    torone Dritter versuch mit Mediaportal 2 Allgemeines Support- und Diskussionsforum 1
    W [solved] MP suddenly Crashes when starting live TV on most channels and on recordings from the same channels General Support 20
    W [solved] MP suddenly Crashes when starting live TV on some channels and on some recordings Television (MyTV frontend and TV-Server) 1
    vvulture UNKNOWN ERROR when starting live TV General Support 6
    H random black screen live tv and videos (amended) General Support 0
    404 How to turn off narration on live tv General 2
    Volker MP2 Rewind / zurückspulen bei Live TV funktioniert nicht Allgemeines Support- und Diskussionsforum 3
    G Occasional Black screen on Live TV and Recorded TV Watch / Listen Media 5
    G Live Tv friert ein Allgemeines Support- und Diskussionsforum 47
    U [solved] Beginner needs help recording live TV General 19
    limpwhizkid 1.22.0 Stutter and or artifact problem when recording and watching the same live tv channel 1.22 2
    rbo Fehlermeldung im Live-TV TV / Streaming 6
    R Pixellation on live TV every few seconds General Support 11
    M After a while Live TV or Recorded TV doesn't play first time General Support 9
    S [solved] Live TV subtitle issue if not using 100% font General 31
    S [solved] Live TV playing stopped General 13
    H Live TV info OSD not displaying number of audio channels General Support 3
    E [solved] No Live TV in MP2.2 Client - Can TEST Successfully in "MediaPortal 2 TV Configuration" utility General 8
    D Skip to end/live during dvbip recording causes it to stop playing instead. General Support 15
    Similar threads

























    Top Bottom