[fixed] live Tv freeze - 15- --> 30+ helps (3 Viewers)

tompa

MP Donator
  • Premium Supporter
  • October 3, 2005
    665
    34
    Stockholm
    Sweden Sweden
    Hi!
    I have had some trouble (not very often) with Swedish local news, meaning that when they stop the picture sometimes freezes and I have to stop and restart the channel (as I remember they are switching audio format??).
    Tonight I succeeded to get this in the logs ...hopefully :)

    I would appreciate if you could take a look at it!
    /tompa
     

    Owlsroost

    Development Group
  • Team MediaPortal
  • October 28, 2008
    5,540
    5,038
    Cambridge
    United Kingdom United Kingdom
    Country flag
    Hi!
    I have had some trouble (not very often) with Swedish local news, meaning that when they stop the picture sometimes freezes and I have to stop and restart the channel (as I remember they are switching audio format??).
    Tonight I succeeded to get this in the logs ...hopefully :)

    I would appreciate if you could take a look at it!
    /tompa
    I think I can see from the logs what's going on - the local news switchover points seem to be creating stream continuity errors and big PTS timestamp jumps (the stream switching is not 'clean').....I'll think about it....

    Tony
     

    tourettes

    Retired Team Member
  • Premium Supporter
  • January 7, 2005
    17,301
    4,800
    Hi!
    I have had some trouble (not very often) with Swedish local news, meaning that when they stop the picture sometimes freezes and I have to stop and restart the channel (as I remember they are switching audio format??).
    Tonight I succeeded to get this in the logs ...hopefully :)

    I would appreciate if you could take a look at it!
    /tompa
    I think I can see from the logs what's going on - the local news switchover points seem to be creating stream continuity errors and big PTS timestamp jumps (the stream switching is not 'clean').....I'll think about it....
    Sounds like a TsWriter bug - it should smooth of the timestamp discontinuities.
     

    Owlsroost

    Development Group
  • Team MediaPortal
  • October 28, 2008
    5,540
    5,038
    Cambridge
    United Kingdom United Kingdom
    Country flag
    tompa is using ForTheRecord.

    TsReader ought to cope with the PTS jumps, but something runs into problems around here:

    Code:
    09-10-2011 19:59:04.871 [1420]  MPEG I-FRAME found 7837.203000 
    09-10-2011 19:59:04.873 [1420]  MPEG First '0' frame found. 7837.123000 
    09-10-2011 19:59:04.906 [1420]Audio Samples : 3, First : 7836.442, Last : 7836.722
    09-10-2011 19:59:04.907 [1420]Video Samples : 3, First : 7837.123, Last : 7837.203
    09-10-2011 19:59:04.908 [1420]Compensation : ( Rnd : 0 mS ) Audio pts greatly ahead Video pts . Add 0.601 sec of extra video comp to start now !...( real time TV )
    09-10-2011 19:59:04.910 [1420]Elapsed time from pause to Audio/Video ( total zapping time ) : 1708008 mS
    09-10-2011 19:59:04.911 [1420]aud:Compensation:-41670.953, Clock on start 46443.715 m_rtStart:3063760
    Tony
     

    tourettes

    Retired Team Member
  • Premium Supporter
  • January 7, 2005
    17,301
    4,800
    tompa is using ForTheRecord.

    TsReader ought to cope with the PTS jumps, but something runs into problems around here:
    I shouldn't have to since TsWriter has the logic in place (duration calculation for example is not possible if .ts file has timestamp discontinuities. To get it work we would need to scan the whole .ts file before we could start up playing which might be a bit slow on network connection and HD material).

    4TR should be fixed in the first place since TsReader cannot be fixed completely without introducing any performance issues. So, my advice is to reproduce the issue with bare TVE3 and if it wont happen -> open a support request for 4TR.
     

    mcrob83

    MP Donator
  • Premium Supporter
  • November 10, 2009
    206
    12
    St.Marienkirchen, Eferding
    Austria Austria
    AW: live Tv freeze - 15- --> 30+ helps

    I gave 0028 a chance and it's running very decent so far.

    tourettes
    I don't think, that 4TR is the problem. I had some of these problems also under TVE3.
    Tony's doing a good job, perhaps he's able to get the thing running perfect - I'm sure he'll do the job.
     

    tourettes

    Retired Team Member
  • Premium Supporter
  • January 7, 2005
    17,301
    4,800
    Re: AW: live Tv freeze - 15- --> 30+ helps

    Tony's doing a good job, perhaps he's able to get the thing running perfect - I'm sure he'll do the job.
    Even he cannot do miracles :) If there is a discontinuity in stream timestamps - lets say broadcaster has jump of two hours in advance the .ts file duration would be +2 hours (unless the whole file is read thru).
     

    Owlsroost

    Development Group
  • Team MediaPortal
  • October 28, 2008
    5,540
    5,038
    Cambridge
    United Kingdom United Kingdom
    Country flag
    Tourettes is quite correct :) (and the magic wand got broken a while ago ;)) - I only said I'd think about it, and anyway it looks like the base problem here is that the broadcaster (or telco) isn't doing their job properly.....

    Tony
     

    wouter1971

    MP Donator
  • Premium Supporter
  • November 19, 2008
    911
    143
    Purmerend, Holland
    Netherlands Netherlands
    Country flag
    Tony, i found out that a lot/all of my freezing picture problems were caused by a bad Astoncrypt Cam on second FloppyDTV card (so not allways visable but only if card 1 is in use), in combination with a card sharing device (SmartWii) which transmits to the smartcards through radio waves. Moved the device to a less radio waves interference location and prefect picture with no freezes. Found a lot of "PES H264 0-0-1 fail" in ts reader log that's what triggered me to look at the cams.
    If you can make a combination of this threads no stop mod 29 and the 300ms audio version from other thread would be great.
    Just wanted to report back and thank you for your efforts.

    Greetings,

    Wouter
     

    Owlsroost

    Development Group
  • Team MediaPortal
  • October 28, 2008
    5,540
    5,038
    Cambridge
    United Kingdom United Kingdom
    Country flag
    Good :)

    Yes, the 'PES 0-0-1 fail' messages are usually caused by decryption failures.

    If you can make a combination of this threads no stop mod 29 and the 300ms audio version from other thread would be great.
    It's in progress...

    Tony
     

    Users Who Are Viewing This Thread (Users: 0, Guests: 3)

    OP Similar threads Forum Replies Date
    404 [solved] Live TV...video and audio freeze General Support 20
    S Mediaportal 1.22 Pre-Release remote live-tv freezes MediaPortal 1.22 Pre Release 0
    K MP1.24 HDHomeRun Quatro DVT2 - Pixelation on live TV General Support 1
    S IPTV from online m3u8 for Aussie Live TV General Support 9
    K Flickering live TV playback Newcomers Forum 3
    H [solved] MP2 Wiedergabe von Aufnahmen und Live TV geht nicht Allgemeines Support- und Diskussionsforum 6
    torone Dritter versuch mit Mediaportal 2 Allgemeines Support- und Diskussionsforum 1
    W [solved] MP suddenly Crashes when starting live TV on most channels and on recordings from the same channels General Support 20
    W [solved] MP suddenly Crashes when starting live TV on some channels and on some recordings Television (MyTV frontend and TV-Server) 1
    vvulture UNKNOWN ERROR when starting live TV General Support 6
    H random black screen live tv and videos (amended) General Support 0
    404 How to turn off narration on live tv General 2
    Volker MP2 Rewind / zurückspulen bei Live TV funktioniert nicht Allgemeines Support- und Diskussionsforum 3
    G Occasional Black screen on Live TV and Recorded TV Watch / Listen Media 5
    G Live Tv friert ein Allgemeines Support- und Diskussionsforum 47
    U [solved] Beginner needs help recording live TV General 19
    limpwhizkid 1.22.0 Stutter and or artifact problem when recording and watching the same live tv channel 1.22 2
    rbo Fehlermeldung im Live-TV TV / Streaming 6
    R Pixellation on live TV every few seconds General Support 11
    M After a while Live TV or Recorded TV doesn't play first time General Support 9
    S [solved] Live TV subtitle issue if not using 100% font General 31
    S [solved] Live TV playing stopped General 13
    H Live TV info OSD not displaying number of audio channels General Support 3
    E [solved] No Live TV in MP2.2 Client - Can TEST Successfully in "MediaPortal 2 TV Configuration" utility General 8
    D Skip to end/live during dvbip recording causes it to stop playing instead. General Support 15
    Similar threads

























    Top Bottom