Live TV freezes intermittently on Beta1 & SVNs (1 Viewer)

x4mer

MP Donator
  • Premium Supporter
  • November 8, 2007
    306
    24
    Toronto
    Canada Canada
    I've noticed a telltale sign that the TV is going to freeze.

    I have the minidisplay plugin enabled, using a Soundgraph IMON display. In the advanced settings, I have "use bottom bar as progress display" enabled. Under normal conditions, upon selecting a channel, the progress bar would fill from left to right, & stay like that while watching TV.

    When using rtsp mode under a recent release, the progress bar will sometimes act erratically, jumping between 0% & 100% (and various values between). This happens fairly regularly when a channel is first selected. If it lasts too long, before becoming stable near 100%, the TV playback will freeze. It seems as though the client side is having a problem building up a usable "buffer".
     

    tourettes

    Retired Team Member
  • Premium Supporter
  • January 7, 2005
    17,301
    4,800
    When using rtsp mode under a recent release, the progress bar will sometimes act erratically, jumping between 0% & 100% (and various values between). This happens fairly regularly when a channel is first selected. If it lasts too long, before becoming stable near 100%, the TV playback will freeze. It seems as though the client side is having a problem building up a usable "buffer".
    try disabling the mini display plugin (just to make sure that it itself is not causing the issue you are seeing -> being a different issue than the most of the people are experiencing).
     

    x4mer

    MP Donator
  • Premium Supporter
  • November 8, 2007
    306
    24
    Toronto
    Canada Canada
    I tried disabling the minidisplay plugin today, and still got many freezes during this evenings TV viewing (resolved each time by a -15sec skip).

    The plugin's odd progress bar activity under recent SVNs, appears to be a symptom of the problem, not a cause of the problem.
     

    Juppe

    Portal Pro
    November 17, 2006
    297
    31
    Sweden Sweden
    Country flag
    I also have problem with live tv, but just on a client and only when a change channel, do you think that it's the same problem as in this thread.
    I have tried to watch on a client and then change channel and the pic i freezing but when a look at the same strem with vlc it works.
    I have logs in another thread
    https://forum.team-mediaportal.com/519237-post56.html
    I also get a lot of this

    07-10-2009 20:11:02.359 [a54]memorybuffer:put full buffer (12583592)
    07-10-2009 20:11:02.375 [a54]memorybuffer:put full buffer (12583592)
    07-10-2009 20:11:02.390 [a54]memorybuffer:put full buffer (12583592)
    07-10-2009 20:11:02.390 [a54]memorybuffer:put full buffer (12583592)
    07-10-2009 20:11:02.406 [a54]memorybuffer:put full buffer (12583592)

    when the client freeze.

    Hope someone can look into this.
     

    Juppe

    Portal Pro
    November 17, 2006
    297
    31
    Sweden Sweden
    Country flag
    In this test it was the svn from 09-26-2009.
    I saw in another thread that its maybe fixed in the latest svn, so I will test that one.
     

    Juppe

    Portal Pro
    November 17, 2006
    297
    31
    Sweden Sweden
    Country flag
    now I have tested the last SVN and I still get the same error, I can look at the stream in VLC and see the channel change, so I dont think that there is any problems with the server. If you need logs, let me know, but I dont think they will give any more info, looks the same as those i have linked to in the above post.
     

    Juppe

    Portal Pro
    November 17, 2006
    297
    31
    Sweden Sweden
    Country flag
    livetv just freeze on client for me, on server it works.
    That was not true, livetv freezes on server to now.
    Two more logs from the tv-server and MP running on server.
     

    x4mer

    MP Donator
  • Premium Supporter
  • November 8, 2007
    306
    24
    Toronto
    Canada Canada
    It seems MUCH better under the 831 SVN. It finally did the freeze last night (resumed with -15 skip) for the first time since installing the SVN when it came out.
     

    Users Who Are Viewing This Thread (Users: 0, Guests: 1)

    OP Similar threads Forum Replies Date
    404 [solved] Live TV...video and audio freeze General Support 20
    S Mediaportal 1.22 Pre-Release remote live-tv freezes MediaPortal 1.22 Pre Release 0
    S IPTV from online m3u8 for Aussie Live TV General Support 9
    K Flickering live TV playback Newcomers Forum 3
    H [solved] MP2 Wiedergabe von Aufnahmen und Live TV geht nicht Allgemeines Support- und Diskussionsforum 6
    torone Dritter versuch mit Mediaportal 2 Allgemeines Support- und Diskussionsforum 1
    W [solved] MP suddenly Crashes when starting live TV on most channels and on recordings from the same channels General Support 20
    W [solved] MP suddenly Crashes when starting live TV on some channels and on some recordings Television (MyTV frontend and TV-Server) 1
    vvulture UNKNOWN ERROR when starting live TV General Support 6
    H random black screen live tv and videos (amended) General Support 0
    404 How to turn off narration on live tv General 2
    Volker MP2 Rewind / zurückspulen bei Live TV funktioniert nicht Allgemeines Support- und Diskussionsforum 3
    G Occasional Black screen on Live TV and Recorded TV Watch / Listen Media 5
    G Live Tv friert ein Allgemeines Support- und Diskussionsforum 47
    U [solved] Beginner needs help recording live TV General 19
    limpwhizkid 1.22.0 Stutter and or artifact problem when recording and watching the same live tv channel 1.22 2
    rbo Fehlermeldung im Live-TV TV / Streaming 6
    R Pixellation on live TV every few seconds General Support 11
    M After a while Live TV or Recorded TV doesn't play first time General Support 9
    S [solved] Live TV subtitle issue if not using 100% font General 31
    S [solved] Live TV playing stopped General 13
    H Live TV info OSD not displaying number of audio channels General Support 3
    E [solved] No Live TV in MP2.2 Client - Can TEST Successfully in "MediaPortal 2 TV Configuration" utility General 8
    D Skip to end/live during dvbip recording causes it to stop playing instead. General Support 15
    porky996t Still Unable to play Live or Recorded TV General Support 4
    Similar threads

























    Top Bottom