MCE Remote + Windows 7, not all buttons working!? (1 Viewer)

JC007

Portal Member
June 24, 2009
17
0
Australia Australia
I Have a similar problem with my remote. I have been using Media Portal for many years and the remote has always working fine, but suddenly some of the buttons have stopped working. The round buttons (Play Pause, Stop, Forward etc). I think maybe that some file has become corrupt. Can I reinstall MP over the top of the existing one with ruining MOVING PICTURES AND TV SERIES??? Can anyone help?
Thanks
John
 

wonkyd

Retired Team Member
  • Premium Supporter
  • August 29, 2007
    792
    177
    United Kingdom United Kingdom
    Country flag
    Hi all,

    Similar problem was driving me crazy as well. I had XP PRO based MP with original Microsoft MCE remote & receiver. It worked fine. I made a new MP with Windows 7 PRO X64 and suddenly the same remote & receiver would not work correctly. As I noticed that builtin IR receiver with Antec Fusion cases was causing similar trouble I began checking out the hardware in my machine. I have a BlackGold BGT3620 dual tuner card and it seems it has also a IR receiver builtin. It did not come with any remote, so I did not think of it at first. There was no way to disable it from driver level. Here is what I did: I removed the Microsoft receiver. After that I disabled all HID devices (except USB mouse) I could find. One thing I could not disable was the ehome receiver itself (no option for it). After I disabled all HID devices I put the MS receiver back in and remote started working as it should.

    I hope this helps some of you.

    Markku
    Thanks mate, solved it for me. Bloody iMon drivers!
     

    zicoz

    MP Donator
  • Premium Supporter
  • September 3, 2006
    896
    63
    Norway Norway
    That setting is not available with the Philips choice that gets marked when I auto detect, but switched to the Microsoft one and it sort of helps, but in a weird way.

    - i-button seems to work as right-click both inside and outside of Microsoft.
    - Channel up seems to work as page down
    - Channel down seems to work as page up
    - Volume down seems opens context menu (F9).

    The rest seems to still be dead.
     
    Last edited:

    chefkoch

    Retired Team Member
  • Premium Supporter
  • October 5, 2004
    3,130
    1,630
    Dresden / Munich / Maastricht
    Germany Germany
    That setting is not available with the Philips choice that gets marked when I auto detect, but switched to the Microsoft one and it sort of helps, but in a weird way.

    - i-button seems to work as right-click both inside and outside of Microsoft.
    - Channel up seems to work as page down
    - Channel down seems to work as page up
    - Volume down seems opens context menu (F9).

    The rest seems to still be dead.
    Ok, did you installed any MCE replacement driver stuff or similar?
    Are the special drivers needed for that remote?
    Is it automatically detected by windows without any additional drivers?

    Could you please add all log files as a zip file?
    IR Server Suite log files can be found in the Start Menu under Programs -> IR Server Suite -> Logs. If you use the MCE remote support then there is another log file in your root directory, including that can also help.
    Please also start the debug client and press every button on your remote one. This way you can see the code, which is being detected by the plugin.
     

    zicoz

    MP Donator
  • Premium Supporter
  • September 3, 2006
    896
    63
    Norway Norway
    I have not installed any drivers but there are no indication of any issues in the Device Manager. But I borrowed a Microsoft reciever from a friend, and that seemed to work perfectly so it's probably a driver problem and I have contacted Streacom to ask if they have any drivers for it.

    I can't seem to get the debug mode to work either. I open Debug client, and connect to "localhost", but when I press a button on the remote nothing happens.

    And now it seems I've killed the reciever completely.

    :)
     
    Last edited:

    chefkoch

    Retired Team Member
  • Premium Supporter
  • October 5, 2004
    3,130
    1,630
    Dresden / Munich / Maastricht
    Germany Germany
    I have not installed any drivers but there are no indication of any issues in the Device Manager. But I borrowed a Microsoft reciever from a friend, and that seemed to work perfectly so it's probably a driver problem and I have contacted Streacom to ask if they have any drivers for it.

    I can't seem to get the debug mode to work either. I open Debug client, and connect to "localhost", but when I press a button on the remote nothing happens.

    And now it seems I've killed the reciever completely.
    It does not have to be a driver problem.
    Nevertheless, I can not say what's wrong without log files.
     
    Last edited:

    zicoz

    MP Donator
  • Premium Supporter
  • September 3, 2006
    896
    63
    Norway Norway
    Yeah, I've ordered a new reciever so will have to wait untill that comes.
     

    zicoz

    MP Donator
  • Premium Supporter
  • September 3, 2006
    896
    63
    Norway Norway
    Ok, recieved my new receiver today, but how do I run the debug client?

    What I've done so far:

    Open Debug Client
    Connect to localhost.
     

    Users Who Are Viewing This Thread (Users: 0, Guests: 1)

    OP Similar threads Forum Replies Date
    T Can Emprex 3009ARF III MCE Remote Control be used to toggle Fullscreen/Windowed mode?? Remotes 7
    F MCE Remote has no focus General 6
    brena MCE Remote Disable Volume Mapping Input / Output interfaces 0
    T How to add missing buttons IR Server Suite (IRSS) 0
    B iPhone app for MCE remote General Support 2
    F Somethings changed - mce remote General Support 9
    N [Finished] [MP2-789] MCE remote control Recorded TV and My Pictures buttons do not work MediaPortal 2 17
    H MP 1.21 Volume OSD for 1039 MCE remote and MCE keyboard not working 1.21 74
    azzuro MCE remote and Azerty keyboard other Input / Output interfaces 2
    Spaldo Bose universal remote with MP Input/Output Interfaces 2
    E Getting ortek mce remote to work better MediaPortal 1 Talk 13
    T MCE remote double keypress up and down General 1
    Volker [Suche] RC6 MCE IR-Empfänger Marktplatz 2
    V Some Issues with MP2 (ex MCE User) General 1
    P The elusive "MCE Replacement Driver" for Vista / Win7 IR Server Suite (IRSS) 0
    D PS3 Bluetooth Remote Remotes 1
    henrysinn Remote - W10 Gyro by Pepper Jobs General 8
    G Remote control suggestions? MediaPortal 1 Talk 16
    bigboss97 Does anyone has a SoundGraph imon remote file for MP2 to share? General 0
    TLD Can not watch tv from remote clients Television (MyTV frontend and TV-Server) 19
    R Problems accessing MySQL database remotely MediaPortal 1 Talk 0
    D Full fuctional htpc - Silverstone Case - Digital Devices Cine S2 - SSD - IR Remote For Sale 1
    N Play a TV recording needs a double selection - twice ok on remote Television (MyTV frontend and TV-Server) 2
    emphatic Allow remote control mapping of all plugins Improvement Suggestions 0
    S Remote button to change audio and subtitle on / off General 10
    Similar threads

























    Top Bottom