MediaPortal Audio renderer - better video playback quality | Page 93

Discussion in 'General Development (no feature request here!)' started by tourettes, July 12, 2010.

  1. doveman

    doveman Portal Pro

    Joined:
    February 12, 2008
    Messages:
    2,326
    Likes Received:
    166
    Ratings:
    +182 / 3
    Home Country:
    United Kingdom United Kingdom
    Show System Specs



     
  2. Google AdSense Guest Advertisement



    to hide all adverts.
  3. tourettes
    • Premium Supporter

    tourettes Retired Team Member

    Joined:
    January 7, 2005
    Messages:
    17,301
    Likes Received:
    4,595
    Ratings:
    +4,810 / 3
    New binaries available (ver 17): https://forum.team-mediaportal.com/637138-post3.html

    version 17 - based on SVN revision 26623

    • Added audio delay setting in the registry
    • Fixed A/V sync drifting when AC3 encoding is enabled


    AudioDelay

    Delay audio for xxx ms, can be used to compensate delay introduced by display device (postprocessing in LCD for example). By default this is 0 ms. Amount is given in ms.
     
    • Like Like x 3
  4. Truri
    • Premium Supporter

    Truri MP Donator

    Joined:
    November 9, 2008
    Messages:
    192
    Likes Received:
    8
    Ratings:
    +8 / 0
    Home Country:
    Germany Germany
    AW: MediaPortal Audio renderer - better video playback quality

    Hi,

    I'm watching currently via timeshift Sport1

    Here occures sometimes heavy stuttering.
    Sound is sync.

    [​IMG]
    [​IMG]
    [​IMG]

    I have no shot from the stats of the right moment, but there are the lines hevy shaking.
     
  5. Truri
    • Premium Supporter

    Truri MP Donator

    Joined:
    November 9, 2008
    Messages:
    192
    Likes Received:
    8
    Ratings:
    +8 / 0
    Home Country:
    Germany Germany
    AW: MediaPortal Audio renderer - better video playback quality

    Besides that I have an other small problem:
    After waking up from standby i hear constant "noise". Like some rest in the buffer.
    This only goes away if i play something with sound.
     
  6. tourettes
    • Premium Supporter

    tourettes Retired Team Member

    Joined:
    January 7, 2005
    Messages:
    17,301
    Likes Received:
    4,595
    Ratings:
    +4,810 / 3
    Re: AW: MediaPortal Audio renderer - better video playback quality

    Sounds like a driver issue. What are the exact steps to reproduce that? Also would be interesting to see if Reclock triggers the same issue with WASAPI.
     
  7. Truri
    • Premium Supporter

    Truri MP Donator

    Joined:
    November 9, 2008
    Messages:
    192
    Likes Received:
    8
    Ratings:
    +8 / 0
    Home Country:
    Germany Germany
    AW: Re: AW: MediaPortal Audio renderer - better video playback quality

    Windows System Sounds Disabled
    MP Navi Sounds Disabled

    Stop Playback (think makes no difference TV, Video...)
    Supend HTPC (S3 - Suspend to Ram)
    Wake up HTPC
    Hear that noise ^^
    Start Playback (sound is correctly played), noise is gone

    Using latest ATI Cat10.10 with latest ATI HDMI driver
     
  8. tourettes
    • Premium Supporter

    tourettes Retired Team Member

    Joined:
    January 7, 2005
    Messages:
    17,301
    Likes Received:
    4,595
    Ratings:
    +4,810 / 3
    Re: AW: Re: AW: MediaPortal Audio renderer - better video playback quality

    Not reproducible here.

    1) can anyone else reproduce that?
    2) does it happen with Reclock as audio renderer?
    3) does it happen with directsound default audio renderer?
    4) does it happen with foobar2000 music player + WASAPI plugin in use?
    5) does it happen with previous versions of the renderer?
    6) does it happen with previous versions of the drivers?
     
  9. Truri
    • Premium Supporter

    Truri MP Donator

    Joined:
    November 9, 2008
    Messages:
    192
    Likes Received:
    8
    Ratings:
    +8 / 0
    Home Country:
    Germany Germany
    AW: MediaPortal Audio renderer - better video playback quality

    No.

    The HDMI driver is the same since Cat 10.8

    But I have tried to reproduce the issue again right now but I can't. *argh*
     
  10. disaster123
    • Premium Supporter

    disaster123 MP Donator

    Joined:
    May 14, 2008
    Messages:
    3,546
    Likes Received:
    417
    Ratings:
    +431 / 2
    Home Country:
    Germany Germany
    AW: MediaPortal Audio renderer - better video playback quality

    just wanted to know if it is known. Using Ver 17 with HWbased clock and ac3 encodings and audio relay to 100ms results into a really fast running audio for me. Pressing pause and play fix this for about 5s then audio is again forward.
     
  11. disaster123
    • Premium Supporter

    disaster123 MP Donator

    Joined:
    May 14, 2008
    Messages:
    3,546
    Likes Received:
    417
    Ratings:
    +431 / 2
    Home Country:
    Germany Germany
    AW: MediaPortal Audio renderer - better video playback quality

    Heavily drifting Audio - i'm now back in V15. With that one it is working fine. But i've only the problem when AC3 is enabled.
     

    Attached Files:

    • Like Like x 1
Loading...

Users Viewing Thread (Users: 0, Guests: 0)

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice
  • About The Project

    The vision of the MediaPortal project is to create a free open source media centre application, which supports all advanced media centre functions, and is accessible to all Windows users.

    In reaching this goal we are working every day to make sure our software is one of the best.

             

  • Support MediaPortal!

    The team works very hard to make sure the community is running the best HTPC-software. We give away MediaPortal for free but hosting and software is not for us.

    Care to support our work with a few bucks? We'd really appreciate it!