Mediaportal freeze after pausing tv and switch-off of screen (1 Viewer)

jimbeam128

Portal Pro
December 16, 2008
169
19
Home Country
Germany Germany
Hi all,

I´m using MP 1.30 at the moment and have a problem which also exists on my system on previous versions. So I don´t think an update will help. Therefore it would be good if I get support for my current environment.

Here the situation / Problem:

I´m watching live-tv (DVBS-2) and everything works well. I press the pause button and the video halts as expected. When I press play the video goes on as exprected.
I´ve configured a screensaver-timeout in windows power options of 10 Minutes. When the timeout is reached, the screen will be "disconnected / powered off" by windows energy options. - Screensaver settings in Mediaportal Config are disabled.

When I "come back" and press the play button to resume, the screen switches on, but the media portal (picture) is frozen. No reaction from media portal any more. Even pressing Alt + F4 does not end mediaportal.
The only solution is to kill the mediaportal.exe process.
I had a look in the tasklist in the background and could see that the process is not marked as "not respondig". Although the application is not working any more...

Does anybody ever had this issue? Can someone maybe give a hint for a solution? Or to isolate the problem...?

Best regards
 

CyberSimian

Test Group
  • Team MediaPortal
  • June 10, 2013
    2,924
    1,841
    Southampton
    Home Country
    United Kingdom United Kingdom
    I´ve configured a screensaver-timeout in windows power options of 10 Minutes. When the timeout is reached, the screen will be "disconnected / powered off" by windows energy options. - Screensaver settings in Mediaportal Config are disabled.
    I don't know what the problem is, but I would suggest disabling the Windows screen saver, and enabling the MP screen saver, and seeing what effect that has.

    I have the MP screen saver configured to show a blank screen after 1 minute. If video is paused, I can unpause the video and playback continues without problem.

    However, if I allow the screen saver to operate on an MP panel (i.e. no media playing), when I play video subsequently, sometimes there will be audio but no video. It is necessary to exit MP and then restart MP to remedy this situation.

    -- from CyberSimian in the UK
     

    CyberSimian

    Test Group
  • Team MediaPortal
  • June 10, 2013
    2,924
    1,841
    Southampton
    Home Country
    United Kingdom United Kingdom
    I have the MP screen saver configured to show a blank screen after 1 minute.
    I should add that when the MP screen saver shows a blank screen, I have my Sony TV configured to switch the LEDs off (this saves about 20 watts), but the TV itself does not switch off.

    -- from CyberSimian in the UK
     

    joecrow

    Test Group
  • Team MediaPortal
  • August 9, 2012
    2,614
    1,976
    Home Country
    Germany Germany
    Does anybody ever had this issue? Can someone maybe give a hint for a solution? Or to isolate the problem...?
    I tried setting the windows screensaver to power off the display on my MP1 HTPC but in fact it only blanks the screen ("no video signal") on the TV I suspect the AVR has something to do with that. If I manually put the TV only into standby when TV is playing but paused then on wakeup I could not immediately take it out of pause and needed a number of button presses on the remote (esc, back OK etc.) before playback resumed (though not exactly from the same place but again that test may have been muddied since the AVR also goes into standby with the TV. :unsure:
    I also tried it out on my Desktop PC which just has a simple monitor display with MP2, either using the Windows "power off the display" timeout or manually switching the display off had no effect on the paused TV it resumed perfectly, tested several times. Note though I am using the TV Mosaic MP2 version which uses a very different TV Server so the problem could be in the TV Service which is very similar in both MP1 and the MP2 standard version.
    I would echo the response from @CyberSimian if it is just the screensaver you need then maybe use the MP one which works perfectly for me and for power saving try looking for any options in your TV settings.
     
    Last edited:

    Users who are viewing this thread

    Top Bottom