MP 1.26 fails to connect to SQL Server (1 Viewer)

rsbrux

Documentation Group
  • Team MediaPortal
  • April 15, 2007
    1,116
    115
    Home Country
    Switzerland Switzerland
    Country flag
    After a clean installation of MP 1.27, the needed dependency is still missing. However, this time I was able to add it by executing a .cmd file with the following command line:
    sc config TVService depend= MSSQL$SQLEXPRESS/SQLBrowser/Netman
    as administrator.
     

    doskabouter

    Development Group
  • Team MediaPortal
  • September 27, 2009
    3,954
    2,192
    Nuenen
    Home Country
    Netherlands Netherlands
    Country flag
    Just did a simple test (clean install of MP 1.27, singleseat, Mysql) and there the dependency was correctly added (both with mysql installed by mediaportal and with an already installed mysql), so that part is indeed working correctly.
    For SQL Server I think the name of the dependency wasn't correct in the "setup database configuration" tool (it defaults to SQLBrowser), so it couldn't set the dependency correctly.
     

    rsbrux

    Documentation Group
  • Team MediaPortal
  • April 15, 2007
    1,116
    115
    Home Country
    Switzerland Switzerland
    Country flag
    Evidently the dependency on SQL Browser is not adequate. I assumed that it was needed in addition to the dependency on SQL Server itself. If that is not the case, then the command to set the dependency should be:
    sc config TVService depend= MSSQL$SQLEXPRESS/Netman
    Unfortunately, I rejoiced too soon; on subsequent reboots, the added dependency has disappeared each time, so I am going back to the workaround solution of using "Automatic (Delayed Start)". So far, that has worked reliably. BTW, the DB connection dialog still says SQL Server "2005". Since it has been proven that the DB I/F works with later versions of SQL Server, i suggest deleting "2005" to avoid confusing the uninitiated ;-)
     

    rsbrux

    Documentation Group
  • Team MediaPortal
  • April 15, 2007
    1,116
    115
    Home Country
    Switzerland Switzerland
    Country flag
    Since this thread has wandered a bit from the original issue / title, I am starting another one.
     

    Users who are viewing this thread

    Similar threads

    FWIW, please see SQL Server 2017 Express for a workaround. Adding the scheduled task on startup seems to resolve the problem, at least in my installation.
    FWIW, please see SQL Server 2017 Express for a workaround. Adding the scheduled task on startup seems to resolve the problem, at...
    When installing MP1, the TV DB configuration dialog specifies SQL Server 2005 (see attached file "Setup database connection -...
    Replies
    4
    Views
    805
    Azzuro and doskabouter, got it working. Resetting the database worked. And after linking to the server via current IP and making a new db, I relinked to the original db and all settings were restored. Thanks again and Happy New Year to all!
    Azzuro and doskabouter, got it working. Resetting the database worked. And after linking to the server via current IP and making a...
    A couple weeks ago the TV server service stopped working. Not urgent, so waited till today to research it. Did an upgrade to 1.26...
    Replies
    4
    Views
    539
    I think there's a master table here http://install.team-mediaportal.com/MPEI/extensions.txt with a list of urls to all the plugin sources. Don't know exactly who has rights to change that
    I think there's a master table here http://install.team-mediaportal.com/MPEI/extensions.txt with a list of urls to all the plugin...
    I am attempting a virgin installation and configuration of MP1 v1.26 on a fresh installation on windows 8.1 Pro x64. When i try to...
    Replies
    7
    Views
    689
    • Sticky
    Pre Releases are provided as a way for the community to test and give feedback on all the exciting things we have lined up for the next release. We allocate about one month for Pre Release testing. In that time we will only fix bugs, after which comes the final release! Highlights of this release Bugfixes: [MP1-5081] - WatchDog...
    Pre Releases are provided as a way for the community to test and give feedback on all the exciting things we have lined up for the...
    Pre Releases are provided as a way for the community to test and give feedback on all the exciting things we have lined up for the...
    Replies
    0
    Views
    209
    I thinks this is the first time I've installed MP on all my machines without a single IO error 32. Good work guys, thanks!
    I thinks this is the first time I've installed MP on all my machines without a single IO error 32. Good work guys, thanks!
    We have just released MediaPortal 1.26 - Winter is coming... Highlights of this release Bugfixes: [MP1-5031] - Fix Invalid File...
    Replies
    1
    Views
    1K
    Top Bottom