MP 1.26 fails to connect to SQL Server (1 Viewer)

rsbrux

Documentation Group
  • Team MediaPortal
  • April 15, 2007
    1,133
    115
    Home Country
    Switzerland Switzerland
    Country flag
    After a clean installation of MP 1.27, the needed dependency is still missing. However, this time I was able to add it by executing a .cmd file with the following command line:
    sc config TVService depend= MSSQL$SQLEXPRESS/SQLBrowser/Netman
    as administrator.
     

    doskabouter

    Development Group
  • Team MediaPortal
  • September 27, 2009
    4,107
    2,340
    Nuenen
    Home Country
    Netherlands Netherlands
    Country flag
    Just did a simple test (clean install of MP 1.27, singleseat, Mysql) and there the dependency was correctly added (both with mysql installed by mediaportal and with an already installed mysql), so that part is indeed working correctly.
    For SQL Server I think the name of the dependency wasn't correct in the "setup database configuration" tool (it defaults to SQLBrowser), so it couldn't set the dependency correctly.
     

    rsbrux

    Documentation Group
  • Team MediaPortal
  • April 15, 2007
    1,133
    115
    Home Country
    Switzerland Switzerland
    Country flag
    Evidently the dependency on SQL Browser is not adequate. I assumed that it was needed in addition to the dependency on SQL Server itself. If that is not the case, then the command to set the dependency should be:
    sc config TVService depend= MSSQL$SQLEXPRESS/Netman
    Unfortunately, I rejoiced too soon; on subsequent reboots, the added dependency has disappeared each time, so I am going back to the workaround solution of using "Automatic (Delayed Start)". So far, that has worked reliably. BTW, the DB connection dialog still says SQL Server "2005". Since it has been proven that the DB I/F works with later versions of SQL Server, i suggest deleting "2005" to avoid confusing the uninitiated ;-)
     

    rsbrux

    Documentation Group
  • Team MediaPortal
  • April 15, 2007
    1,133
    115
    Home Country
    Switzerland Switzerland
    Country flag
    Since this thread has wandered a bit from the original issue / title, I am starting another one.
     

    Users who are viewing this thread

    Similar threads

    This problem still exists with MP 1.29.
    This problem still exists with MP 1.29.
    When installing MP1, the TV DB configuration dialog specifies SQL Server 2005 (see attached file "Setup database connection -...
    Replies
    5
    Views
    1K
    WinTV v10 TV server may have the tv cards locked.
    WinTV v10 TV server may have the tv cards locked.
    I recently tried to test the MP 1.29 Pre-release, to find out the MySQL Server 5.6 won't install & connect host to my TV Tuner...
    Replies
    2
    Views
    250
    From documentation: For Windows 7 or later - MSSQL versions above 2008, there's no official documentation from Mediaportal but you can install and configure it based on the articles above, google or documentation from Microsoft. Compatibility has not been tested.
    From documentation: For Windows 7 or later - MSSQL versions above 2008, there's no official documentation from Mediaportal but you...
    With a couple restore points ahead of for emergency, I tried to install MS SQL Server 2008 first, but found no way to extract the...
    Replies
    1
    Views
    99
    Azzuro and doskabouter, got it working. Resetting the database worked. And after linking to the server via current IP and making a new db, I relinked to the original db and all settings were restored. Thanks again and Happy New Year to all!
    Azzuro and doskabouter, got it working. Resetting the database worked. And after linking to the server via current IP and making a...
    A couple weeks ago the TV server service stopped working. Not urgent, so waited till today to research it. Did an upgrade to 1.26...
    Replies
    4
    Views
    638
    the best way is to use localhost or the name of the computer. 127.0.0.1 is good too.
    the best way is to use localhost or the name of the computer. 127.0.0.1 is good too.
    Hello team, Setup: MP 1.28 single seat on Win 10 pro x64, using MySQL database, wired NIC to router. The setup works fine until I...
    Replies
    4
    Views
    293
    Top Bottom