MP 1.3.x dshowhelper development | Page 2

Discussion in 'General Development (no feature request here!)' started by Owlsroost, October 7, 2012.

  1. Jelmo

    Jelmo Portal Pro

    Joined:
    September 8, 2007
    Messages:
    711
    Likes Received:
    43
    Gender:
    Male
    Ratings:
    +52 / 0
    Home Country:
    Germany Germany
    Show System Specs
    Hi Tony,

    Thanks for your effort. New posted version runs very well. Better as 1.3A Default stuff. Only one thing ... i had to disable the REG Key to 0
    So i think Windows with my GT430 works with noDWM stuff better as enabled. I also used the noDWM version with 1.2.3 to get better results.
    In my opinion its a system / driver related point, where everybody can test witch setting is the best.

    I will stay on this version / EnableDWMQueuedMode = 0



    Many thanks Tony
     
  2. Google AdSense Guest Advertisement



    to hide all adverts.
  3. Owlsroost
    • Team MediaPortal

    Owlsroost Development Group

    Joined:
    October 28, 2008
    Messages:
    5,537
    Likes Received:
    2,829
    Location:
    Cambridge
    Ratings:
    +4,131 / 1
    Home Country:
    United Kingdom United Kingdom
    Show System Specs
    The key is created automatically with the default settings the first time dshowhelper is used (so just play something after installing it).

    Tony
     
  4. Owlsroost
    • Team MediaPortal

    Owlsroost Development Group

    Joined:
    October 28, 2008
    Messages:
    5,537
    Likes Received:
    2,829
    Location:
    Cambridge
    Ratings:
    +4,131 / 1
    Home Country:
    United Kingdom United Kingdom
    Show System Specs
    I agree.

    Enabling DWM 'queued' mode seems to help people using dual monitor setups in particular (which is why I've had several requests for a 1.3.x compatible 'DWM' version :))

    Tony
     
    Last edited: October 8, 2012
  5. doveman

    doveman Portal Pro

    Joined:
    February 12, 2008
    Messages:
    2,326
    Likes Received:
    166
    Ratings:
    +182 / 3
    Home Country:
    United Kingdom United Kingdom
    Show System Specs
    Thanks, I can confirm it's worked :)[DOUBLEPOST=1349692529][/DOUBLEPOST]
    Yes, I use dual-monitor and always found the DWM version essential with 1.2.3. 1.3a seems to have been OK with the default dshowhelper, although my friends are always telling me that TV is out-of-sync, so hopefully this will help but certainly with 1.2.3 I would have very obvious and noticeable problems with the framerate/high render time with the standard dshowhelper.
     
    Last edited: October 8, 2012
  6. Der_Bub
    • Premium Supporter

    Der_Bub MP Donator

    Joined:
    June 17, 2008
    Messages:
    829
    Likes Received:
    52
    Location:
    Cologne
    Ratings:
    +60 / 2
    Home Country:
    Germany Germany
    Show System Specs
    With this release, I have a Problem after watsching a BluRay (3D) via external Player (TMT5):
    • After closing Player and going back to MP, skin doesn't display any reaction to input (remote control). The last Window is shown (Filmlist of moving pictures), but the cursor doesn't move or any other screen is displayed.
    • But the system does react to the input: The skin sounds are fine and on LCD display of the case, the Names (Film or Menu Element Name) is shown.
    Did try both DWM options, with no success. With the original dsshowherlper, I don't have this problem.
     
  7. Owlsroost
    • Team MediaPortal

    Owlsroost Development Group

    Joined:
    October 28, 2008
    Messages:
    5,537
    Likes Received:
    2,829
    Location:
    Cambridge
    Ratings:
    +4,131 / 1
    Home Country:
    United Kingdom United Kingdom
    Show System Specs

    Logs please for the EnableDWMQueuedMode = 0 situation (note you need to restart MP when you change the registry settings)

    Tony
     
  8. tourettes
    • Premium Supporter

    tourettes Retired Team Member

    Joined:
    January 7, 2005
    Messages:
    17,301
    Likes Received:
    4,595
    Ratings:
    +4,810 / 3
    An odd issue if you ask from me. When using the external Blu-ray player the EVR renderer is not used for anything, so it shouldn't affect the MP GUI in any way.
     
  9. Owlsroost
    • Team MediaPortal

    Owlsroost Development Group

    Joined:
    October 28, 2008
    Messages:
    5,537
    Likes Received:
    2,829
    Location:
    Cambridge
    Ratings:
    +4,131 / 1
    Home Country:
    United Kingdom United Kingdom
    Show System Specs
    That's my opinion too....but I'd still like to see the logs....

    Tony
     
    Last edited: October 15, 2012
  10. Der_Bub
    • Premium Supporter

    Der_Bub MP Donator

    Joined:
    June 17, 2008
    Messages:
    829
    Likes Received:
    52
    Location:
    Cologne
    Ratings:
    +60 / 2
    Home Country:
    Germany Germany
    Show System Specs
    Hello,

    the logs are attached.

    Steps I've have made:
    1. Stop TV
    2. search & start Movi in Moving Pictures Plugin
    3. a few seconds playback in TMT5
    4. stop and back to MP
    I had this problem allready with MP 1.2.3 and some of the dshowhelper for it. As far as I remember ther v0092a_no_DWM did fine and the "part_DWM" ones not.

    If Mediportal is resumed, the colors are little "bright" for few seconds, but changes immediately to "normal". Within TMT5 auto refresh rate Changing is enabled. (For 3D Movies) it makes no difference if disbaled --> still no reaction on Skin.

    Hopefully you can get some futher Information from the logs...
     
    Last edited: October 15, 2012
  11. Owlsroost
    • Team MediaPortal

    Owlsroost Development Group

    Joined:
    October 28, 2008
    Messages:
    5,537
    Likes Received:
    2,829
    Location:
    Cambridge
    Ratings:
    +4,131 / 1
    Home Country:
    United Kingdom United Kingdom
    Show System Specs
    OK - found a problem with the way the registry settings were handled (which meant that DWM queued mode was always enabled....)

    Der_Bub - can you try the attached v665 version please (with EnableDWMQueuedMode = 0) ?

    Tony
     
    • Like Like x 2
Loading...

Users Viewing Thread (Users: 0, Guests: 0)

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice
  • About The Project

    The vision of the MediaPortal project is to create a free open source media centre application, which supports all advanced media centre functions, and is accessible to all Windows users.

    In reaching this goal we are working every day to make sure our software is one of the best.

             

  • Support MediaPortal!

    The team works very hard to make sure the community is running the best HTPC-software. We give away MediaPortal for free but hosting and software is not for us.

    Care to support our work with a few bucks? We'd really appreciate it!