MP detects & selects YLE HD audio stream for the visually impaired incorrectly (1 Viewer)

Pirppuli

MP Donator
  • Premium Supporter
  • July 19, 2008
    63
    44
    Helsinki
    Finland Finland
    MediaPortal Version: 1.4.0

    Description
    Hi,
    The Finnish broadcaster YLE has an HD channel where they provide an audio stream for the visually impaired (a synthesized voice reads the subtitles aloud). MP detects this stream as "Unknown" and always plays it back even though I have selected Finnish and English as my audio preferences in the TV Client configuration. This happens both in live TV and recordings.
    As far as I know, YLE flags the stream as Dutch for the visually impaired. This is also how the stream is identified in MPC-HC w/ LAV Splitter. A short sample recording ("Dutch" & English audio) can be downloaded from File Dropper. Debug logs are attached with YLE HD being the second channel tuned into.
    BR,
    P.

    Steps to Reproduce:
    Tune into YLE HD when they are showing a program with subtitles, or play back a YLE HD recording. The audio stream for the visually impaired is detected as "Unknown" and selected automatically regardless of TV audio language preferences.

    EDIT: This appears to be the issue described here - https://issues.team-mediaportal.com/browse/MP1-2172
     
    Last edited by a moderator:

    tourettes

    Retired Team Member
  • Premium Supporter
  • January 7, 2005
    17,301
    4,800
    You could set the ENG audio language as preferred after FIN then MP should be able to pick up the correct language. UNK seems to be an bug in TsReader as VLC for example is able to pick the Netherlands audio stream language correctly.
     

    mm1352000

    Development Group
  • Team MediaPortal
  • September 1, 2008
    21,571
    8,218
    New Zealand New Zealand
    Country flag
    Language "UNK" means the language for the stream is not specified in the PMT descriptors for the stream. TsWriter is not detecting the language either.
     

    Pirppuli

    MP Donator
  • Premium Supporter
  • July 19, 2008
    63
    44
    Helsinki
    Finland Finland
    @mm1352000: The TS dump you requested is now on the FTP server, named "Finland_YLE_330MHz_DVBC_YLEHD_FTA.ts"

    @tourettes: I have selected both Finnish and English in the TV audio preferences. The Unk audio is is selected automatically regardless.
     

    tourettes

    Retired Team Member
  • Premium Supporter
  • January 7, 2005
    17,301
    4,800
    @tourettes: I have selected both Finnish and English in the TV audio preferences. The Unk audio is is selected automatically regardless.
    A bit strange that you have the issue, since on my HTPC I haven't had any issues with that same HD channel. I cannot even remember if I have ENG as selected. Of course it might be just luck that I haven't watched any shows that have the visually impaired audio stream.
     

    Pirppuli

    MP Donator
  • Premium Supporter
  • July 19, 2008
    63
    44
    Helsinki
    Finland Finland
    Can someone confirm this issue? I noticed that MP always detects the first audio stream as Unk for YLE HD even if it's not a track for the visually impaired: e.g. today's European Championships have Finnish and Swedish audio streams, but MP only recognizes the Swedish one. It only bothers me when the robot voice starts reading the subtitles aloud... :)
     

    tourettes

    Retired Team Member
  • Premium Supporter
  • January 7, 2005
    17,301
    4,800
    I'll try to remember to check what Yle HD says here as audio languages. It might be some broadcaster issue as I haven't had the robot hijacking the air waves ever on that channel.
     

    mm1352000

    Development Group
  • Team MediaPortal
  • September 1, 2008
    21,571
    8,218
    New Zealand New Zealand
    Country flag
    Just a quick progress update... :)
    I've had a look at the PMT parsing code in TsReader and TsWriter. Assigning of language is a bit more complex than I expected. It is entirely possible there is a bug there... and indeed in the dump file that was provided I can see there is really a language code present.
     

    Pirppuli

    MP Donator
  • Premium Supporter
  • July 19, 2008
    63
    44
    Helsinki
    Finland Finland
    Can you tag this issue as a bug? I'd be happy to help with testing if and when a fix is available.
     

    Users Who Are Viewing This Thread (Users: 0, Guests: 1)

    Top Bottom