[duplicate] Mp not focused on after resuming from sleep (1 Viewer)

stirlinghart

Portal Pro
July 22, 2011
110
2
MediaPortal 2 Version: 2.2

Description
Hi,

Even with MP set to run at full screen and also the shortcut set to run maximised when you resume windows, the remote will bring up guide, recorded tv etc if you press the buttons but when you use the up/down/left/right buttons it does not move anything on the screen until you grab the keyboard and click anywhere on the screen, then the arrows will control the menu items.

This also happened in 2.2 Pre Release.

Is there any way to fix this?

Thanks in advance :)

Steps to Reproduce:
Have MP open to full screen, sleep computer then turn back on and try to use the arrow buttons to navigate menu items.
 

HTPCSourcer

MP2 Product Manager
  • Team MediaPortal
  • May 16, 2008
    11,431
    2,333
    Germany Germany
    Country flag
    Is there any way to fix this?
    It's not a general thing and doesn't happen for everybody on every resume. Therefore it is difficult to give an answer. The issue itself is known and already captured as a Jira MP2-576, however, despite several small things to ensure that focus remains, we do have situations like the one that you report here.
     

    HTPCSourcer

    MP2 Product Manager
  • Team MediaPortal
  • May 16, 2008
    11,431
    2,333
    Germany Germany
    Country flag
    Does doing a 'circle', i.e. 'up', 'right', 'down', 'left' bring back the focus?
     

    stirlinghart

    Portal Pro
    July 22, 2011
    110
    2
    Hi,

    I have tried pressing lots of keys but not so much all of those ones. I will try this. I have the same issue with KODI so it may just be a windows thing.

    Thanks for your help.
     

    henso

    Development Group
  • Team MediaPortal
  • February 16, 2012
    2,170
    735
    Denmark Denmark
    Country flag
    Pushing the Green button on the remote should refocus the client.
     

    stirlinghart

    Portal Pro
    July 22, 2011
    110
    2
    Hi, sorry for the late reply. Yes I tried this but it didn't make any difference. I have since just left my mediaportal pc on all the time. It doesn't use much power. Thanks for your advice :)
     

    Users Who Are Viewing This Thread (Users: 0, Guests: 1)

    OP Similar threads Forum Replies Date
    stirlinghart FOCUS not on MP after resuming from sleep General 11
    F MCE Remote has no focus General 6
    M [further infos missing] Stuttery UI behaviour when in focus, super fast outside focus. Submit: Bug Reports 14
    cbr954rr Mp loose focus after switching tv off General 1
    N [Finished] Focus problems - I think I've found the bug MediaPortal 2 30
    HTPCSourcer [Rejected] Mouse movements and focus: Windows standards MediaPortal 2 3
    B [MP2-744] WMC home content focus improvements Archive 55
    joecrow 1.25.0 Radio Time plugin fails after Resume from Sleep with MP 1.25 Bugreports 3
    F After resume, TV Server connection screen is shown General Support 4
    Dark Eyes TVService locks up or fails to restart on resuming from sleep, and crashes when grabbing EPG Installation, configuration support 7
    P MP2 Client Screen Flickering on Resume General 2
    HTPCSourcer [fixed] [MP2-815] User not logged in when resuming from standby MediaPortal 2 17
    J Resume from Standby Last Module TV Showing TV Server Settings Television (MyTV frontend and TV-Server) 2
    R Media portal resumes with wrong screen resolution General Support 3
    B resume from within a folder Watch / Listen Media 0
    joecrow No Audio after MP Start/Resume from Sleep General Support 0
    R Weird sleep/resume loop General Support 4
    joecrow Further problem on resume from sleep (MP Crash) 1.21 5
    joecrow Loss of Navigation Sounds on Resume from Sleep Mp 1.21 General Support 10
    D [further infos missing] Problems switching to live tv channel after resume 2.2 Archive 1
    P Multiple clients - share resume/watched data General 1
    U IR Blaster doesn't work after system wake/resume General Support 6
    megahorst Mediaportal chrashs when the PC goes to suspend mode (or when it resumes?) 1.19 11
    B pls help. tv stops playing but resumes if I push pause and play General 0
    BlueMax1916 Problems with MP1 client process dying when resuming from standby, probably MovingPictures related Moving Pictures 2
    Similar threads

























    Top Bottom