[Bug] MP1-4560 Backing out of Pictures full screen freezes MP (1 Viewer)

Sebastiii

Development Group
  • Team MediaPortal
  • November 12, 2007
    16,447
    10,273
    France
    France France
    Country flag
    I can't really debug right now, on finishing vacation lol
     

    Sebastiii

    Development Group
  • Team MediaPortal
  • November 12, 2007
    16,447
    10,273
    France
    France France
    Country flag
    I was able to reproduce it (always so that's good) and it seems that MP get lost in a loop.
    So i will need to see how to fix it :)
    And maybe post a binary soon :p
     

    Sebastiii

    Development Group
  • Team MediaPortal
  • November 12, 2007
    16,447
    10,273
    France
    France France
    Country flag
    Issue is maybe introduced by :
    MP1-4521 : Remember_last_used_folder_in_MyPictures_is_not_working

    So hope it will not break other part on mypicture.

    @regeszter , i will add a workaround to fix the issue and hope it will not break the last item selected when exit the slideshow.

    The loop is happening because the folder is set to empty (because of MP1-4521).

    But if only that part need a fix we are good but i'm not 100% sure lol.
     

    regeszter

    Retired Team Member
  • Premium Supporter
  • October 29, 2005
    5,335
    4,954
    Hungary Hungary
    The loop is happening because the folder is set to empty (because of MP1-4521).
    I don't understand how this issue is connect the MP1-4521 but if you can give me an step by step guide how can I reproduce it, then I will check it. :)
     

    Sebastiii

    Development Group
  • Team MediaPortal
  • November 12, 2007
    16,447
    10,273
    France
    France France
    Country flag
    The loop is happening because the folder is set to empty (because of MP1-4521).
    I don't understand how this issue is connect the MP1-4521 but if you can give me an step by step guide how can I reproduce it, then I will check it. :)
    It seems to reset some folder somehow and trigger the issue.

    I just add a check on null value : https://github.com/Sebastiii/MediaPortal-1/commit/86dee5e81a394a7349f395397717f2f5b2550366

    And it fix the issue for me :)

    The step by step :

    1- Clear thumb + picture db
    2- Start to play some picture
    3- Go back (ESC or B key or remote)
    4- MP get freezed because in loop (while(true) ......)

    So it's not related and it's different issue from the other one i notice (when thumb are generated, we need to wait until it finished or something, i don't remember exactly how i trigger it but from i remember, it was with picture and video but that's a different issue :) ) so off topic lol
     

    Sebastiii

    Development Group
  • Team MediaPortal
  • November 12, 2007
    16,447
    10,273
    France
    France France
    Country flag
    The loop is happening because the folder is set to empty (because of MP1-4521).
    I don't understand how this issue is connect the MP1-4521 but if you can give me an step by step guide how can I reproduce it, then I will check it. :)
    Finally not sure it was related :) seems that howudodat are on 1.8.0 and MP1-4521 was merged for 1.9.0 Pre-release :)

    So hopping that the fix is working for good :)
     

    Users Who Are Viewing This Thread (Users: 0, Guests: 1)

    OP Similar threads Forum Replies Date
    ajs [News] MediaPortal 1.26 Pre-Release ready for testing! News and Announcements 0
    C Hauppauge HVR-1265 -- does it work with MP1? MediaPortal 1 Talk 1
    ajs MP2Web - MP1 compatibility MediaPortal 1 20
    T MadVR + LAV Filters, Perfect in MPC-BE, Bad in MP1 MediaPortal 1 Talk 13
    P MP2: US user, OTA - can NOT get SchedulesDirect plugin to work on MP1 or MP2 --> how do I get OTA schedule? General 5
    framug [solved] Some changes/fix in MP1 configuration client and server Submit: code patches (MediaPortal/TV-Server/etc.) 14
    S TV-Server MP1 - Automatic search doesn't work Installation, configuration support 2
    C Streaming/transcoding MP2 vs MP1? General 4
    ajs [fixed] 5015: Improving the MP1 installer, providing nicer GUI :) MediaPortal 1 138
    C Streaming to clients over Wifi. MP1 or MP2? Newcomers Forum 0
    S Shortcuts MP1 My Recorded & TV Guide General 10
    azzuro [WiP] MP1-4999 - Big changes with many related change at once by Sebastiii MediaPortal 1 22
    ajs [WiP] MP1 X64 Version MediaPortal 1 70
    joecrow How about a Launcher plugin for MP1? MediaPortal 1 6
    wizard123 [solved] MP1 Build help MediaPortal 1 21
    ajs [News] MediaPortal 1 - 1.24 Released! News and Announcements 3
    CyberSimian [fixed] MP1-4990 : Improve horizontal scrolling in the EPG MediaPortal 1 10
    azzuro [WiP] MP1-5019: Replace MySQL with MariaDB MediaPortal 1 40
    catalpa Umsteiger von MP1: Schwierigkeiten Allgemeines Support- und Diskussionsforum 17
    CyberSimian [solved] MP1-4976 Built-in skin variables for current date MediaPortal 1 8
    rbo [solved] Umsteiger MP1 zu MP2 Allgemeines Support- und Diskussionsforum 67
    azzuro [Info] MP2 TVE inside MP1 repo MediaPortal 2 12
    G MP1 TV Server "failed to upgrade the database" using MS Sql Server Installation, configuration support 3
    lisag Can I get MP1 to open in the Recorded TV screen? MediaPortal 1 Talk 2
    M MP1 stops responding after Starting Plugins General Support 14
    Similar threads

























    Top Bottom