MP2.2 Pre Release fails installation with not starting the MP2-service (1 Viewer)

Status
Not open for further replies.

tnarraf

MP Donator
  • Premium Supporter
  • May 23, 2013
    20
    1
    54
    Great Britain (UK) Great Britain (UK)
    Country flag
    MediaPortal 2 Version: 2.1.3

    Description
    I am upgrading from 2.1.3 to 2.2 Pre release
    Setup goes all the way through to Starting Services and after a long time comes up with a Windows Box 'Service MediaPortal 2 Server Service (MP2-Server) failed to start. Check you have sufficient priviledges...
    It has a retry option but this just takes a long time and ends up where I was.
    I rebooted and then re-ran with the MP2-Setup-logging.bat file and same thing happened. Logfiles from this are 0 bytes long
    Service exists in service manager
    I attempted to start it manually and quite quickly it came back saying it started and then stopped

    I found a Crash log in the log folder and the most obvious item is :
    == Exception: System.IO.DirectoryNotFoundException: Could not find a part of the path 'C:\Program Files (x86)\Team MediaPortal\MP2-Server\Plugins'.

    (crash logs attached)
    I had 2.1.3 installed on the D drive
    My C drive is a small SSD for just the OS and then I install programs on the D drive
    I now seem to have some MP2 stuff in C:\Program Files (x86)\Team MediaPortal and some in
    D:\Program Files (x86)\Team MediaPortal\
    There is a Plugins Dir in the D drive copy but not the C drive bits so I guess this is causing the error

    I originally had MP1.20 installed on the C Drive so this may be 'confusing it'

    I'm going to cancel the setup (only option). Remove the C: drive Team Media Portal Folder and try setup again
    I will update this ticket

    Steps to Reproduce:
    Run MP2-Setup.exe upgarding from 2.1.3
     

    Attachments

    tnarraf

    MP Donator
  • Premium Supporter
  • May 23, 2013
    20
    1
    54
    Great Britain (UK) Great Britain (UK)
    Country flag
    With the 'upgrade' I did not get the option that I can remember. The only choice was Cient and Server, Or Client or Server or there may have been a 4th option.
    Certainly do not think it looked like that wike screenshot

    I have managed to get it installed and it is running

    By uninstalling MP2.1.3. Removing the folder Team Media Portal on the D drive and then it has installed on the C drive
    I have a Plugins folder off MP-TV Server amd it has started OK.
    It kept all my settings from 2.1.3 (which I had exported from the TVserver on 2.1.3 before uninstalling) and I am waiting for it 're-import' my media
     

    HTPCSourcer

    Retired Team Member
  • Premium Supporter
  • May 16, 2008
    11,431
    2,334
    Germany Germany
    Country flag
    Good that you were able to sort it out.

    @aspik, something to look at in the future: how does the installer behave if it encounters a non-standard setup like in this case?
     

    aspik

    Development Group
  • Team MediaPortal
  • April 14, 2008
    1,386
    556
    @aspik, something to look at in the future: how does the installer behave if it encounters a non-standard setup like in this case?
    There is a custom action to read the custom paths from an existing installation in order to update the files in those path(s). According to the logs, this action gets called. I can't say why the installer ends with an privilege error.

    I found some more info about this error here. I suppose this point:
    • The drive that contains the folder that you are trying to install the Windows Installer package to is accessed as a substitute drive.
    can apply here. But I'm not sure what they mean by "substitute" drive.

    Personally I never tried an installation on a different drive than the default C:\, so I don't know how reliable this procedure is in case of an update.
     
    Status
    Not open for further replies.

    Users who are viewing this thread

    Similar threads
    OP Title Forum Replies Date
    P MP2 TV Recording Logs General 1
    T MP2 - V2.3 MP2 Won't Restart, Requires System Reboot Submit: Bug Reports 2
    ge2301 MP2 - V2.4 [MP2-863] Extend View Mode Settings MediaPortal 2 8
    porky996t Outdated Tuning Parameters in MP2 TVServer Config TV-Server 0
    B IRSS shows button presses, nothing happening out-of-the-box in MP2 Newcomers Forum 1
    D MP2 DLNA status? General 10
    N [solved] MP2 TV-Server DD cine 2 V6, Astra keine deutschen Sender mehr General 4
    H MP2 - V2.4 [MP2-855] Extend Nereus HomeMenuEditor to allow configuration of HomeContent features MediaPortal 2 16
    M MP2 - V2.3 MP2 & USB Problems Submit: Bug Reports 43
    L MP2 - V2.3 Troubles upgrading from MP2 2.2.3 to 2.3 General 0
    T MP2 - V2.3 MP2 x64 won't run Submit: Bug Reports 5
    J Copying Old VHS tapes Newcomers Forum 8
    W MP2 - V2.3 MP2 2.3 Import von Audioquellen / Datenbankprobleme Allgemeines Support- und Diskussionsforum 26
    G MP2 - V2.3 New install and crashing MP2-2.3 General 6
    S MP2 - V2.3 MP2 No video General 6
    W [solved] MP2 Server stürzt immer nach kurzer Zeit ab Allgemeines Support- und Diskussionsforum 89
    toricred MP2 - V2.3 MP2 2.3 Client won't start General 7
    Grisu002 MP2 - V2.3 MP2 2.3 Client startet nicht - bleibt beim Laden hängen Allgemeines Support- und Diskussionsforum 64
    M [solved] MP2 PROBLEME Standby Allgemeines Support- und Diskussionsforum 2
    Scheibes Was passiert bei MP2? Allgemeines Support- und Diskussionsforum 42
    S Programmierte Aufnahme in MP2 - kein Aufwachen des PC Allgemeines Support- und Diskussionsforum 5
    morpheus_xx [Finished] "What's New" plugin for MP2 upgrades MediaPortal 2 20
    da3dsoul [Request] An MVP Plugin example for custom settings in MP2 Plugin Development 2
    morpheus_xx MP2 - V2.4 Porting MP2 to .Net (Core) 5 MediaPortal 2 49
    da3dsoul Does MP2 not have any active devs? General 8

    Similar threads

    Top Bottom