MP2.2 Pre Release fails installation with not starting the MP2-service (1 Viewer)

Status
Not open for further replies.

tnarraf

MP Donator
  • Premium Supporter
  • May 23, 2013
    20
    1
    54
    Great Britain (UK) Great Britain (UK)
    Country flag
    MediaPortal 2 Version: 2.1.3

    Description
    I am upgrading from 2.1.3 to 2.2 Pre release
    Setup goes all the way through to Starting Services and after a long time comes up with a Windows Box 'Service MediaPortal 2 Server Service (MP2-Server) failed to start. Check you have sufficient priviledges...
    It has a retry option but this just takes a long time and ends up where I was.
    I rebooted and then re-ran with the MP2-Setup-logging.bat file and same thing happened. Logfiles from this are 0 bytes long
    Service exists in service manager
    I attempted to start it manually and quite quickly it came back saying it started and then stopped

    I found a Crash log in the log folder and the most obvious item is :
    == Exception: System.IO.DirectoryNotFoundException: Could not find a part of the path 'C:\Program Files (x86)\Team MediaPortal\MP2-Server\Plugins'.

    (crash logs attached)
    I had 2.1.3 installed on the D drive
    My C drive is a small SSD for just the OS and then I install programs on the D drive
    I now seem to have some MP2 stuff in C:\Program Files (x86)\Team MediaPortal and some in
    D:\Program Files (x86)\Team MediaPortal\
    There is a Plugins Dir in the D drive copy but not the C drive bits so I guess this is causing the error

    I originally had MP1.20 installed on the C Drive so this may be 'confusing it'

    I'm going to cancel the setup (only option). Remove the C: drive Team Media Portal Folder and try setup again
    I will update this ticket

    Steps to Reproduce:
    Run MP2-Setup.exe upgarding from 2.1.3
     

    Attachments

    tnarraf

    MP Donator
  • Premium Supporter
  • May 23, 2013
    20
    1
    54
    Great Britain (UK) Great Britain (UK)
    Country flag
    With the 'upgrade' I did not get the option that I can remember. The only choice was Cient and Server, Or Client or Server or there may have been a 4th option.
    Certainly do not think it looked like that wike screenshot

    I have managed to get it installed and it is running

    By uninstalling MP2.1.3. Removing the folder Team Media Portal on the D drive and then it has installed on the C drive
    I have a Plugins folder off MP-TV Server amd it has started OK.
    It kept all my settings from 2.1.3 (which I had exported from the TVserver on 2.1.3 before uninstalling) and I am waiting for it 're-import' my media
     

    HTPCSourcer

    MP2 Product Manager
  • Team MediaPortal
  • May 16, 2008
    11,431
    2,333
    Germany Germany
    Country flag
    Good that you were able to sort it out.

    @aspik, something to look at in the future: how does the installer behave if it encounters a non-standard setup like in this case?
     

    aspik

    Development Group
  • Team MediaPortal
  • April 14, 2008
    1,383
    553
    @aspik, something to look at in the future: how does the installer behave if it encounters a non-standard setup like in this case?
    There is a custom action to read the custom paths from an existing installation in order to update the files in those path(s). According to the logs, this action gets called. I can't say why the installer ends with an privilege error.

    I found some more info about this error here. I suppose this point:
    • The drive that contains the folder that you are trying to install the Windows Installer package to is accessed as a substitute drive.
    can apply here. But I'm not sure what they mean by "substitute" drive.

    Personally I never tried an installation on a different drive than the default C:\, so I don't know how reliable this procedure is in case of an update.
     
    Status
    Not open for further replies.

    Users Who Are Viewing This Thread (Users: 0, Guests: 1)

    OP Similar threads Forum Replies Date
    mp2-ulrich [solved] MP 2.2.3 spielt nur manche Sender Allgemeines Support- und Diskussionsforum 2
    H MP2 database won't keep in synch with recordings General 8
    H [solved] MP2 Wiedergabe von Aufnahmen und Live TV geht nicht Allgemeines Support- und Diskussionsforum 6
    ge2301 [WiP] MP2Web - A platform independent web client for MP2 MediaPortal 2 68
    F Problems with new install of MP2 Newcomers Forum 3
    catalpa Bug MP2-837 Allgemeines Support- und Diskussionsforum 2
    P MP2: US user, OTA - can NOT get SchedulesDirect plugin to work on MP1 or MP2 --> how do I get OTA schedule? General 5
    bigboss97 Does anyone has a SoundGraph imon remote file for MP2 to share? General 0
    ge2301 Android based client for MP2 MediaPortal 2 3
    R MP2 GUI Issues General 7
    P [solved] MP2 new install, 2 x hdhomerun tuners, client on same PC unable to view TV & recordings Newcomers Forum 8
    Lichloathe MP2 importing keyart instead of poster General 0
    Lichloathe Trakt for MP2 question General 7
    C Streaming/transcoding MP2 vs MP1? General 4
    P MP 2 - Request to add an additional TV series Filename protocal Feature Requests 0
    C Streaming to clients over Wifi. MP1 or MP2? Newcomers Forum 0
    CyberSimian MP2 synchronising of stoptime MediaPortal 1 Talk 5
    M Initial Setup MP2 (On Wndows 10) General 2
    R [solved] MP2 Client ist extrem langsam Allgemeines Support- und Diskussionsforum 5
    D [solved] EPG Buddy for MP2 - Does it work? General 5
    T Amazon und Netflix in MP2 - Wie? Allgemeines Support- und Diskussionsforum 6
    J [solved] How to in MP2 General 19
    M [fixed] [MP2-831] 12h time format shown in TV Guide with Swedish language settings Submit: Bug Reports 27
    Volker MP2 Rewind / zurückspulen bei Live TV funktioniert nicht Allgemeines Support- und Diskussionsforum 3
    B [solved] MP2.2.3 TV Guide not scrolling with mouse wheel General 2
    Similar threads

























    Top Bottom