mysqld.exe CPU spikes whenever TV Server is running (1 Viewer)

DragonQ

Portal Pro
August 30, 2011
644
78
United Kingdom United Kingdom
Using MediaPortal 1.3.0 RC, whenever the TV Server is running on my HTPC (single seat), I get mysqld.exe CPU spikes every 10 seconds or so. See this image:

CPU spikes.png


I only noticed this today, not sure how long it's been going or what's caused it but I recently installed DJBlu's Custom Data Grabber. However, this issue occurs even if my TV Server plugins are disabled (Sky UK Grabber and PowerScheduler++) so I'm not sure if that's related.

I did a complete reinstall of MediaPortal - the only things I kept from my previous installation was my channel and schedule list, and my Moving Pictures and MP-TVSeries databases. The CPU spikes are still there, but not as large (5-10% rather than 30-50%). The TV database does not need repairing (mysqlcheck mptvdb --auto-repair -e -u root -p --password=MediaPortal comes back clear).

Is there a way of seeing what specifically is accessing the database? I've installed MySQL Workbench but can't see a way of checking logs or anything. I've attached logs.
 

Attachments

Last edited:

DragonQ

Portal Pro
August 30, 2011
644
78
United Kingdom United Kingdom
As I said in my first post, disabling the TV-Server plugins doesn't fix the problem.
 

tourettes

Retired Team Member
  • Premium Supporter
  • January 7, 2005
    17,301
    4,800
    If you remove the schedules does it remove the CPU spikes? TVE could be just going thru the schedules and EPG to see if it should record something.
     

    DragonQ

    Portal Pro
    August 30, 2011
    644
    78
    United Kingdom United Kingdom
    Hmm interesting hypothesis. I'll give that a go later.

    If that turns out to be the cause, how can the CPU spikes be eliminated? Perhaps the database is too big and contains older, unused schedules still?
     

    DragonQ

    Portal Pro
    August 30, 2011
    644
    78
    United Kingdom United Kingdom
    You were right, removing all of my schedules fixed the problem. After re-adding them, I managed to trim the list down from 36 to 30 but I want to keep most of the rest.

    Is this fixable by changing a setting somewhere or is it a bug that needs patching?
     
    Last edited:

    tourettes

    Retired Team Member
  • Premium Supporter
  • January 7, 2005
    17,301
    4,800
    You were right, removing all of my schedules fixed the problem. After re-adding them, I managed to trim the list down from 36 to 30 but I want to keep most of the rest.

    Is this fixable by changing a setting somewhere or is it a bug that needs patching?
    How many channels you have? Try trimming down the EPG data - do not grap EPG for channels that you aren't using? Not sure if there is something that could be done to reduce the DB queries.
     

    DragonQ

    Portal Pro
    August 30, 2011
    644
    78
    United Kingdom United Kingdom
    About 200 channels (TV & radio combined). Surely that is not excessive.
     

    Users Who Are Viewing This Thread (Users: 0, Guests: 1)

    Top Bottom