MyTrailers 2.0.2 (beta) | Page 22

Discussion in 'My Trailers' started by armandp, October 3, 2008.

Thread Status:
Not open for further replies.
  1. SilentException
    • Team MediaPortal

    SilentException Retired Team Member

    Joined:
    October 27, 2008
    Messages:
    2,617
    Likes Received:
    1,125
    Gender:
    Male
    Location:
    Rijeka, Croatia
    Ratings:
    +1,129 / 0
    Home Country:
    Croatia Croatia
    thats nice to hear.. this is one of the best plugins so keep up the good work!



    no biggie with this one.. i built my own svn version but maybe others would like it "fixed" too.. i have a good eye for those small glitches hehe :)
     
  2. Google AdSense Guest Advertisement



    to hide all adverts.
  3. armandp
    • Team MediaPortal

    armandp Retired Team Member

    Joined:
    April 6, 2008
    Messages:
    990
    Likes Received:
    584
    Gender:
    Male
    Occupation:
    Application Designer
    Location:
    Zoetermeer
    Ratings:
    +616 / 0
    Home Country:
    Netherlands Netherlands
    Show System Specs
    iyou can submit the patch on the google code page. if you have more fixes and you are up for it i can even grant you the righs to commit to svn yourself. extra developers are always welcome.
    Posted via Mobile Device
     
  4. Raytestrak
    • Premium Supporter

    Raytestrak MP Donator

    Joined:
    April 12, 2008
    Messages:
    497
    Likes Received:
    21
    Occupation:
    IT Engineer
    Location:
    Honselersdijk
    Ratings:
    +21 / 0
    Home Country:
    Netherlands Netherlands
    I uninstalled quicktime and Medialooks to try the tips you posted on page 16, but I'n not getting anywhere ... AT ALL ... now when I try to load a trailer from apple.com or a mov file, graphedit just says "well screw you". I don't have the necessary filters installed, but I am running the latest Haali and CoreAVC. Which should be enough for video at least, right? When I try to manually create a graph, it GraphEdit says the filetype isn't recognized. I'm trying, but I'm just not understanding what I'm doing :(

    Edit:

    I'm a bit further (and a bit more aware of what a complete moron I am). The .mov file I was loading was a h263 container. I have a h264 .mov now,1080p batman trailer which plays fine in graphEdit. But MyTrailers still doesn't work, nor does rendering a url in GraphEdit.

    I've added a sample of my log. If I click the url to Crank2 in internet explorer it opens fine in MediaPlayer Classic but not in MediaPortal or GraphEdit.

    2009-02-06 20:13:46.286454 [Info.][MyTrailersWorker]: [MyTrailers][Apple Trailers] Retrieving index: /just_added
    2009-02-06 20:13:46.290454 [Info.][MyTrailersWorker]: [MyTrailers][Apple Trailers] Fetching trailers for: /just_added
    2009-02-06 20:13:47.366454 [Info.][MyTrailersWorker]: [MyTrailers][Apple Trailers] Found 80 items.
    2009-02-06 20:13:49.897454 [Info.][MPMain]: download failed:The remote server returned an error: (404) Not Found.
    2009-02-06 20:13:49.898454 [Info.][MPMain]: texture:C:\ProgramData\Team MediaPortal\MediaPortal\Thumbs\MPTemp10.gif does not exist
    2009-02-06 20:13:52.492454 [Info.][MyTrailersWorker]: [MyTrailers][Apple Trailers] Retrieving details: /trailers/lions_gate/crank2/
    2009-02-06 20:13:52.946454 [Info.][MyTrailersWorker]: [MyTrailers][Apple Trailers] Added 1 poster.
    2009-02-06 20:13:53.396454 [Info.][MyTrailersWorker]: The remote name could not be resolved: 'www.apple.comhttp'
    2009-02-06 20:13:53.399454 [Info.][MyTrailersWorker]: The remote name could not be resolved: 'www.apple.comhttp'
    2009-02-06 20:13:53.400454 [Info.][MyTrailersWorker]: The remote name could not be resolved: 'www.apple.comhttp'
    2009-02-06 20:13:53.401454 [Info.][MyTrailersWorker]: [MyTrailers] Error connecting to http://www.apple.comhttp://crank2.com/ . Reached retry limit of 3
    2009-02-06 20:13:53.405454 [Info.][MyTrailersWorker]: Error parsing results from http://www.apple.comhttp://crank2.com/ as XML: Root element is missing.
    2009-02-06 20:13:53.406454 [Info.][MyTrailersWorker]: [MyTrailers][Apple Trailers] No XML Found for trailer page: http://www.apple.comhttp://crank2.com/
    2009-02-06 20:13:53.407454 [Info.][MyTrailersWorker]: [MyTrailers][Apple Trailers] Added 1 trailers.
    2009-02-06 20:13:54.321454 [Debug][MPMain]: WindowManager: route MediaPortal.Plugins.Trailers.GUITrailers:5900->MediaPortal.Dialogs.GUIDialogMenu:2012
    2009-02-06 20:13:54.323454 [Debug][MPMain]: DialogWindow: MediaPortal.Dialogs.GUIDialogMenu init
    2009-02-06 20:13:55.406454 [Debug][MPMain]: WindowManager: unroute to MediaPortal.Dialogs.GUIDialogMenu:2012->MediaPortal.Plugins.Trailers.GUITrailers:5900
    2009-02-06 20:13:55.427454 [Info.][MPMain]: [MyTrailers] Trying PlayStream()
    2009-02-06 20:13:55.430454 [Debug][MPMain]: CommandProcessor: add cmd: MediaPortal.TV.Recording.StopRadioCommand #1
    2009-02-06 20:13:55.431454 [Info.][MPMain]: g_Player.PlayVideoStream(http://movies.apple.com/movies/lionsgate/crank2/crank2-tlr1b_h1080p.mov)
    2009-02-06 20:13:55.432454 [Info.][CommandProcessor]: Commandprocessor: MediaPortal.TV.Recording.StopRadioCommand failed reason: No tuner cards installed time: 1 msec
    2009-02-06 20:13:55.435454 [Info.][MPMain]: VideoPlayer:play http://movies.apple.com/movies/lionsgate/crank2/crank2-tlr1b_h1080p.mov
    2009-02-06 20:13:55.516454 [Info.][MPMain]: VideoPlayerVMR9: Enabling DX9 exclusive mode
    2009-02-06 20:13:55.525454 [Info.][MPMain]: VMR9: added EVR Renderer to graph
    2009-02-06 20:13:55.587454 [Debug][MPMain]: VMR9: Now active
    2009-02-06 20:13:55.587454 [Debug][MPMain]: VMR9: Renderer successfully added
    2009-02-06 20:13:55.594454 [Info.][MPMain]: DirectShowUtils: First try to insert new audio renderer DirectSound: Realtek Digital Output (Realtek High Definition Audio)
    2009-02-06 20:13:55.651454 [Info.][MPMain]: DirectShowUtils: Found audio renderer
    2009-02-06 20:13:55.652454 [Debug][MPMain]: DirectShowUtils: added filter:DirectSound: Realtek Digital Output (Realtek High Definition Audio) to graph
    2009-02-06 20:13:55.657454 [Info.][MPMain]: added filter:AC3Filter to graph
    2009-02-06 20:13:55.663454 [Info.][MPMain]: added filter:DirectVobSub to graph
    2009-02-06 20:13:55.953454 [Info.][MPMain]: PlaneScene: PresentSurface() dispose surfaces
    2009-02-06 20:13:55.983454 [Info.][MPMain]: VideoPlayerVMR9: add normal vob sub filter
    2009-02-06 20:13:55.983454 [Info.][MPMain]: VideoPlayerVMR9: Setting DirectVobsub parameters
    2009-02-06 20:13:56.045454 [Info.][MPMain]: VideoPlayer:Duration:0
    2009-02-06 20:13:56.049454 [Debug][MPMain]: VideoPlayer: FoundStreams: Type=Subtitle_shown; Name=Show Subtitles, Filter=DirectVobSub, Id=0, PDWGroup=6590033
    2009-02-06 20:13:56.049454 [Debug][MPMain]: VideoPlayer: FoundStreams: Type=Subtitle_hidden; Name=Hide Subtitles, Filter=DirectVobSub, Id=1, PDWGroup=6590033
    2009-02-06 20:13:56.049454 [Debug][MPMain]: VideoPlayer: FoundStreams: Type=Unknown; Name=Original Picture, Filter=DirectVobSub, Id=2, PDWGroup=6590034
    2009-02-06 20:13:56.049454 [Debug][MPMain]: VideoPlayer: FoundStreams: Type=Unknown; Name=Flipped Picture, Filter=DirectVobSub, Id=3, PDWGroup=6590034
    2009-02-06 20:13:56.051454 [Info.][MPMain]: g_Player.OnStarted() Crank 2 media:Video
    2009-02-06 20:13:56.054454 [Debug][MPMain]: GUITVCropManager.g_Player_PlackBackStarted: media: Video tv:False ts:False
    2009-02-06 20:13:56.056454 [Info.][MPMain]: opening video database
    2009-02-06 20:13:56.062454 [Info.][MPMain]: video database opened
    2009-02-06 20:13:56.071454 [Info.][MPMain]: [MyTrailers] Playback OK.
    2009-02-06 20:13:56.071454 [Debug][MPMain]: g_Player: ShowFullScreenWindow
    2009-02-06 20:13:56.073454 [Info.][MPMain]: g_Player: ShowFullScreenWindow switching to fullscreen video
    2009-02-06 20:13:56.073454 [Debug][MPMain]: Window: MediaPortal.Plugins.Trailers.GUITrailers deinit
    2009-02-06 20:13:56.092454 [Debug][MPMain]: TextureManager: CleanupThumbs()
    2009-02-06 20:13:56.104454 [Debug][MPMain]: Window: MediaPortal.GUI.Video.GUIVideoFullscreen init
    2009-02-06 20:13:56.112454 [Info.][MPMain]: xml:C:\Program Files\Team MediaPortal\MediaPortal\Skin\MediaStream\videoOSD.xml image id:350 width:0 height:0 gfx:-
    2009-02-06 20:13:56.150454 [Debug][MPMain]: VMR9Helper: Playing -> Repainting, Frames 50
    2009-02-06 20:13:56.185454 [Debug][MPMain]: VMR9: Repainting -> Playing, Frames: 50
    2009-02-06 20:13:57.193454 [Debug][MPMain]: VMR9Helper: Playing -> Repainting, Frames 0
     
  5. giantpopples

    giantpopples Portal Member

    Joined:
    January 16, 2008
    Messages:
    15
    Likes Received:
    3
    Ratings:
    +3 / 0
    Hi !

    I've updated the Project Mayhem III skin, so it is compatible with the 2.0.2 version (select provider button), it msses the studio information on the detail page, because it is too much information on a 4:3 screen...

    BTSW, what is the second stacklayout control for ? ( the one with : video title, video published and video image), so i can see and integrate it in PMIII.

    Thanks again for this great plugin which works perfectly ! I would also be glad to receive your instruction for the new skin design for your next version of the plugin, so i can try to make a XML for PMIII.

    Best regards,

    Romain
     

    Attached Files:

  6. Raytestrak
    • Premium Supporter

    Raytestrak MP Donator

    Joined:
    April 12, 2008
    Messages:
    497
    Likes Received:
    21
    Occupation:
    IT Engineer
    Location:
    Honselersdijk
    Ratings:
    +21 / 0
    Home Country:
    Netherlands Netherlands
    I found the cause of my problem, it was PowerDVD7. I finally got Graphedit to render a url and it was using PowerDVD splitter, instead of Haali Mediasplitter AX. I removed PowerDVD and now my trailers work, only thing is that I have to keep mediaportal always on top, otherwise the taskbar comes on top and MP is uncontrollable after the trailers stops (since the taskbar is active instead of MP).

    Question: Is it possible to get 5.1 sound on trailers somehow?
     
  7. armandp
    • Team MediaPortal

    armandp Retired Team Member

    Joined:
    April 6, 2008
    Messages:
    990
    Likes Received:
    584
    Gender:
    Male
    Occupation:
    Application Designer
    Location:
    Zoetermeer
    Ratings:
    +616 / 0
    Home Country:
    Netherlands Netherlands
    Show System Specs
    Yes it's possible.. I will kinda type this in a hurry cause i'm busy with some other stuff now but i'm assuming you also use AC3Filter.

    First, not all trailers have 5.1 audio btw so find one that does . The trailer i'm sure of that has 5.1 (as i used it to test my codecs) is the one from Terminator Salvation the 720p one. There are a couple of problems i encountered in the beginning.. problem one was that if Monogram AAC was the preferred audio decoder (which is the case after installing mediaportal) between Haali and AC3Filter the sounds was 5.1 but the channels were mixed up.. after this i tried MPC Audio Decoder and it could decode the AAC sound from Apple Trailers and it had the channels correct. So i started with MPC Audio Decoder.. i set the merit for AC3Filter to preferred +1 and the MPC Audio Decoder as merit normal with no audio codecs above that.. In the MPC Audio Codec properties set the output to SPDIF.
     
    • Like Like x 1
  8. Raytestrak
    • Premium Supporter

    Raytestrak MP Donator

    Joined:
    April 12, 2008
    Messages:
    497
    Likes Received:
    21
    Occupation:
    IT Engineer
    Location:
    Honselersdijk
    Ratings:
    +21 / 0
    Home Country:
    Netherlands Netherlands
    Thanx, everything's working now. Monogram AAC does indeed screw up the channels, center was switched with front left. Now running ffdshow for AAC and some other exotic audio codecs used in some of my anime's. Thanks again for the help.
     
  9. armandp
    • Team MediaPortal

    armandp Retired Team Member

    Joined:
    April 6, 2008
    Messages:
    990
    Likes Received:
    584
    Gender:
    Male
    Occupation:
    Application Designer
    Location:
    Zoetermeer
    Ratings:
    +616 / 0
    Home Country:
    Netherlands Netherlands
    Show System Specs
    Oke glad to be of service.. it mostly is a one time trial & error kind of thing with all these different codecs nowadays :)
     
  10. Raytestrak
    • Premium Supporter

    Raytestrak MP Donator

    Joined:
    April 12, 2008
    Messages:
    497
    Likes Received:
    21
    Occupation:
    IT Engineer
    Location:
    Honselersdijk
    Ratings:
    +21 / 0
    Home Country:
    Netherlands Netherlands
    If it only were a one time thing ... I spend so much time tweaking my HTPC it's almost like work :D

    My girlfriend's always telling me to leave it be if everythings working fine, but I just can't help myself. If I see a nice tweak or an update, I HAVE to apply it. Usually 5 minutes before I should go to bed or out or right before my girlfriend has sat down to watch a movie together :D
     
  11. RetroZA

    RetroZA Portal Member

    Joined:
    July 1, 2008
    Messages:
    22
    Likes Received:
    0
    Location:
    Cape Town
    Ratings:
    +0 / 0
    Home Country:
    South Africa South Africa
    Can this plugin be used for playing local files as well? I have a bunch of HD trailers that I would like to add to Media Portal if possible. Or are there any other plugins I can use for this?
     
Thread Status:
Not open for further replies.

Users Viewing Thread (Users: 0, Guests: 0)

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice
  • About The Project

    The vision of the MediaPortal project is to create a free open source media centre application, which supports all advanced media centre functions, and is accessible to all Windows users.

    In reaching this goal we are working every day to make sure our software is one of the best.

             

  • Support MediaPortal!

    The team works very hard to make sure the community is running the best HTPC-software. We give away MediaPortal for free but hosting and software is not for us.

    Care to support our work with a few bucks? We'd really appreciate it!