NFO import not working (1 Viewer)

PrinzValium

Portal Member
December 26, 2010
29
4
Germany Germany
My movies are stored in a network direcotry, each in a separate folder with the movie file, a nfo file, a cover jpg and a fanart jpg.
When I try to import movies through AMC Updater it seems to be doing something and in the end a "Process Complete" pops up but not a single file is added. I've already read the wiki and set up everything accordingly.
I attached a log and my settings if that helps.
--- Post updated ---
and here is a sample NFO file. I changed the extension to .txt to be able to upload
 

Attachments

catalpa

Portal Pro
May 9, 2009
385
19
Germany Germany
Country flag
dein nfo sollte ein xml-file sein und z.B. so aussehen:

XML:
<number>797</number>
  <title>Mel Brooks' Spaceballs</title>
  <originaltitle>Spaceballs </originaltitle>
  <translatedtitle>Mel Brooks' Spaceballs</translatedtitle>
  <formattedtitle>Spaceballs  (Mel Brooks' Spaceballs)</formattedtitle>
  <checked>True</checked>
  <url>http://www.imdb.com/title/tt0094012</url>
  <rating>7.0</rating>
  <plot>Skroob (Mel Brooks), der Präsident des Planeten Spaceball, sendet den dunkle$
  <runtime>92</runtime>
  <languages>German</languages>
  <genre>Komödie,Science-Fiction</genre>
  <country>USA</country>
  <year>1987</year>
  <date>2012-10-07</date>
  <plot>Skroob (Mel Brooks), der Präsident des Planeten Spaceball, sendet den dunkle$
  <director>Mel Brooks</director>
  <actors>
    <actor>
      <name>Mel Brooks</name>
      <role>President Skroob /Yogurt</role>
    </actor>
    <actor>
      <name>John Candy</name>
      <role>Barf</role>
    </actor>
    <actor>
      <name>Rick Moranis</name>
      <role>Dark Helmet</role>
    </actor>
    <actor>
      <name>Bill Pullman</name>
      <role>Lone Starr</role>
    </actor>
    <actor>
      <name>Daphne Zuniga</name>
      <role>Princess Vespa</role>
    </actor>
  </actors>
  <producers>
    <producer>
      <name>Mel Brooks</name>
      <role>producer</role>
    </producer>
    <producer>
      <name>Ezra Swerdlow</name>
      <role>co-producer</role>
    </producer>
  </producers>
  <mediainfo>
    <medialabel>Markus</medialabel>
    <mediatype>HDD</mediatype>
    <size>1602</size>
    <disks>1</disks>
    <source>\\SERVER\Filme2\Spaceballs\Spaceballs.mkv</source>
    <videoformat>AVC</videoformat>
    <videobitrate>1995</videobitrate>
    <audioformat>AC3</audioformat>
    <audiobitrate>384</audiobitrate>
    <resolution>716x554</resolution>
    <framerate>25.000</framerate>
    <subtitles>German</subtitles>
  </mediainfo>
  <artwork>
    <picture>pictures\Spaceballs.jpg</picture>
  </artwork>
  <status />
</movie>
 

PrinzValium

Portal Member
December 26, 2010
29
4
Germany Germany
dein nfo sollte ein xml-file sein und z.B. so aussehen:
Wenn ich den Scraper teste, dann erkennt er meine .nfo Datei aber korrekt. Ansonsten ist meine .nfo Datei ja auch im XML Standard aufgebaut und laut Wiki sollte es so auch klappen.
 

catalpa

Portal Pro
May 9, 2009
385
19
Germany Germany
Country flag
Hm, laut Wiki kann man Ember und MyFilms mit nfo zusammenbringen. Hab ich noch nie gemacht, deine sehen verwustet aus. Teste doch mal mit meinem Beispiel, natürlich mit Anpassung des serverpfades und filename.

Ich benutze nfos als Bindeglied zw. meinen MP und XBMC-Clients, klappt gut. Leider versteht sich mein Editor (ANT) neuerdings nicht mehr mit MyFilms, eine Besserung ist nicht in Sicht und ich fänge auf einer uralten Version fest.
 

StephanM

Portal Member
October 14, 2016
5
0
Barcelona
European Union European Union
Country flag
Just untick "Prohibit Internet Lookup" in the AMC Updater - Import Movies tab.
Don't know why, but it works.

Ich hatte das selbe Problem, als ich versuchte meine nfo Dateien von tinyMediaManager zu importieren. Nach langem Suchen habe ich den Übeltäter gefunden: man muss nur das Feld "Prohibit Internet Lookup" ausschalten. Ist überhaupt nicht logisch da man ja möchte dass alle Infos aus den nfo Dateien und nicht aus dem Internet eingelesen werden, aber es scheint notwendig zu sein. Tatsächlich werden die Daten aus nfo Dateien übernommen. Das soll einmal einer verstehen.
 

Guzzi

Retired Team Member
  • Premium Supporter
  • August 20, 2007
    2,161
    747
    Country flag
    true - it's pretty illogical from a user perspective ... reason is, that the nfo scraper had been added later as a "scraper" type and thus internally is handled like the other internet based scrapers. if I find the time, I'll change that ...
     
    Last edited:

    PrinzValium

    Portal Member
    December 26, 2010
    29
    4
    Germany Germany
    Habe es heute nochmal getestet. Leider werden meine Filme dann nicht mehr gescanned, folglich passiert auch wieder nichts.
    In der Log Datei findet sich dann jedoch zusätzlich der Eintrag "ErrorEvent : object reference not set to an instance of an object."
     

    HTPCSourcer

    MP2 Product Manager
  • Team MediaPortal
  • May 16, 2008
    11,431
    2,333
    Germany Germany
    Country flag
    @catalpa ,@StephanM , @Guzzi , @PrinzValium :

    Guys, this is the English section - no German please ;).

    Let me know if you would like to have your German postings moved to a separate thread in the appropriate forum section.
     

    Guzzi

    Retired Team Member
  • Premium Supporter
  • August 20, 2007
    2,161
    747
    Country flag
    you can leave it here - I changed my post to english ...
     

    Users Who Are Viewing This Thread (Users: 0, Guests: 1)

    OP Similar threads Forum Replies Date
    J [fixed] Importer confused on specific movies with the same title, different years and different NFO's Submit: Bug Reports 3
    F My Films and .nfo grabber don't grab all the covers Newcomers Forum 0
    cbr954rr [fixed] Movie db refresh on changes of nfo and correct spelling of words in titles 2.2 Archive 33
    M reimport of movies with changed nfo files General 14
    KlausWirn [solved] MePo1 Cover und Fanart in .nfo Datei ablegen Allgemeines Supportforum 8
    toricred Using TMM, How to Stop Importer From Going to The Movie Database for Data General 1
    Lichloathe MP2 importing keyart instead of poster General 0
    P Recordings not showing up unless re-imported and not possible to delete General 0
    C Importer works super slow My TVSeries 5
    C Imported media doesn't show up immediately? General 1
    X Recording import hängt Allgemeines Support- und Diskussionsforum 0
    J [fixed] Import issue with alternate movie title matching the name of another movie Submit: Bug Reports 7
    B xmltv - cannot import tvguide.xml australia Installation, configuration support 0
    B [solved] tvguide.xml not importing australian channels Electronic Program Guide 10
    azzuro [fixed] [WIP MP2.3] - Audio files not imported to MP MediaPortal 2 18
    thepahakurki TVDB import not working My TVSeries 3
    T I cannot get a basic media import-what is the best configuration? General 10
    L TV-Series kein Import Plugins & Erweiterungen 6
    J [fixed] [MP2-833] 2.2.2 server crash during import Submit: Bug Reports 50
    D Ripped movies not importing unless IMDB code is included in folder name General 4
    R [solved] Moving pictures importer wont add files from a removable drive. Is there a work around ? Moving Pictures 8
    MausWiesel LightsOut-Connector für MP2? Allgemeines Support- und Diskussionsforum 9
    fredco [solved] Large import not working Moving Pictures 15
    M [solved] MP2 Not discovering all movies Newcomers Forum 2
    J [fixed] [MP2-821] Importer glitches in 2.2 Submit: Bug Reports 42
    Similar threads

























    Top Bottom