No video in channel preview window (1 Viewer)

Sakols

Portal Member
November 21, 2016
33
2
58
United States of America United States of America
Country flag
Hi, Im not getting any video in the TV Server video preview window, while I do get audio. the video window is white. I have updated to the latest version of MP, and reinstalled LAV codecs, still no video. Logs attached. Not sure where to look to fix this.
 

Attachments

CyberSimian

Test Group
  • Team MediaPortal
  • June 10, 2013
    2,301
    1,385
    Southampton
    United Kingdom United Kingdom
    Country flag
    In the MP client, I do see the video.
    Other users experience this. See for example this thread.

    I don't know anything about the internals of "TV Server" or "TV Server Config", but my understanding is that the "Preview" window in "TV Server Config" uses a simplified interface to the tuning and decoding parts of "TV Server", as a result of which it does not work for all TV datastreams. In contrast, the MP client uses the full-function interface that supports all of the variants in TV datastreams.

    If the "Preview" window previously worked OK, but has recently stopped working, I would suspect that your broadcaster has changed the datastream in such a way that it can no longer be handled by the simplified interface used for the "Preview" window.

    Sadly, the number of active developers for MP1 has been steadily decreasing over the years, and the current team has no one who knows anything about "TV Server". So I think that it is unlikely that any solution or workaround will become available for the "Preview" screen. Sorry if this is not the answer that you were hoping for. :(

    -- from CyberSimian in the UK
     

    Sakols

    Portal Member
    November 21, 2016
    33
    2
    58
    United States of America United States of America
    Country flag
    Thanks.

    Perhaps I migrate to MP2? I have experience a lot of problems with MP1 and it makes a hobby just to keep it working. I think I went with MP1 was that all I wanted was a replacement for Windows TV player from Win7. I just use the PVR on a PC connected to the TV display. I also need the OTA EPG.
     

    CyberSimian

    Test Group
  • Team MediaPortal
  • June 10, 2013
    2,301
    1,385
    Southampton
    United Kingdom United Kingdom
    Country flag
    Perhaps I migrate to MP2?
    Unfortunately, MP2 uses the same "TV Server" and "TV Server Config" code as MP1 (although packaged differently, so you cannot mix MP1 with MP2). If the problem with the "Preview" window originates as I suggested, MP2 will have the same limitation.

    Unfortunately (again), the MP2 team also have no one who knows anything about "TVServer" or "TV Server Config". I will tag @morpheus_xx in case he wants to comment.

    -- from CyberSimian in the UK
     

    Sakols

    Portal Member
    November 21, 2016
    33
    2
    58
    United States of America United States of America
    Country flag
    Does anybody have experience with Happague's latest software. WinTV 10. If its reliable, supports a free matrix style EPG, Id give that a try. MediaPortal is really fiddly to get all the parts working right. My EPG is broken (mc2xml) and haven't started working on fixing that part.
     

    CyberSimian

    Test Group
  • Team MediaPortal
  • June 10, 2013
    2,301
    1,385
    Southampton
    United Kingdom United Kingdom
    Country flag
    Does anybody have experience with Hauppauge's latest software. WinTV 10.
    You will need to install it and try it for yourself. No two people want the same thing from mediacenter applications, and what one person finds very suitable, another may find to be cumbersome and inconvenient to use.

    An alternative might be the "NextPvr" application. I have never installed it, but from the screen shots on its web site, it looks to have similar features to MP. It is also free for personal use. Look at its forum to get a feel for the frequency and types of problems that "NextPvr" users encounter.

    There is a Wikipedia page that compares many mediacenter applications. I have it bookmarked somewhere, but I now have so many bookmarks I can never find anything, so you will have to find that web page for yourself.

    My EPG is broken (mc2xml) and haven't started working on fixing that part.
    In the UK we are blessed with a terrestrial TV system that includes a 7-day EPG as part of the TV datastream. But I think that the USA does not do this?

    The recommendation for WMC users is to pay for a "Schedules Direct" subscription, and use the "EPG123" tool to import the downloaded xml file into WMC. This combination is very highly regarded on the Green Button web site. If you still have Windows 7 available, you might consider re-installing it and using WMC with "Schedules Direct" and "EPG123".

    "Schedules Direct" can also be used with MP's "TV Server" -- there is a plugin for it. However, the only user who tried it recently could not get it to work. I suspect that he was a computer novice, and was making some fundamental mistake that it was not possible to diagnose over the internet.

    The final possibilities would be to buy or rent the DVR available from your TV provider, or buy or rent a Tivo (if that is supported in your area).

    -- from CyberSimian in the UK
     

    404

    Portal Pro
    January 11, 2005
    307
    56
    Country flag
    I'd suggest trying EPG Collector, I've always had a complete guide when using that. For the last few versions of MP I've just had a white window when using channel preview audio works ok though so if I get that I know the channel in live TV will be OK, I don't really take much notice as it doesn't affect playback in any way.
     

    CyberSimian

    Test Group
  • Team MediaPortal
  • June 10, 2013
    2,301
    1,385
    Southampton
    United Kingdom United Kingdom
    Country flag
    I'd suggest trying EPG Collector,
    As I understand it, "EPG Collector" extracts the EPG from the data included with the TV transmissions. MP already has this built in to "TV Server" (it is what I use). But it won't work in the USA, as the TV transmissions don't include an EPG (at least, I think that that is the case).

    For the last few versions of MP I've just had a white window when using channel preview audio works ok though
    Strange. Channel preview in "TV Server" works OK for me for DVB-T/T2 channels. Since we are both in the UK, I would expect it to work for you too (for DVB-T/T2).

    audio works ok though so if I get that I know the channel in live TV will be OK, I don't really take much notice as it doesn't affect playback in any way.
    Yes, I agree. (y)

    -- from CyberSimian in the UK
     

    Users who are viewing this thread

    Similar threads
    OP Title Forum Replies Date
    LeeKelly Online Videos Breaks IPTV channels and scanning Installation, configuration support 1
    cbr954rr How to setup only german channels in online videos Plugin Development 13
    raffe Trailers via Youtube in Online Videos (for movies and maybe also TV-series) Feature Requests 0
    raffe [solved] [Solved] How to import TV series Videos Not in any online source? General 8
    A [solved] Video playback only successful after second attempt when returning from standby General Support 5
    bta489 Sometimes no image rendered when playing video watch/edit Videos 39
    S External player in MP2 and see videos made with my cam? General 8
    S Be able to see photos and videos together MediaPortal 1 Skins 1
    catavolt [solved] LMH - Wrong Video order Fanart Handler 27
    ajs [Bug] 5058: BlackScreen instead XMas Video :) MediaPortal 1 302
    rainbowforest MP2 - V2.3 Anmeldung Online Video (Streaming provider) Allgemeines Support- und Diskussionsforum 9
    doskabouter 1.26.0 Codec question (unable to play video, lv50 codec) Codecs, External Players 24
    Scheibes MP2 - V2.3 2. Client stops video on 1. Client Submit: Bug Reports 10
    S MP2 - V2.3 MP2 No video General 6
    P Nach Video Stream muss TVService beendet werden TV / Streaming 0
    O No Video playback on Media Portal 2.2.3 Newcomers Forum 2
    E 1.25.0 Change AVC / AAC Codec for Analog card captured videos Codecs, External Players 0
    N [not reproducible] Online videos not working at all Submit: Bug Reports 1
    R Bug: Video Folders disappear General Support 11
    Stephen O'Kane [SOLVED] TV Stream stuttering - both Video and Audio Watch / Listen Media 14
    B some music videos stutter Watch / Listen Media 0
    I 1.25.0 Videos in HEVC UHD 2160p don't play good watch/edit Videos 8
    CanadianEh MP TV server rebuild with Colossus 2 - Kodi clients receive PMT error when playing videos recoreded by Colossus 2 TV-Server 2
    Rob Hexenmeister Skinning Online Videos question OnlineVideos 2
    A [solved] How to Play All Videos in a List watch/edit Videos 3

    Similar threads

    Top Bottom