One Button Random Music? (1 Viewer)

findftp

MP Donator
  • Premium Supporter
  • September 20, 2011
    184
    35
    Nootdorp
    Netherlands Netherlands
    Yes, that's what i see.
    After OneButton added the songs and starts playback of the first song, i receive a Playback stop command, which causes the first song to stop and the second to start.
    But again, from the logs i don't see 2 songs playing at the same time, besides the Fading.

    Maybe you could turn off the "Fade out on Stop" and any Crossfading? just for a test
    Well, I disabled the stuff but now it happened again.
    2 songs mixed together,.... here is the log.
     

    findftp

    MP Donator
  • Premium Supporter
  • September 20, 2011
    184
    35
    Nootdorp
    Netherlands Netherlands
    This time something else happened. Not two songs mixed together, but when I pressed the play button on the start screen, there was a Van Halen song played, without the info popping up on the screen. I just heard the song, but no information. When I pressed stop, nothing happened, the song kept playing. I just let it play and captured the log remotely.
    While reading the log (which said there should be 99 songs) the song ended but there never came another song.

    I tried to google g.player to figure out what it got to do with playing music but could not find much about it.
    What's the purpose of g.player?

    This is the relvant piece of the log:

    [2015-03-05 22:48:52,391] [Log ] [MPMain ] [DEBUG] - Window: MediaPortal.GUI.Home.GUIHome init
    [2015-03-05 22:48:55,865] [Log ] [15 ] [INFO ] - OneButtonMusic: Adding 99 Random songs from the database
    [2015-03-05 22:48:55,905] [Log ] [15 ] [DEBUG] - MediaInfoWrapper: isVideo:False, isDVD:False[enabled:False]
    [2015-03-05 22:48:55,905] [Log ] [15 ] [DEBUG] - MediaInfoWrapper: disabled for this content
    [2015-03-05 22:48:55,906] [Log ] [15 ] [INFO ] - g_Player.Play(D:\shared\music\lossless\Van Halen - Studio Discography 1978 - 2012 [FLAC] [h33t] - Kitlope\Van Halen - A Different Kind of Truth 2012\09. The Trouble With Never - VAN HALEN.flac Music)
    [2015-03-05 22:48:55,907] [Log ] [15 ] [DEBUG] - PlayerFactory: Successfully created player instance for file - D:\shared\music\lossless\Van Halen - Studio Discography 1978 - 2012 [FLAC] [h33t] - Kitlope\Van Halen - A Different Kind of Truth 2012\09. The Trouble With Never - VAN HALEN.flac
    [2015-03-05 22:48:55,922] [Log ] [MPMain ] [INFO ] - g_Player.Process() player stopped...
    [2015-03-05 22:48:55,923] [Log ] [15 ] [INFO ] - BASS: ---------------------------------------------
    [2015-03-05 22:48:55,923] [Log ] [15 ] [INFO ] - BASS: Creating BASS audio stream
    [2015-03-05 22:48:55,923] [Log ] [MPMain ] [DEBUG] - g_Player.doStop() keepTimeShifting = False keepExclusiveModeOn = False
    [2015-03-05 22:48:55,924] [Log ] [MPMain ] [DEBUG] - g_Player.doStop() - stop
    [2015-03-05 22:48:55,925] [Log ] [MPMain ] [DEBUG] - BASS: Already stopped. Don't execute Stop a second time
    [2015-03-05 22:48:55,942] [Log ] [MPMain ] [DEBUG] - D3D: OnPaint()
    [2015-03-05 22:48:55,965] [Log ] [15 ] [INFO ] - BASS: Stream Information
    [2015-03-05 22:48:55,965] [Log ] [15 ] [INFO ] - BASS: ---------------------------------------------
    [2015-03-05 22:48:55,966] [Log ] [15 ] [INFO ] - BASS: File: D:\shared\music\lossless\Van Halen - Studio Discography 1978 - 2012 [FLAC] [h33t] - Kitlope\Van Halen - A Different Kind of Truth 2012\09. The Trouble With Never - VAN HALEN.flac
    [2015-03-05 22:48:55,967] [Log ] [15 ] [DEBUG] - BASS: Type of Stream: BASS_CTYPE_STREAM_FLAC
    [2015-03-05 22:48:55,967] [Log ] [15 ] [INFO ] - BASS: Number of Channels: 2
    [2015-03-05 22:48:55,968] [Log ] [15 ] [INFO ] - BASS: Stream Samplerate: 44100
    [2015-03-05 22:48:55,969] [Log ] [15 ] [DEBUG] - BASS: Stream Flags: BASS_MUSIC_FLOAT, BASS_MUSIC_DECODE, BASS_UNICODE
    [2015-03-05 22:48:55,969] [Log ] [15 ] [INFO ] - BASS: ---------------------------------------------
    [2015-03-05 22:48:55,970] [Log ] [15 ] [DEBUG] - BASS: Registering stream playback events
    [2015-03-05 22:48:55,970] [Log ] [15 ] [INFO ] - BASS: Successfully created BASS audio stream
    [2015-03-05 22:48:55,971] [Log ] [15 ] [INFO ] - BASS: ---------------------------------------------
    [2015-03-05 22:48:55,971] [Log ] [15 ] [DEBUG] - BASS: ---------------------------------------------
    [2015-03-05 22:48:55,971] [Log ] [15 ] [DEBUG] - BASS: Creating BASS mixer stream
    [2015-03-05 22:48:55,972] [Log ] [15 ] [DEBUG] - BASS: Found more output channels (6) than input channels (2). Check for upmixing.
    [2015-03-05 22:48:55,972] [Log ] [15 ] [INFO ] - BASS: No upmixing of Stereo selected
    [2015-03-05 22:48:55,972] [Log ] [15 ] [DEBUG] - BASS: Creating 2 channel mixer with sample rate of 44100
    [2015-03-05 22:48:55,977] [Log ] [15 ] [DEBUG] - BASS: Successfully created BASS Mixer stream
    [2015-03-05 22:48:55,977] [Log ] [15 ] [INFO ] - BASS: playback started
     

    findftp

    MP Donator
  • Premium Supporter
  • September 20, 2011
    184
    35
    Nootdorp
    Netherlands Netherlands
    g_player is the global player, which initiates ll other players.
    Can i get the full log please?
    Here you are.
    I must notice a few things because they might be related.

    Before I start mediaportal I always quit explorer.exe, it's done through a bat file.

    taskkill /f /im explorer.exe
    taskkill /f /im Taskmgr.exe
    start "" "C:\Program Files (x86)\Team MediaPortal\MediaPortal\MediaPortal.exe"

    I also noticed that there was an unknown user owner of all my music (security settings of folder) probably a legacy from the past. I've used this disk on other systems before.
    I repaired all my file rights.
     

    hwahrmann

    Development Group
  • Team MediaPortal
  • September 15, 2004
    4,542
    2,333
    Vienna, Austria
    Austria Austria
    Country flag
    Are you sure that the log is complete.
    the last thing i see is "Playback started" and then nothing else, which i can't believe.
     

    findftp

    MP Donator
  • Premium Supporter
  • September 20, 2011
    184
    35
    Nootdorp
    Netherlands Netherlands
    Are you sure that the log is complete.
    the last thing i see is "Playback started" and then nothing else, which i can't believe.
    It ended at "playback started" because I took the log right after it happened.
    Apparently the log continued 4 minutes later.
    Here is the continued log.
     

    hwahrmann

    Development Group
  • Team MediaPortal
  • September 15, 2004
    4,542
    2,333
    Vienna, Austria
    Austria Austria
    Country flag
    I don't see any error:

    Code:
    [2015-03-05 22:48:55,977] [Log    ] [15       ] [DEBUG] - BASS: Successfully created BASS Mixer stream
    [2015-03-05 22:48:55,977] [Log    ] [15       ] [INFO ] - BASS: playback started
    [2015-03-05 22:52:52,605] [Log    ] [BASS X-Fade] [DEBUG] - BASS: X-Fading out stream D:\shared\music\lossless\Van Halen - Studio Discography 1978 - 2012 [FLAC] [h33t] - Kitlope\Van Halen - A Different Kind of Truth 2012\09. The Trouble With Never - VAN HALEN.flac
    [2015-03-05 22:52:52,605] [Log    ] [31       ] [DEBUG] - BASS: End of Song D:\shared\music\lossless\Van Halen - Studio Discography 1978 - 2012 [FLAC] [h33t] - Kitlope\Van Halen - A Different Kind of Truth 2012\09. The Trouble With Never - VAN HALEN.flac
    [2015-03-05 22:52:52,606] [Log    ] [31       ] [DEBUG] - BASS: Reached end of playlist.
    [2015-03-05 22:52:52,607] [Log    ] [BassCommand] [DEBUG] - BASS: Stop of stream D:\shared\music\lossless\Van Halen - Studio Discography 1978 - 2012 [FLAC] [h33t] - Kitlope\Van Halen - A Different Kind of Truth 2012\09. The Trouble With Never - VAN HALEN.flac.
    [2015-03-05 22:52:52,610] [Log    ] [BassCommand] [DEBUG] - BASS: Disposing Music Stream D:\shared\music\lossless\Van Halen - Studio Discography 1978 - 2012 [FLAC] [h33t] - Kitlope\Van Halen - A Different Kind of Truth 2012\09. The Trouble With Never - VAN HALEN.flac
    [2015-03-05 22:52:52,610] [Log    ] [BassCommand] [DEBUG] - BASS: Disposing Mixer Stream
    [2015-03-05 22:53:05,935] [Log    ] [MPMain   ] [DEBUG] - Main: WM_POWERBROADCAST (PBT_POWERSETTINGCHANGE)
    [2015-03-05 22:53:05,936] [Log    ] [MPMain   ] [INFO ] - Main: The user activity timeout has elapsed with no interaction from the user
    [2015-03-05 22:57:40,579] [Log    ] [32       ] [INFO ] - OneButtonMusic: Adding 99 Random songs from the database
    [2015-03-05 22:57:40,619] [Log    ] [32       ] [DEBUG] - MediaInfoWrapper: isVideo:False, isDVD:False[enabled:False]
    Playback of Van Halen started at 22:48:55,977 and after the song, we have reached the end of playlist.
    Don't know why, but for some reason, BASS thinks there's nothing more to play.

    on 22:53:05, i got some Power Broadcast.
    At 22:57:40 new songs were added. Maybe you pressed Play again.
     

    ajs

    Development Group
  • Team MediaPortal
  • February 29, 2008
    11,878
    6,723
    Kyiv
    Ukraine Ukraine
    Country flag
    @findftp
    I have something similar, I launch an album to play, when it ends, starts Auto DJ. And after a couple of songs, it turns out like you. ie two songs simultaneously. Log files I will try to collect in the near future ...
     

    Users Who Are Viewing This Thread (Users: 0, Guests: 1)

    OP Similar threads Forum Replies Date
    framug 1.25.0 Modify native Irtrans buttons Remotes 10
    Patrik-See Spenden Button (Url) geht nicht mehr Allgemeines Supportforum 3
    T [solved] Green Button start MP not working....but box ticked in config. General Support 1
    wizard123 [solved] Auto sizing buttons to text content MediaPortal 1 11
    Rob Hexenmeister Navigation problems adding menu buttons to EPG General Support 1
    S Remote button to change audio and subtitle on / off General 10
    Rob Hexenmeister [solved] Latest Media Handler - skinning buttons Fanart Handler 19
    T How to add missing buttons IR Server Suite (IRSS) 0
    Rob Hexenmeister Video Buttons / Latest Media MediaPortal 1 Skins 7
    emphatic PC Power button on puts MediaPortal in Away Mode Remotes 5
    N [Finished] [MP2-789] MCE remote control Recorded TV and My Pictures buttons do not work MediaPortal 2 17
    Rob Hexenmeister Shutdown options General Support 0
    Wampus [MP2-752] Record-Button not working on the fly General 7
    S Pause button no longer works with MadVR in 1.19 General Support 4
    J Info button is virtually pressed with each button use in MePo 1.19 Remotes 8
    W "Enter" button no longer works General Support 26
    B [Finished] TV Guide Navigation Button Archive 0
    g0rsq Info box randomly popping up when watching TV or other video MediaPortal 2 Newcomers Forum 1
    H random black screen live tv and videos (amended) General Support 0
    RoChess Random GPU crash leads to MePo restart, but works fine afterwards MediaPortal 1 14
    N What do the series recording options mean, and why is MP2 recording random programs? General 3
    B Server service on the service monitor keeps stopping randomly. Client can't see server status. 2.2 Archive 5
    horned_reaper [solved] When playing music Fanart does not shuffle Fanart Handler 20
    horned_reaper [solved] When playing music Fanart does not appear immediately after downloading Fanart Handler 272
    horned_reaper [Music] 5012: Start current music track from the beginning Improvement Suggestions 21
    Similar threads

























    Top Bottom