OnlineVideos for MediaPortal 2 Alpha | Page 11

Discussion in 'OnlineVideos for MediaPortal 2' started by offbyone, March 4, 2012.

  1. morpheus_xx
    • Team MediaPortal

    morpheus_xx Lead Dev MP2

    Joined:
    March 24, 2007
    Messages:
    10,940
    Likes Received:
    4,708
    Ratings:
    +6,747 / 11
    Home Country:
    Germany Germany
    Show System Specs
    I've attached a test build here.



    The crash happens due to changed SharpDX version (2.6.2->2.6.3) in one of the recent weekly builds. We could also workaround this by adding AssemblyBinding redirects, but I compiled a fresh version.

    This version also includes a first pre-alpha-test support for BrowserHost based sites (Amazon Prime, Netflix). But those sites are not yet working correctly, AP needs a modified url handling and Netflix doesn't seem to work properly at all.
     

    Attached Files:

  2. Google AdSense Guest Advertisement



    to hide all adverts.
  3. mpirklbauer

    mpirklbauer Portal Pro

    Joined:
    May 7, 2011
    Messages:
    285
    Likes Received:
    7
    Ratings:
    +10 / 0
    Home Country:
    Austria Austria
    Show System Specs
  4. breese
    • Team MediaPortal

    breese Retired Team Member

    Joined:
    July 11, 2011
    Messages:
    3,903
    Likes Received:
    325
    Gender:
    Male
    Occupation:
    Sr. Systems Engineer
    Location:
    Arlington Heights, Illinois
    Ratings:
    +768 / 0
    Home Country:
    United States of America United States of America
    Show System Specs
    I installed this test version on my client.
    There are a few issues....

    [OnlineVideos] Error loading SiteUtils and Hosters: Could not load type 'OnlineVideos.IChoice' from assembly 'OnlineVideos, Version=2.1.0.0, Culture=neutral, PublicKeyToken=null'.

    [2015-12-29 17:18:40,720] [175742 ] [AMQ 'OnlineVideosWorkflowModel'] [WARN ] - [OnlineVideos] Error loading SiteUtils and Hosters: Method 'GetVideos' in type 'OnlineVideos.Sites.ABCUtil' from assembly 'OnlineVideos.Sites.corporategadfly, Version=1.1.0.3496, Culture=neutral, PublicKeyToken=null' does not have an implementation.


    About 30 Sites not found like this
    [OnlineVideos] SiteUtil with name: Orf not found!

    Then there is this.....

    [2015-12-29 17:19:42,095] [237117 ] [OVThumbs2] [INFO ] - [OnlineVideos] Invalid Image: 'http://www.discovery.com/radio/gallery/DiscoveryNewsNEW_logo.jpg' The remote server returned an error: (404) Not Found.
    [2015-12-29 17:19:52,020] [247042 ] [Thread83 ] [WARN ] - [OnlineVideos] System.Xml.XmlException: The 'hr' start tag on line 5 position 2 does not match the end tag of 'body'. Line 6, position 3.

    Server stack trace:
    at System.Xml.XmlTextReaderImpl.Throw(Exception e)
    at System.Xml.XmlTextReaderImpl.Throw(String res, String[] args)
    at System.Xml.XmlTextReaderImpl.ThrowTagMismatch(NodeData startTag)
    at System.Xml.XmlTextReaderImpl.ParseEndElement()
    at System.Xml.XmlTextReaderImpl.ParseElementContent()
    at System.Xml.XmlTextReaderImpl.Read()
    at System.Xml.XmlTextReader.Read()
    at System.Xml.XmlWriter.WriteNode(XmlReader reader, Boolean defattr)
    at System.Xml.XmlReader.ReadOuterXml()
    at RssToolkit.Rss.RssXmlHelper.ConvertToRssXml(XmlReader reader)
    at RssToolkit.Rss.RssDocumentBase.Load[T](XmlReader reader)
    at RssToolkit.Rss.RssDocumentBase.Load[T](String xml)
    at RssToolkit.Rss.RssDocument.Load(String xml)
    at OnlineVideos.Sites.GenericSiteUtil.Parse(String url, String data)
    at OnlineVideos.Sites.GenericSiteUtil.GetVideos(Category category)
    at System.Runtime.Remoting.Messaging.StackBuilderSink._PrivateProcessMessage(IntPtr md, Object[] args, Object server, Object[]& outArgs)
    at System.Runtime.Remoting.Messaging.StackBuilderSink.SyncProcessMessage(IMessage msg)

    Exception rethrown at [0]:
    at System.Runtime.Remoting.Proxies.RealProxy.HandleReturnMessage(IMessage reqMsg, IMessage retMsg)
    at System.Runtime.Remoting.Proxies.RealProxy.PrivateInvoke(MessageData& msgData, Int32 type)
    at OnlineVideos.Sites.GenericSiteUtil.GetVideos(Category category)
    at OnlineVideos.MediaPortal2.OnlineVideosWorkflowModel.<>c__DisplayClass14.<SelectCategory>b__c()
    at OnlineVideos.MediaPortal2.BackgroundTask.<>c__DisplayClass2`1.<Start>b__0()



    [2015-12-29 17:20:38,790] [293812 ] [OVThumbs1] [INFO ] - [OnlineVideos] Invalid Image: 'http://i2.cdn.turner.com/cnn/dam/assets/151127172925-the-33-movie-chilean-miners-top-tease.jpg' The operation has timed out


    [2015-12-29 17:22:21,240] [396262 ] [OVThumbs4] [INFO ] - [OnlineVideos] Invalid Image: 'http://cdn.playapi.mtgx.tv/imagecac...623/season/vlcsnap-2014-12-15-18h57m25s59.jpg' The operation has timed out



    Biggest one is when I went to play a video movie from the RedBull Site

    [OnlineVideos] Invalid Image: 'https://redbulltv.redbullmediabase....efall_show_landscape.jpg/width=798,height=532' A generic error occurred in GDI+.

    Application Envent Log

    Faulting application name: MP2-Client.exe, version: 2.0.0.1511, time stamp: 0x563dd824
    Faulting module name: ntdll.dll, version: 6.1.7601.19045, time stamp: 0x56258e62
    Exception code: 0xc00000fd
    Fault offset: 0x0002eb91
    Faulting process id: 0x1614
    Faulting application start time: 0x01d1428ed7f0e927
    Faulting application path: C:\Program Files (x86)\Team MediaPortal\MP2-Client\MP2-Client.exe
    Faulting module path: C:\Windows\SysWOW64\ntdll.dll
    Report Id: 3a25cad2-ae83-11e5-8f49-94de80fcab27
     
  5. ulischultz

    ulischultz Portal Pro

    Joined:
    September 16, 2009
    Messages:
    156
    Likes Received:
    2
    Location:
    Munich
    Ratings:
    +6 / 0
    Home Country:
    Germany Germany
    I searched everywhere, but the latest version of the onlinevideos plugin for MP2 I found here. It is from 2015.
    Is there any newer one?
    I found this:
    OnlineVideos
    But it seems not to be compatible with MP2!? Or is there any way to install it?
    Thanks!
     
  6. morpheus_xx
    • Team MediaPortal

    morpheus_xx Lead Dev MP2

    Joined:
    March 24, 2007
    Messages:
    10,940
    Likes Received:
    4,708
    Ratings:
    +6,747 / 11
    Home Country:
    Germany Germany
    Show System Specs
    There is no need to install this plugin manually, it is contained in every release.

    Gesendet von meinem SM-G930F mit Tapatalk
     
  7. Lehmden
    • Team MediaPortal

    Lehmden Retired Team Member

    Joined:
    December 17, 2010
    Messages:
    11,775
    Likes Received:
    2,143
    Gender:
    Male
    Location:
    Lehmden
    Ratings:
    +3,600 / 28
    Home Country:
    Germany Germany
    Show System Specs
    Hi.
    Yes, it is. OnlineVideos is part of the main MP2 installation since a very long time. So no need to download an external plugin at all. Simply install the latest MP2 and you will also have OV installed...
     
  8. ulischultz

    ulischultz Portal Pro

    Joined:
    September 16, 2009
    Messages:
    156
    Likes Received:
    2
    Location:
    Munich
    Ratings:
    +6 / 0
    Home Country:
    Germany Germany
    I see... However I only have some german channels in this version. No youtube for example. Is that normal? Is there any way to config the channels or get youtube running?
     
  9. Lehmden
    • Team MediaPortal

    Lehmden Retired Team Member

    Joined:
    December 17, 2010
    Messages:
    11,775
    Likes Received:
    2,143
    Gender:
    Male
    Location:
    Lehmden
    Ratings:
    +3,600 / 28
    Home Country:
    Germany Germany
    Show System Specs
    YouTube is listed under English (covering most languages including German) and is running without issues...
    You can configure the channels in MP2 settings > Plugin >OV. Settings for a special channel (like username and password for e.g. Amazon Prime) you can configure by "right clicking" (aka "info" button on the remote) on the channel logo in OV main view.
    In general all channels working in the MP1 version are also working in the MP2 version. But there are plenty of sites that are missing in general. Important for me would be "sportschau.de" or "funk.net" but as always there are not enough devs to implement all this...
    OV is extendable with site- dll that everyone with the needed skills can add. So if you are missing a site and you are able to do this, feel free to add the site by yourself. It would really be appreciated if you do... Sadly my skills are not enough so I'm not able to add missing sites myself...
     
  10. ulischultz

    ulischultz Portal Pro

    Joined:
    September 16, 2009
    Messages:
    156
    Likes Received:
    2
    Location:
    Munich
    Ratings:
    +6 / 0
    Home Country:
    Germany Germany
    Ok, it works now. Thank you!
     
  11. wkrueger38

    wkrueger38 Portal Member

    Joined:
    January 22, 2009
    Messages:
    19
    Likes Received:
    0
    Ratings:
    +0 / 0
    Hallo zusammen.
    MP 2.1.1 W10/64
    Bei mir verschwinden die Login-Daten für AmazonPrime.
    Hat jemand eine Idee?
    Danke für Eure Hilfe

    Problem ist gelöst.
     
    Last edited: October 26, 2017
Loading...

Users Viewing Thread (Users: 0, Guests: 0)

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice
  • About The Project

    The vision of the MediaPortal project is to create a free open source media centre application, which supports all advanced media centre functions, and is accessible to all Windows users.

    In reaching this goal we are working every day to make sure our software is one of the best.

             

  • Support MediaPortal!

    The team works very hard to make sure the community is running the best HTPC-software. We give away MediaPortal for free but hosting and software is not for us.

    Care to support our work with a few bucks? We'd really appreciate it!