OnlineVideos for MediaPortal 2 Alpha (2 Viewers)

morpheus_xx

Lead Dev MP2
  • Team MediaPortal
  • March 24, 2007
    11,390
    6,966
    Germany Germany
    Country flag
    I've attached a test build here.

    The crash happens due to changed SharpDX version (2.6.2->2.6.3) in one of the recent weekly builds. We could also workaround this by adding AssemblyBinding redirects, but I compiled a fresh version.

    This version also includes a first pre-alpha-test support for BrowserHost based sites (Amazon Prime, Netflix). But those sites are not yet working correctly, AP needs a modified url handling and Netflix doesn't seem to work properly at all.
     

    Attachments

    breese

    Retired Team Member
  • Premium Supporter
  • July 11, 2011
    3,903
    769
    61
    Arlington Heights, Illinois
    United States of America United States of America
    Country flag
    I installed this test version on my client.
    There are a few issues....

    [OnlineVideos] Error loading SiteUtils and Hosters: Could not load type 'OnlineVideos.IChoice' from assembly 'OnlineVideos, Version=2.1.0.0, Culture=neutral, PublicKeyToken=null'.

    [2015-12-29 17:18:40,720] [175742 ] [AMQ 'OnlineVideosWorkflowModel'] [WARN ] - [OnlineVideos] Error loading SiteUtils and Hosters: Method 'GetVideos' in type 'OnlineVideos.Sites.ABCUtil' from assembly 'OnlineVideos.Sites.corporategadfly, Version=1.1.0.3496, Culture=neutral, PublicKeyToken=null' does not have an implementation.


    About 30 Sites not found like this
    [OnlineVideos] SiteUtil with name: Orf not found!

    Then there is this.....

    [2015-12-29 17:19:42,095] [237117 ] [OVThumbs2] [INFO ] - [OnlineVideos] Invalid Image: 'http://www.discovery.com/radio/gallery/DiscoveryNewsNEW_logo.jpg' The remote server returned an error: (404) Not Found.
    [2015-12-29 17:19:52,020] [247042 ] [Thread83 ] [WARN ] - [OnlineVideos] System.Xml.XmlException: The 'hr' start tag on line 5 position 2 does not match the end tag of 'body'. Line 6, position 3.

    Server stack trace:
    at System.Xml.XmlTextReaderImpl.Throw(Exception e)
    at System.Xml.XmlTextReaderImpl.Throw(String res, String[] args)
    at System.Xml.XmlTextReaderImpl.ThrowTagMismatch(NodeData startTag)
    at System.Xml.XmlTextReaderImpl.ParseEndElement()
    at System.Xml.XmlTextReaderImpl.ParseElementContent()
    at System.Xml.XmlTextReaderImpl.Read()
    at System.Xml.XmlTextReader.Read()
    at System.Xml.XmlWriter.WriteNode(XmlReader reader, Boolean defattr)
    at System.Xml.XmlReader.ReadOuterXml()
    at RssToolkit.Rss.RssXmlHelper.ConvertToRssXml(XmlReader reader)
    at RssToolkit.Rss.RssDocumentBase.Load[T](XmlReader reader)
    at RssToolkit.Rss.RssDocumentBase.Load[T](String xml)
    at RssToolkit.Rss.RssDocument.Load(String xml)
    at OnlineVideos.Sites.GenericSiteUtil.Parse(String url, String data)
    at OnlineVideos.Sites.GenericSiteUtil.GetVideos(Category category)
    at System.Runtime.Remoting.Messaging.StackBuilderSink._PrivateProcessMessage(IntPtr md, Object[] args, Object server, Object[]& outArgs)
    at System.Runtime.Remoting.Messaging.StackBuilderSink.SyncProcessMessage(IMessage msg)

    Exception rethrown at [0]:
    at System.Runtime.Remoting.Proxies.RealProxy.HandleReturnMessage(IMessage reqMsg, IMessage retMsg)
    at System.Runtime.Remoting.Proxies.RealProxy.PrivateInvoke(MessageData& msgData, Int32 type)
    at OnlineVideos.Sites.GenericSiteUtil.GetVideos(Category category)
    at OnlineVideos.MediaPortal2.OnlineVideosWorkflowModel.<>c__DisplayClass14.<SelectCategory>b__c()
    at OnlineVideos.MediaPortal2.BackgroundTask.<>c__DisplayClass2`1.<Start>b__0()



    [2015-12-29 17:20:38,790] [293812 ] [OVThumbs1] [INFO ] - [OnlineVideos] Invalid Image: 'http://i2.cdn.turner.com/cnn/dam/assets/151127172925-the-33-movie-chilean-miners-top-tease.jpg' The operation has timed out


    [2015-12-29 17:22:21,240] [396262 ] [OVThumbs4] [INFO ] - [OnlineVideos] Invalid Image: 'http://cdn.playapi.mtgx.tv/imagecac...623/season/vlcsnap-2014-12-15-18h57m25s59.jpg' The operation has timed out



    Biggest one is when I went to play a video movie from the RedBull Site

    [OnlineVideos] Invalid Image: 'https://redbulltv.redbullmediabase....efall_show_landscape.jpg/width=798,height=532' A generic error occurred in GDI+.

    Application Envent Log

    Faulting application name: MP2-Client.exe, version: 2.0.0.1511, time stamp: 0x563dd824
    Faulting module name: ntdll.dll, version: 6.1.7601.19045, time stamp: 0x56258e62
    Exception code: 0xc00000fd
    Fault offset: 0x0002eb91
    Faulting process id: 0x1614
    Faulting application start time: 0x01d1428ed7f0e927
    Faulting application path: C:\Program Files (x86)\Team MediaPortal\MP2-Client\MP2-Client.exe
    Faulting module path: C:\Windows\SysWOW64\ntdll.dll
    Report Id: 3a25cad2-ae83-11e5-8f49-94de80fcab27
     

    ulischultz

    Portal Pro
    September 16, 2009
    156
    8
    Munich
    Germany Germany
    I searched everywhere, but the latest version of the onlinevideos plugin for MP2 I found here. It is from 2015.
    Is there any newer one?
    I found this:
    OnlineVideos
    But it seems not to be compatible with MP2!? Or is there any way to install it?
    Thanks!
     

    morpheus_xx

    Lead Dev MP2
  • Team MediaPortal
  • March 24, 2007
    11,390
    6,966
    Germany Germany
    Country flag
    There is no need to install this plugin manually, it is contained in every release.

    Gesendet von meinem SM-G930F mit Tapatalk
     

    Lehmden

    Retired Team Member
  • Premium Supporter
  • December 17, 2010
    12,069
    3,681
    Lehmden
    Germany Germany
    Country flag
    Hi.
    Is there any newer one?
    Yes, it is. OnlineVideos is part of the main MP2 installation since a very long time. So no need to download an external plugin at all. Simply install the latest MP2 and you will also have OV installed...
     

    ulischultz

    Portal Pro
    September 16, 2009
    156
    8
    Munich
    Germany Germany
    I see... However I only have some german channels in this version. No youtube for example. Is that normal? Is there any way to config the channels or get youtube running?
     

    Lehmden

    Retired Team Member
  • Premium Supporter
  • December 17, 2010
    12,069
    3,681
    Lehmden
    Germany Germany
    Country flag
    YouTube is listed under English (covering most languages including German) and is running without issues...
    You can configure the channels in MP2 settings > Plugin >OV. Settings for a special channel (like username and password for e.g. Amazon Prime) you can configure by "right clicking" (aka "info" button on the remote) on the channel logo in OV main view.
    In general all channels working in the MP1 version are also working in the MP2 version. But there are plenty of sites that are missing in general. Important for me would be "sportschau.de" or "funk.net" but as always there are not enough devs to implement all this...
    OV is extendable with site- dll that everyone with the needed skills can add. So if you are missing a site and you are able to do this, feel free to add the site by yourself. It would really be appreciated if you do... Sadly my skills are not enough so I'm not able to add missing sites myself...
     

    wkrueger38

    Portal Member
    January 22, 2009
    19
    0
    Hallo zusammen.
    MP 2.1.1 W10/64
    Bei mir verschwinden die Login-Daten für AmazonPrime.
    Hat jemand eine Idee?
    Danke für Eure Hilfe

    Problem ist gelöst.
     
    Last edited:

    Users Who Are Viewing This Thread (Users: 0, Guests: 1)

    OP Similar threads Forum Replies Date
    morpheus_xx [WiP] OnlineVideos: New browser based playback support using WebDriver, new Amazon siteutil MediaPortal 2 6
    bta489 [solved] System goes to Standby during Amazon Prime Playback OnlineVideos 2
    J Debug OnlineVideos, How To? OnlineVideos 1
    Predpray OnlineVideo 2 Probleme Allgemeines Support- und Diskussionsforum 12
    HTPCSourcer MP2 OnlineVideos Overhaul MediaPortal 2 46
    HTPCSourcer OnlineVideos is not remembering my sites MediaPortal 2 25
    P MP2 - V2.1 Bug - Onlinevideos U.S. Amazon Prime Fails to Connect Older releases 5
    E OnlineVideo Plugins - eigene Videostreams hinzufügen Plugins & Erweiterungen 0
    G Update von MediaPortal Installationsprobleme? 0
    ajs [News] MediaPortal 1 - 1.25 Released! News and Announcements 1
    horned_reaper Standby is prevented by MediaPortal client General Support 0
    U [solved] MediaPortal crashing on startup General Support 10
    g0rsq Info box randomly popping up when watching TV or other video MediaPortal 2 Newcomers Forum 1
    high [unanswered] Hallo möchte gerne Mediaportal. nutzen kann mich jemand anrufen? contactform feedback and requests 2
    ajs [News] MediaPortal 1.25 Pre-Release ready for testing! News and Announcements 0
    ajs [Rejected] Mediaportal Codename MediaPortal 1 41
    M 2nd (Touch-)Display Support on MediaPortal 2 such MPDisplay++? General 2
    N Steam release of MediaPortal MediaPortal 1 Talk 0
    torone Dritter versuch mit Mediaportal 2 Allgemeines Support- und Diskussionsforum 1
    M Fehlerhafter Link auf der aktuellen MediaPortal Seite Page- und Forumsfeedback 0
    H 1.24.0 MP 1.24 high CPU utilization when 'Keep MediaPortal always on top' option enabled Bugreports 4
    mickb [solved] Mediaportal Stops working General Support 5
    J [solved] Newbie to MediaPortal 2 - Cannot open/run TV programs Newcomers Forum 4
    atlantic How to use Spotify inside Mediaportal? Listen Music 18
    horned_reaper MediaPortal configuration error log message General Support 1
    Similar threads

























    Top Bottom